WordPress.org

Ready to get started?Download WordPress

Forums

running a website locally (5 posts)

  1. hope2
    Member
    Posted 3 years ago #

    I have set up xampp on my computer and did most of the things necessary to get it up and running with my real website's database and files but... only the home page is accessible. When I hover over any link the browser's status bar shows the correct url (http://localhost/test_site/sample-post) but I get sent to http://localhost/xampp. I can access wp-admin and edit post, etc. Can anyone tell me what I have to fix? Thank you very much.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Is mod_rewrite running?

  3. hope2
    Member
    Posted 3 years ago #

    I looked at the httpd.conf file and I believe mod_rewrite is running.

    LoadModule rewrite_module modules/mod_rewrite.so

    I wasn't sure about the AllowOverride so here is the way it is set:

    <Directory />
    AllowOverride None
    ...

    <Directory "C:/xampp/htdocs">
    AllowOverride All
    ...

    <Directory "C:/xampp/cgi-bin">
    AllowOverride None
    ...

  4. hope2
    Member
    Posted 3 years ago #

    I wish I knew what I did because it is now working. The settings in httpd.conf are as I stated and the only thing I did was open it, look, save, and restart Apache. ?????

  5. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Perhaps Apache just needed a kick? I've had that happen before now - especially running under Windows.

Topic Closed

This topic has been closed to new replies.

About this Topic