WordPress.org

Ready to get started?Download WordPress

Forums

RumGallery Problem (10 posts)

  1. MaxwellSmart
    Member
    Posted 9 years ago #

    Hi I've just installed RumGallery on WP 1.5 and am getting the following error:
    Warning: Cannot set time limit in safe mode in ...html/wp-content/plugins/RumGallery/gallery.php on line 2

    I am not running php in safe mode. Any suggestions?

  2. RummandDan
    Member
    Posted 9 years ago #

    Maxwell, ohh havent tried the gallery at all at php safe mode...

    You have to remove the line saying set_time_limit(.... at line 2...

    Try that :)

  3. MaxwellSmart
    Member
    Posted 9 years ago #

    Thanks - that worked but now I keep getting

    Warning: SAFE MODE Restriction in effect. The script whose uid is 516 is not allowed to access wp-content/gallery owned by uid 48 in wp-content/plugins/gallery.php on line 205
    Couldnt create directory, check file rights in directory wp-content/gallery)

    when as far as I can tell PHP is not running in safe mode. At least the ini file indicates that it is off....

    also i have set chmod to 777 on wp-content/gallery

  4. RummandDan
    Member
    Posted 9 years ago #

    It is for sure running in safe mode, hehe, if you have changed the inifile, you need to get the apache server restarted before the change is taken in action...

    Ill have to look into this error, Ill set my own server to run in safe mode tonight...

  5. MaxwellSmart
    Member
    Posted 9 years ago #

    Hi RummandDan,

    Thanks, I have restarted the server numerous times and the default for the ini was always set to not run in safemode.

    Could it be because I am using an older version of php?

    I've also got this silly Ensim thing running on my server so not sure if that is completely ignoring the ini. Possibily as it ignores a lot of the other standard configs.

  6. RummandDan
    Member
    Posted 9 years ago #

    Maxwell, i dont know about that "ensim" thing you mention, but make a page with the content <?php phpinfo(); ?>, in there you can see where the php.ini is located the php runtime is looking for...

    Search for:
    Configuration File (php.ini) Path

  7. MaxwellSmart
    Member
    Posted 9 years ago #

    Ok this is interesting, and sorry for getting off topic...

    If I VI the php.ini it indicates safe_mode = Off but when I run phpinfo under the heading "Configure Command" it says '--enable-safe-mode'.

    Does that mean my php.ini is being bypassed and safe mode is running?

  8. CrashX
    Member
    Posted 9 years ago #

    Seach the output of phpinfo() for "safe_mode". You're looking for the instance under the "PHP Core" heading. This will tell you if safe_mode is On or Off.

  9. RummandDan
    Member
    Posted 9 years ago #

    Maxwell you have to recompile php then... to disable it...

  10. MaxwellSmart
    Member
    Posted 9 years ago #

    I rebuilt the server as it was an old version of php, linux etc - everything is fine now. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.