WordPress.org

Ready to get started?Download WordPress

Forums

Ruined The Site by Changing File Permissions (11 posts)

  1. hectorlowe
    Member
    Posted 2 years ago #

    I am assisting a company that is running WordPress on a subdomain until the site is fully structured, at which point they intend to move it to their main domain.

    They are using the 'iFeature Pro' theme.

    When trying to use the CSS editor within the WordPress dashboard, I persistently ran up against an error message informing me that I needed to change the permissions on the style.css file. However, having done this, the WordPress dashboard still did not allow me use of the CSS editor.

    Using a quick Google search, I found a thread that advised me to bulk change all of the file permissions for every file in the theme folder. I did this, opting to use 766 permissions to be relatively versatile, without being too insecure.

    Unfortunately, something went terribly wrong. Suddenly the site became inaccessible on any level. The wp-admin dashboard, the index page, indeed everything associated with the website simply shows a blank page. Here is the blank site.

    Knowing that the only files altered were in two theme folders ('iFeature' and 'iFeaturePro'), I resigned myself to replacing both theme directories and starting from scratch.

    Unfortunately, this has had no effect. Certain folders in the directories (namely the 'library', 'includes', 'images', 'css' and 'core') refuse to be deleted, altered or replaced by their brand new counterparts. Consequently the site remains blank, I cannot access the WordPress dashboard, and I have no idea how to remedy the situation.

    Please help?

    Screenshot of my FTP program

  2. SNSD Photo
    Member
    Posted 2 years ago #

    how about files owner group ?

  3. peter achutha
    Member
    Posted 2 years ago #

    Change back your permissions. I think it is a system block. change your permission back to 644 or 755 and it should come back.

  4. hectorlowe
    Member
    Posted 2 years ago #

    I will try to change the permissions, but before I do I think it would be prudent to point out that the files in the theme directory are a mix of the original files (which I ruined) and some newer files (from attempting to re-upload the directory to replace the broken directory).

    The permissions for the entire directory are set to 755, which I believe is the default. However, individual files in that directory are set to 644 (also the default, as far as I am aware).

    Is your advice to select all of the files and folders (Cmd+A) within the directory and change them to 644? I only ask because this is what I initially did to cause an upset in the site (although at that time I was changing it to 766).

  5. peter achutha
    Member
    Posted 2 years ago #

    You can try 755 first or if the original setting was 644 you can try that first. If you have aback up you can restore form the backup and then change back the file permissions.

  6. hectorlowe
    Member
    Posted 2 years ago #

    Am trying to restore the theme by overwriting the current directory ('iFeaturePro'), but some folders refuse to be overwritten. My FTP program keeps repeating the following errors:

    550 /httpdocs/wp-content/themes/ifeaturepro/core/actions: Permission denied.
    
    500 Illegal PORT command.

    It claims "Upload Failed", "Cannot create folder actions", "Cannot create folder thumbs" etc.

    Here is a full transcript:

    150 Opening BINARY mode data connection for /httpdocs/wp-content/themes/ifeaturepro/sidebar.php
    226 Transfer complete
    NOOP
    200 NOOP command successful
    SITE CHMOD 644 /httpdocs/wp-content/themes/ifeaturepro/sidebar.php
    200 SITE CHMOD command successful
    TYPE I
    200 Type set to I
    PORT 192,168,1,8,200,184
    500 Illegal PORT command
    NOOP
    200 NOOP command successful
    SITE CHMOD 644 /httpdocs/wp-content/themes/ifeaturepro/single.php
    200 SITE CHMOD command successful
    TYPE I
    200 Type set to I
    PORT 192,168,1,8,200,185
    500 Illegal PORT command
    NOOP
    200 NOOP command successful
    SITE CHMOD 644 /httpdocs/wp-content/themes/ifeaturepro/style.css
    200 SITE CHMOD command successful
    QUIT
    221 Goodbye.

    Thank you for all your help so far; I hope we can resolve the issue soon!

  7. Michael
    Member
    Posted 2 years ago #

    Rename the directory 'iFeaturePro' to something else like 'iFeaturePro-Original' then create a new directory named iFeaturePro and try to restore your theme files to the new directory you created. If you still get an error uploading from then you'll have to review all the permissions from /wp-content down.

  8. peter achutha
    Member
    Posted 2 years ago #

    That's a good idea @michael

  9. hectorlowe
    Member
    Posted 2 years ago #

    Thanks, I'll give it a shot!

  10. hectorlowe
    Member
    Posted 2 years ago #

    The site seems to have come back - The CSS editor within the WordPress dashboard still states:

    You need to make this file writable before you can save your changes. See the Codex for more information.

    But I fear now that by trying to make said file writable (the very thing I was trying to begin with) I will end up ruining it again forever.

  11. peter achutha
    Member
    Posted 2 years ago #

    I am not sure but I am taking a guess.

    1. Your FTP account has no authorisation to modify files in that subdirectory.

    2. There may be a .htaccess file either at root level or at the theme subdirectory level that is blocking access to the file. You could test this by renaming the .htaccess file to myold.htacess or .htaccessOLD ... and see what happens. If it does not work restore the name back to .htaccess but you would need cPanel or Hepsia control panel to do that. Do you have administrator rights to your website control panel?

    Back up your site before you do anything, including the databases.

Topic Closed

This topic has been closed to new replies.

About this Topic