WordPress.org

Ready to get started?Download WordPress

Forums

WP Accessibility
[resolved] RTL bug (14 posts)

  1. Yakir Gottesman
    Member
    Posted 4 months ago #

    I just upgraded the plugin on an rtl website, and it made all the elements to ltr. It's not the first time there are issues with rtl. You should always test it also.

    https://wordpress.org/plugins/wp-accessibility/

  2. Joe Dolson
    Member
    Plugin Author

    Posted 4 months ago #

    Can you describe the issue, and provide a link to the site?

  3. Yakir Gottesman
    Member
    Posted 4 months ago #

    Very simple. After upgrading, my site turned LTR. I managed to fix it by body { direction: rtl; }.

    I disabled the plugin, so there is no use of a link.

  4. Joe Dolson
    Member
    Plugin Author

    Posted 4 months ago #

    Your entire site turned LTR? That's -- incredibly strange. WP Accessibility doesn't do anything to adjust the text direction; the only application of ltr/rtl in WP Accessibility is detecting what your site currently is (based on the language in WP config), and adding some classes to its own code on that basis.

    It would be helpful to see the issue; but I understand if you've chosen to disable the plug-in.

  5. Yakir Gottesman
    Member
    Posted 4 months ago #

    Look at this website. Same problem, and plugin is on.

    Link (temp)

  6. Joe Dolson
    Member
    Plugin Author

    Posted 4 months ago #

    It looks like the site's default language is English, so WP Accessibility is injecting the default language into the HTML tag. That's not at all new, however, so I don't know why that would have caused a change in an upgrade.

    However, you should turn that feature off; it won't help you with a multi-lingual site.

  7. Yakir Gottesman
    Member
    Posted 4 months ago #

    It's just a WPML feature, changing to English according to your browser language. Delete the /en/ from the URL to see the Hebrew site, which is LTR.

  8. Joe Dolson
    Member
    Plugin Author

    Posted 4 months ago #

    Yes. That's why I'm saying you should disable that feature in WP Accessibility; it's the only thing in WP Accessibility which has any impact on ltr/rtl behavior, and you can't benefit from it, because the setting it's based on is being overridden by WPML.

  9. Yakir Gottesman
    Member
    Posted 4 months ago #

    Come on, it only redirects. And the first install was Hebrew.

    Now I removed WPML, and it still has this issue. Did you check on a clean RTL WordPress installation?

  10. Joe Dolson
    Member
    Plugin Author

    Posted 4 months ago #

    I don't think you understand what I'm asking you to do; I don't want you to change anything about WPML. WPML is fine.

    Go to the WP Accessibility settings, and disable the option with the label "Add Site Language and text direction to HTML element".

  11. Yakir Gottesman
    Member
    Posted 4 months ago #

    It was turned off. Turning it on actually fixed the problem, but I don't think it is the right solution.

  12. Joe Dolson
    Member
    Plugin Author

    Posted 4 months ago #

    If turning that on fixed the problem, then WP Accessibility may not be the problem. What is the language attribute in your theme's header.php file?

  13. Yakir Gottesman
    Member
    Posted 4 months ago #

    I'll be damn. I tried to recreate the problem on a clean WordPress install, and it worked fine.

    I owe you an apology!

  14. Joe Dolson
    Member
    Plugin Author

    Posted 4 months ago #

    Quite all right. I'm glad it's something else!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.