WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] RSS Widget Error (36 posts)

  1. qofe
    Member
    Posted 7 years ago #

    Just upgraded to 2.2. All the widgets work fine *except* for the RSS widget.

    No matter what feed URL I insert, I get the same error message:

    "Error: could not find an RSS or ATOM feed at that URL."

    I've tried several valid feeds and I still get the same error. Here are links to the feeds I've tried:

    http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml
    http://www.thecitycook.com/misc/feed.xml
    http://www.policyinnovations.org/ideas/rss/feed.xml

    Any insight will be appreciated, thanks!

  2. jbrown3429
    Member
    Posted 7 years ago #

    I am having this exact same problem...

    HELP?!?!?!?!

  3. Trent Adams
    Member
    Posted 7 years ago #

    I am not 100% sure, but I think that widget will only use RSS, RSS2 and ATOM feeds and not strict XML feeds. Do those sites offer another format?

    Trent

  4. qofe
    Member
    Posted 7 years ago #

    XML is the language that RSS is written in... even if the feed URLs were changed to be ".rss" it shouldn't matter.

    I validated The City Cook feed in the Atom/RSS feed validator:
    http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fwww.thecitycook.com%2Fmisc%2Ffeed.xml

  5. djr3110
    Member
    Posted 7 years ago #

    I've been messing with the same problem as these guys, I tried to set up feeds using the rss widget on a number of servers and with a number of themes and nothing! All I get is a long delay as it save then the error - Error: could not find an RSS or ATOM feed at that URL.

    Does anyone know how to fix this or is the an alternative plugin?

  6. qofe
    Member
    Posted 7 years ago #

    I wondered if it was something on the server preventing access to feeds from external sources. But server settings are not something I'm very familiar with.

    I'm still holding out hope that someone with the answer will read this thread...

  7. drewsecret
    Member
    Posted 7 years ago #

    same problem no reply from anyone... struck me as odd that no one knows what is up with this..

  8. djr3110
    Member
    Posted 7 years ago #

    Yeh - searched and searched on this one and nothing? And still nobody knows what to do to fix it. Really really odd, I'd subscribe to the feed on this but IT DON'T WORK? If anyone can help it would really cool

  9. mellojoe
    Member
    Posted 7 years ago #

    What I have found for the couple of feeds that I use is to go to the main site of the feed you want (ie: nytimes.com) and then do an on-site search for RSS feeds.

    I currently use ESPN and CNN as my two feeds, and they work lovely.

  10. qofe
    Member
    Posted 7 years ago #

    Sorry mellojoe, but that's not what we're on about.

    We have valid RSS feed links, but the widget does not save them, it constantly gives us the previously mentioned error message.

    Someone out there must know why, and what to do to fix this... maybe...

  11. djr3110
    Member
    Posted 7 years ago #

    The way it looks like - I doubt anyone in cyber space or outer space can fix this one!

  12. qofe
    Member
    Posted 7 years ago #

    Yeah djr3110, it sure seems like it never really worked to begin with and no one wants to own up to it...

  13. kwikone
    Member
    Posted 7 years ago #

    Yeah, it looks like none of the developers are even looking at it. I really want to make use of it, but with the error message showing it is useless (although if you click on the image you do get the feed).

  14. cafeman
    Member
    Posted 7 years ago #

    Help! I have the same problem. I have three accounts on wordpress.com, all work. When I use the same feeds on my WordPress.org site installed and hosted by aplus.net, none of the feeds work - getting the same error message as you.

  15. cafeman
    Member
    Posted 7 years ago #

    Hi, a quick update. I thought maybe if I installed a different RSS Widget, I might get around the problem. So I downloaded the KB Advanced RSS Widget, installed and activated it and I get the same error. Except this time, the actual feed shows up on the page (see http://yo.landyo.us). Click on the feed and you can see it is up and running. The creator of this feed widget has this in his documentation:

    "An error has occured; the feed is probably down."
    This widget relies on WordPress's feed parsing abilities (look in wordpress/includes/rss.php). WordPress grabs the requested feed then passes it to this widget for formatting. If you are seeing this error, it means one of two things:

    1.) The feed really is down. Wait a while and try again.
    2.) WordPress's feed parser is screwed up. Try updating to the most recent version of WordPress. If that doesn't work, file a WordPress bug report in Trac.
    In the latter case, you may want to first try using the RSS widget that comes as a built-in widget. You'll probably get the same error there, since the KB RSS widget uses the exact same error-checking method.

    So, even though I believe aplus.net installed the latest and greatest version, I downloaded it and installed it and it made no difference. I'll be logging a bug for this issue.

  16. cafeman
    Member
    Posted 7 years ago #

    OK, I logged a bug here: http://trac.wordpress.org/ticket/4744. Incidentally, I mentioned I'm using aplus.net, perhaps that's the problem. Who are the other hosting providers for the guys having the same problem as me?

  17. qofe
    Member
    Posted 7 years ago #

    Hi Cafeman, thanks for the updated info, it's much appreciated. I'm using Dotster to host my blog.

  18. cafeman
    Member
    Posted 7 years ago #

    I may be narrowing down this problem, and I believe it is related to the companies where we're hosting WordPress. In my case, that's aplus.net. I hope you can read this from the knowledge base of aplus.net: http://www.apluskb.com/scripts/I_have_a_shared_hosting_answer3264.html. At the bottom it says:

    Important: All outbound connections going off our shared hosting servers are filtered out by a firewall system. Our administrators review all requests for firewall changes per user basis. If you’d like to connect to a specific RSS feed, please file a request via email to support@aplus.net including the following information:

    * Your Account Registration Number
    * The Domain Name you’d like to use the RSS Feed on.
    * The exact URL of the RSS feed you’d like to connect to.

    This implies that aplus.net blocks all incoming feeds. A support representative, through their chat system, asked me for specific IP and Port numbers so he could open up their firewall from my shared server to these RSS feeds. When I asked "what if I want to change/add feeds later" he said I needed to specifically open up the IP/Ports for any feed I want, which means the functionality of my blog is less useful because I cannot do feeds. That's another discussion.

    I didn't know the IP addresses and Ports. Two of the feeds I want come from blogs I host at wordpress.com, and I haven't thought of which others. But another one I wanted to try was the feed for this problem. So in a DOS window, I simply typed C> ping http://www.mycobalt.net and C> ping http://www.wordpress.org, and I got two IP addresses. In doing a google search, I found that the most common Port for RSS feeds is Port 80. So I gave him the two IP addresses and port 80. He says it should take a couple of hours and I'll get an email.

    So I hope to be able to tell you something definitive today. Stay tuned...

  19. cafeman
    Member
    Posted 7 years ago #

    Hi guys: Aplus.net opened ports for my blogs on wordpress.com and to this post. I used IP addresses as I found them (using the method in the above post) and "guessed" on the port number being 80.

    Go to my blog http://yo.landyo.us and you'll see that the RSS feed for MyCobalt, which is a blog hosted on wordpress.com, works like a charm. The other RSS feed, which is to this post, does not work. I believe the IP address is correct, but port 80 may not be the one used for these feeds. Don't know.

    The point is this: WordPress software works fine. It is your hosting partner closing these links. You need to contact them and determine how to open up those ports for your "shared" server. If you're on a dedicated server, then perhaps you can get them to open it up completely.

    The downside to this issue is that with any new RSS feed I want on my site, I have to have them open up the IP/Port to gain access. That severely limits my ability to add RSS feeds and I may decide to simply drop them altogether. Nonetheless, I believe we have solved this problem.

  20. cafeman
    Member
    Posted 7 years ago #

    Oops, quick update. The RSS feed for this discussion now appears on my blog, and so I suppose the port 80 for wordpress.org was accurately supplied to my hosting provider.

  21. cafeman
    Member
    Posted 7 years ago #

    Incidentally, I installed the "stats" plugin which requires an API key from wordpress.com. I had my hosting partner open a port to wordpress.com IP and port 80 - again, WORKS LIKE A CHARM!

  22. cafeman
    Member
    Posted 7 years ago #

    By the way, both the standard RSS Widget and KB Advanced Widget work.

  23. qofe
    Member
    Posted 7 years ago #

    Cafeman, thank you thank you!

    I'm going to mark this resolved 'cause now at the very least we know 'why'. We know what to do at our respective hosts.

    You sir, ROCK! :-)

  24. Adam Brown
    Member
    Posted 7 years ago #

    Hey, thanks for figuring that out. (I'm the author of KB Advanced RSS.) I've been getting people asking why they get that "An error has occurred" message. Since I couldn't replicate the problem, I just put that comment in the documentation (the comment you quoted earlier in this thread). I'll update the documentation to point to this thread.

  25. eventide
    Member
    Posted 7 years ago #

    Has anyone solved this issue for Lunarpages shared server hosting? Would appreciate some feedback on how to resolve this issue with them.

    I submitted a ticket to them about the opening of ports and I got a very generic response basically telling me it isn't their problem. :\

    I guess they don't care about losing the boatloads of clients I have referred.

  26. hanleo46
    Member
    Posted 6 years ago #

    So if I understand this, I have to go to my hosting company, and ask them to allow individual RSS URl's thru to my blog

    My host is 1and1.com....

    You got to be kidding!!

    Leo

  27. Slamlander
    Member
    Posted 6 years ago #

    Sites that won't give me unrestricted access to the Internet don't get my business. That said, how dare they!

    It gets worse, my hosts are behind NAT on dynamic IP that changes every 20 hours. Yes, I use DynDNS.Org. A Firewall setup like that would completely shut me out. I will not go to static IP because it would make me vulnerable to DDOS.

  28. njappboy
    Member
    Posted 6 years ago #

    I've run into this problem before and then I realized it was my own stupidity.

    I have quite a few WordPress mu blogs hosted on the same host, ip, domain. I never ran into this problem until setting up a new WordPress mu installation.

    After receiving this error a few times: "Error: could not find an RSS or ATOM feed at that URL." I finally realized I was unintentionally putting the 'feed url' in the RSS widget 'title' input field and I was putting the 'feed title' in the 'rss feed url' input field. Of course that would always produce and error.

    I just suggest you make sure you are putting the correct data into the correct fields...

  29. mojowen
    Member
    Posted 6 years ago #

    I've encountered this problem on a bash server I have root access to.

    Is there something I can change with bash or maybe php which would allow to allow wordpress to access feeds?

  30. Rudy64
    Member
    Posted 6 years ago #

    Wish I could help, but I'm not having much luck here either. I don't see this as being "resolved" either, as I'm using WP 2.3.2 freshly downloaded last week, and RSS feeds to my other WP blogs do NOT work.

    My first thought was a PHP config setting, allow_url_fopen, but I already have that set to "on". So that's not the issue. Our host does not use any firewalls that would block content, so that's not the issue either.

    I have three WordPress blogs on the same server at our host, and I can't link to any of them via RSS feeds. One is a "master" site from which the others spin off, so I like to put the most recent posts from the satellite sites on the home page in widgets.

    I cant' link to other WordPress blogs, but I *can* successfully show feeds from forums on other servers (at other hosts) that I visit. And other news sites work. I have the Commentaries area of PC Magazine working in sidebar as well.

    One thing I noticed is that the WordPress feeds only show a directory name, where the forum RSS (or Atom) feeds point to actual files or script parameters. (BUT, PC Magazine's feed is just a directory name, and it works!) It's almost amusing that WordPress can't find its own feeds. And yet, all of my WordPress feeds open fine in Feedreader, so they are indeed functional.

    If this is indeed a bug, it's like WordPress is not succcessfully "hunting" its own feeds...as all other RSS feeds I'm trying in my sidebars are working.

Topic Closed

This topic has been closed to new replies.

About this Topic