WordPress.org

Ready to get started?Download WordPress

Forums

RSS: .php -> .xml? (21 posts)

  1. adri
    Member
    Posted 9 years ago #

    I've only had WordPress installed for about...4 minutes. I'm coming to WP from Movable Type - on that system I had an RSS feed set up as /index.xml. On WP it's a .php file like everything else. Is there any way to get WP to generate a .xml? I already have readers who view my site through the /index.xml file, and it would be a pain to get everyone to switch.
    Thx.

  2. Anonymous
    Unregistered
    Posted 9 years ago #

    the simplest thing is going to be to rewrite requests to index.xml to the .php file
    I added the following to my wordpress rewrite rules in .htaccess
    RewriteRule ^index\.xml /journal/wp-rss\.php [R=301,L]

  3. clay
    Member
    Posted 9 years ago #

    hmm
    that was me
    RewriteRule ^index\.xml /journal/wp-rss\.php [R=301,L]

  4. clay
    Member
    Posted 9 years ago #

    Why does the forum always butcher the code I put?

  5. clay
    Member
    Posted 9 years ago #

    it should be back slashes where the funky encoding happened

  6. clay
    Member
    Posted 9 years ago #

    I should probably add that I assumed you had permalinks turned on and that you were using mod_rewrite
    A search around the forum will tell you how to do this

  7. clay
    Member
    Posted 9 years ago #

    ah.. thanks beel
    cept it should be
    RewriteRule ^index\.xml /journal/wp-rss\.php [R=301,L]

  8. adri
    Member
    Posted 9 years ago #

    Ah, thanks - got it working.

  9. djenyns
    Member
    Posted 9 years ago #

    I'm going to try this.

  10. djenyns
    Member
    Posted 9 years ago #

    I'm sorry I did this ..... I got it so I can rewrite the file in the perminlinks and now my whole blog is offline.

    How do I undo this
    RewriteRule ^index\.xml /journal/wp-rss\.php [R=301,L]

    that I typed into the perminiks box.

  11. Avenir
    Member
    Posted 9 years ago #

    Well, first off, you shouldn't type that into the Permalinks box. That's a mod_rewrite rewrite rule and should be entered directly into your .htaccess file. You should probably delete your .htaccess file, re-enter the permalink structure that you were using, remake the .htaccess file with the rules that WordPress generates (or have WordPress insert the rules for you by CHMOD'ing the .htaccess to something writeable by the server), and then add in that rewrite rule manually.

  12. djenyns
    Member
    Posted 9 years ago #

    My Yahoo IM is mrsil96_com
    Can you please help me fix this?
    I can't find the .htaccess file and I can even see the blog online.

  13. djenyns
    Member
    Posted 9 years ago #

    Can someone help me fix this?

  14. Avenir
    Member
    Posted 9 years ago #

    So you didn't even update the .htaccess file when you put that rewrite rule into the Permalinks box? Well then, that is another reason why your site isn't working at the moment.

    To access your .htaccess, you'll need to access your server with an FTP client first, and make sure that the FTP client is configured to show hidden files. This can usually be set in the preferences or options of the client, so look around. Once you do that, the .htaccess you want to look for is in the root of your WordPress install, or in the root of your server (if you're using the index-in-different-directory trick). If there's nothing there even though you've enabled hidden files with your FTP client, then your server doesn't have a .htaccess yet, so you can just create one.

    Either way, you'll want to either open up the .htaccess from your server or a new file in a plain text editor. Then enter in a Permalink structure following the rules on the Permalinks options page. Click the 'Update' button and then a bunch of text is generated in a box. Copy that to the file in your text editor and save it. If you're using a new file, save the file as .htaccess, that is, a file with no name, but an extension of .htaccess. Then upload that to your server. CHMOD it to something writeable by the server using your FTP client so that when you make further changes to the Permalinks or when you write new Pages, the structure will update itself automatically.

  15. djenyns
    Member
    Posted 9 years ago #

    I can't access the admin the blog is competely down.

    http://www.systemtradingblog.com

    Can you IM me?

  16. djenyns
    Member
    Posted 9 years ago #

    I am using WS_FTP LE. How do I configure to find the hidden file?
    what do I put in it?
    How do I get this blog back up?

    IM Yahoo.... mrsil96_com

  17. Avenir
    Member
    Posted 9 years ago #

    You don't need to access the admin. Start up your FTP client, enable hidden file-viewing if it isn't already, find the .htaccess file on your server, and then either delete it or rename it to a .txt file or something like that. That'll stop the error. I've had this problem before, and this is how I solved it.

    Once you've done that, follow the rest of my steps. You should be able to once the faulty .htaccess is removed.

  18. djenyns
    Member
    Posted 9 years ago #

    I am using WS_FTP LE how do I enable the hidden file viewing?

  19. djenyns
    Member
    Posted 9 years ago #

    Can I use another FTP file to view hidden files?

  20. Avenir
    Member
    Posted 9 years ago #

    I'm not familiar with WS_FTP, so I can't really help you there. I've used SmartFTP and FileZilla only, so my apologies. Try looking around in the options or preferences for something like 'Show hidden files.' If you can't find it, then WS_FTP might show hidden files automatically and you might not need to do anything. If you still can't find the option to enable and still can't see the .htaccess, then I suggest changing FTP clients. FileZilla is open-source and free, so I recommend it.

  21. In WS_FTP, right-click on the connection before logging on, select "properties", then select the "startup" tab. On this screen you shall see a box that says "Remote file mask". In this box place "-al", then log in.

    Or, read through this tutorial which shows you how to display hidden files with a number of FTP clients: http://www.tamba2.org.uk/wordpress/ftp/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.