WordPress.org

Ready to get started?Download WordPress

Forums

RSS Not Working. (8 posts)

  1. niccolls
    Member
    Posted 9 years ago #

    Okay, I have scoured the forums, but have not been able to put things together. I just got my WP installed in the last couple of days, but cannot get my RSS feed to work.

    http://college-search-blog.com/wp-rss2.php

    I get an error message everytime.

    Where should I begin to correct this issue?

    Thanks!

  2. jfriesen
    Member
    Posted 9 years ago #

    If you have the newest 1.5.1 version of WP, then have you applied this bug fix?

    http://fernando.dubtribe.com/archives/2005/05/10/solution-to-wp151-rss-errors/

    Hope that helps!
    JF ;)

  3. niccolls
    Member
    Posted 9 years ago #

    My line 136 looks like this:

    if ( ($client_last_modified && $client_etag) ?
    (($client_last_modified == $wp_last_modified) && ($client_etag == $wp_etag)) :
    (($client_last_modified == $wp_last_modified) || ($client_etag == $wp_etag)) ) {
    if ( preg_match('/cgi/',php_sapi_name()) ) {
    header('Status: 304 Not Modified');
    echo "\r\n\r\n";

    This is slightly different than the one found at the link you gave me. Will that work?

  4. Servant
    Member
    Posted 9 years ago #

    There are posts throughout this forum that a possible solution is deactivating your plugins and reactivating them one at a time, checking RSS feeds each time. Some plugins apparently have minor issues and need updates. In my case, besides applying the above fix, the deactivation/re-activation exercise cleared things up.

  5. niccolls
    Member
    Posted 9 years ago #

    I have been going through the forums for the last few hours. My site is new and I haven't activated any plugins yet. There are no active plugins according to my admin page.

    I applied the change from the above link and continued to get the same error message:

    "The XML page cannot be displayed
    Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.

    I appreciate your input.

  6. Niccolls, your only problem is an unknown character inside the title of your most recent post. See: http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fcollege-search-blog.com%2Fwp-rss2.php

  7. niccolls
    Member
    Posted 9 years ago #

    That was it. Thanks so much... that's a great tool!

    I appreciate your help!

  8. Glad to be of service. ^_^

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags