WordPress.org

Ready to get started?Download WordPress

Forums

RSS Not Showing Full Text (35 posts)

  1. Calophi
    Member
    Posted 7 years ago #

    I just upgraded my WordPress - mainly so that when I used full text in my RSS feeds, the more link would convert to, well, a more link. In my old version I had to manually put the more links in the excerpt.

    So I upgraded and everything seemed fine, but now my default wordpress feed = http://www.animejb.net/feed/ and frankly all my other feeds, ONLY display excerpts.

    My Options->Reading->Full Text for the Syndication feeds is on. I did have podpress installed but I've even deleted the folder from plugins and it still doesn't work.

    This is very perplexing, any suggestions?

  2. Chris_K
    Member
    Posted 7 years ago #

    Well... head back to Options -> Reading. See right below where you chose between Full Text or Summary? It says,

    Note: If you use the <!--more--> feature, it will cut off posts in RSS feeds.

    At first glance, it seems you are using the <!--more--> feature. So, if you don't want posts cut off, you may want to look at a plugin like this one.

  3. Calophi
    Member
    Posted 7 years ago #

    But that's just it, I want it to cut off posts at the more, but it's cutting them off WAY before. Check out my first two entries - that isn't where i put the more (I put it after the episode summaries).

  4. Chris_K
    Member
    Posted 7 years ago #

    What are you using to view the feeds?

    I see the first article, in the feed, show the "more" right at:

    Deianeira refers to it as the last Nodos, and says that inside it is the one kept by the Hero Tribe that they were searching for.

    Looking at the blog, that seems to match, yes?

  5. Calophi
    Member
    Posted 7 years ago #

    Wait, now it's working right, but not in my Firefox. I even cleared the cache! How rude!

  6. DoctorSetebos
    Member
    Posted 7 years ago #

    I'm having the same problem. Only, my issue is that I have the "full text" option turned on AND I'm NOT using the <!--MORE--> feature. I'm still only getting partial text in my RSS feed.

    http://evilavataranalysts.com/feed

  7. Barbayellow
    Member
    Posted 7 years ago #

    I have the same problem : wordpress 2.1, the "full text" option turned on, I am not using the <!--MORE--> feature neither and I am still getting partial text in my articles feed.

    Anybody can help ?

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    What are you using to determine that you're not getting the more text? Are you actually looking at the feed, or are you looking at the feed in Firefox or in some reader or something?

    Posting a link to the feed would be helpful as well.

    Also, if you're using feedburner, then I would suggest looking at your original feed or temporarily disabling the feedburner plugin for us, so that *we* can look at your original feed.

  9. Barbayellow
    Member
    Posted 7 years ago #

    I have disabled the feedburner redirection. My feed adress is http://blog.barbayellow.com/feed/atom/

    Thanks for your help

  10. paulroberts
    Member
    Posted 7 years ago #

    I get the same problem, Full text is selected and i don't use more, i'm looking at the feed in firefox (view source) also I'm getting a mess of unformatted text, all the html is stripped.

    I have this on 2 sites, it worked fine before i updated

  11. ryptide
    Member
    Posted 7 years ago #

    I'm having the same issue.

  12. solarcrash
    Member
    Posted 7 years ago #

    i'm having the same issue right now.

  13. paulroberts
    Member
    Posted 7 years ago #

    updated to 2.2 same story :(

  14. Roger
    Member
    Posted 7 years ago #

    Me too on 2.1. Upgrading one of my blogs to 2.2 in the hope this will resolve the issue.

    Its a problem on all my sites including my number 1 (see below)

    http://www.techwinter.com

    I have disabled the re-direct for now.

  15. Roger
    Member
    Posted 7 years ago #

    I have just decided to use the full-feed plugin that apparently addresses this issue.

    I looked to see if 2.2 addresses the issue but looking at 'Trac' I couldn't out if it does and apparently Paul is also struggling and he uses 2.2.

    I find it a bit shocking that so many have this problem yet somehow it wasn't addressed in 2.2. If this many people are having a problem its not random.

    Anyway if you want to see my site and see that it works now click the link above I won't be cheeky and add my website again as I know the Google Juice is good on this domain and I respect that.

    Thanks

  16. Mojofofofo
    Member
    Posted 7 years ago #

    I am using v2.2. I had to modify wp-includes/feed-rss2.php line 37. I changed the_excerpt_rss() to the_content_rss() and the feeds came out full-text after that.

  17. nabeelo
    Member
    Posted 6 years ago #

    I'm in 2.1 - any idea what php file to edit in our case?

  18. Stephen Cronin
    Member
    Posted 6 years ago #

    There should be no need to edit the files. Just use a plugin like the original Full Text Feed plugin which strips the more tag, or my DualFeeds plugin, which does the same, except it also creates a summary feed as well as the full text one.

  19. mrshl
    Member
    Posted 6 years ago #

    I'm having the same problem. There's no MORE tags in my feed (I've verified this). I've also tried the plugins you mention above. Nothing works.

  20. netjeff
    Member
    Posted 6 years ago #

    I'm having the same problems (v2.3.2). I've chosen "Full text" and I'm not using "more" tags, but the RSS feed still is truncating.

    I tried DualFeeds, but that still had the same symptoms.

    I finally fixed it by editing my wp-includes/feed-rss2.php as described above by Mojofofofo

    Any plans to fix this officially? Otherwise I assume I may have to keep "re-fixing" this with every release.

  21. trmanco
    Member
    Posted 6 years ago #

    I'm having this problem on one of my websites too.

    Its interesting, that on one site its ok, and on my second website the feeds are striped to 50 words with no html in it even with the full text option activated in wordpress.

    I have tried all the suggested above to fix this, but I didn't have any success

    Any ideas?

  22. Chris_K
    Member
    Posted 6 years ago #

    I'm sad that nobody claiming to have this issue remembers to share a link to their feed and mention HOW they're determining it is a short feed.

    If you're looking at it in Firefox, for instance, you'll only see it truncated -- but it isn't. View Source and you'll see the real feed you're sending.

  23. trmanco
    Member
    Posted 6 years ago #

    ok sorry for that...

    http://open-mania.com/rss

    It redirects to feedburner, and no I'm not using Firefox to read Feeds, I'm using newsfox and google reader, and they all display full feeds from other major blogs, like lifehacker and and downloadsquad.

  24. trmanco
    Member
    Posted 6 years ago #

    Has does anyone have a solution for this??

  25. trisweb
    Member
    Posted 6 years ago #

    This is a real bug, quite blatant. First noticed the problem when full posts weren't coming through to Facebook note importing, and also verified it by viewing source in Firefox, the RSS actually does have truncated excerpts only regardless of the setting in the options.

    This has nothing to do with the <!--more--> tag, absolutely nothing. The code in feed-rss2.php shows the bug pretty clearly, seems the excerpt is the only text being included regardless of the option setting.

    Mojofofofo's fix works great, but it's a hack. Can we fix this in the main WP trunk please? It's been a long long time. Is there a bug open?

  26. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    This has nothing to do with the <!--more--> tag, absolutely nothing. The code in feed-rss2.php shows the bug pretty clearly, seems the excerpt is the only text being included regardless of the option setting.

    No, it's not, it's just that people are not actually looking at the feed and only seeing it in Firefox or whatever.

    WordPress's full text feed WORKS.

    Look closer at feed-rss2.php. Here's the relevant code:

    <?php if (get_option('rss_use_excerpt')) : ?>
    		<description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
    <?php else : ?>
    		<description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
    	<?php if ( strlen( $post->post_content ) > 0 ) : ?>
    		<content:encoded><![CDATA[<?php the_content() ?>]]></content:encoded>
    	<?php else : ?>
    		<content:encoded><![CDATA[<?php the_excerpt_rss() ?>]]></content:encoded>
    	<?php endif; ?>
    <?php endif; ?>

    That's a complex piece of code, so let's make it simpler, so that everybody can understand it.

    if (we're using summary feeds) {
       Show <description>EXCERPT HERE</description>
    } else {
       Show <description>EXCERPT HERE</description>
       if (the post content is not empty) {
         Show <content:encoded>CONTENT HERE</content:encoded>
       } else {
         <content:encoded>EXCERPT HERE</content:encoded>
       }
    }

    See? The idea is that the description tag always contains the excerpt, while the content:encoded tab has the full text in it. Firefox always shows the description. Every real feed reader on the planet uses the content:encoded if/when it is available.

    WordPress does NOT have a bug here. You don't need to do any workarounds. Really. Just enable the Full Text mode in the settings. The setting works correctly and exactly as it is supposed to work.

  27. cwapshere
    Member
    Posted 6 years ago #

    This is happening to me too on 2.3.2. It's certainly got nothing to do with firefox as it's same in IE and Outlook.

    http://www.wapshere.com/missmiis/?feed=rss

    Like the others here I have selected "full text" under options -> reading, and I'm not using <!--more-->.

    I made the change descibed above to the rss2 file and now that feed is working correctly.

    http://www.wapshere.com/missmiis/?feed=rss2

    I would definitely call that a bug!

    Carol

    PS Looks like there is some sort of firefox issue, but I was also testing this in IE and Outlook, and changing that line has fixed the problem.

  28. mnol
    Member
    Posted 6 years ago #

    For folks using feedburner, and the feedburner feedsmith plugin:

    I was struggling with this issue for a while, but was able to fix the problem without doing any php revisions.

    The problem was that in feedburner, I had set my wordpress feed location to http://www.naturalcondition.com/?feed=rss2. For some reason, feedburner doesn't handle that location correctly, and only grabs the description. I changed the feedburner location of my feed to http://www.naturalcondition.com/feed/ (and http://www.naturalcondition.com/comments/feed/ for comments) and feedburner began grabbing the full-text feed.

    I realize not everyone here uses feedburner, but this might help some people.

  29. trmanco
    Member
    Posted 6 years ago #

    mnol

    I don't know what to say... but.. a.. a..

    YOUR A GENIUS!!

    Finally I have full feed on my blog

    Everyone who doesn't have full feeds even tho you have that option checked, try this and it will solve your problem :D

    Thank you, for sharing this

  30. patternsofchaos
    Member
    Posted 6 years ago #

    This is definitely a bug. Just looking at the code shows that it was mis typed. Follow the logic of the code:

    if (get_option('rss_use_excerpt'))
    // output the_excerpt_rss
    else
    // output the_excerpt_rss

    So the code, as provided, outputs the EXCERPT no matter what your settings are.

    Very big problem to users, very small effort to change. I'm just wondering why it isn't fixed?

    Is there somewhere to report bugs?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags