WordPress.org

Ready to get started?Download WordPress

Forums

RSS not displaying full text (7 posts)

  1. brittanie
    Member
    Posted 8 years ago #

    Although I have it set to do so in my dashboard, RSS 2.0 is not showing the full content, only the excerpt. What gives?

  2. saiajin
    Member
    Posted 8 years ago #

    when specifying the rss feed address use this format:

    http://www.example.com/?feed=rss2

    the 2 on the end did it for me

  3. scootersnoop
    Member
    Posted 8 years ago #

    squooze my ignorance, but I know very little about html etc. I have the same issue, my site http://www.scootersnoop.com is only sending out a summary rss even though I have selected "Full feed".
    In the answer above, where exactly to I stick that '2'?

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    scooter: Umm.. No, your site appears to send a full feed. At least, the full content of your posts is in the RSS that I get back.

  5. baudesign
    Member
    Posted 7 years ago #

    I have exactly the same problem as brittanie on
    http://magazine-audio.com/feed/

    I thought for a moment that this would have something to do with my template, showing the_excerpt instead of the_content, but no.

    Any idea?

  6. baudesign
    Member
    Posted 7 years ago #

    Well, I do not get it. With Firefox internal Feed reader, I get the summary. With Netvibes, I get the summary (But I get the complete text reading Gizmodo!?).

    But then, when I use the Sage plug-in in Firefox, this thing can see the whole content, or the summary, when I switch the option in the Control Panel of my WordPress site. In other words, only Sage works fine.

    Pfff!

  7. nashife
    Member
    Posted 7 years ago #

    My friend helped me with a solution. I'm not sure if this is kosher or whatever, but we edited my wp-rss2.php file and changed the following:

    In the section of php if() else() statements where it's saying, <?php if (get_settings('rss_use_excerpt'), we changed the contents of the <description> after the 'else' statement.

    My change was this: <description><![CDATA[<?php the_content('', 0, '') ?>]]></description>

    We did this ONLY for the 'description' tag after the else statement.

    Then, make sure you choose the "full text" setting in your wordpress control panel.

Topic Closed

This topic has been closed to new replies.

About this Topic