WordPress.org

Ready to get started?Download WordPress

Forums

RSS link? (16 posts)

  1. kensav
    Member
    Posted 9 years ago #

    What is the URL of my rss feeds after I setup WP?
    http://www.kensavage.com/wp-rss2.php isn't a feed with .xml at the end of it like I would need for some application.
    Any help?

  2. Belthasar
    Member
    Posted 9 years ago #

    Go here
    http://www.bigbold.com/rssdigest/index.html
    they will make some php output and you can put that on a site to link to your blog !! Hope that helped!!..
    ----
    http://www.art-fetish.net

  3. kensav
    Member
    Posted 9 years ago #

    all that does is make me link to another site.
    How do I get WP to output a .xml file for my rss feed?

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    WP doesn't make xml files as such, it creates them when needed ... sort of I think.
    If you had rewrite rules, the address would be /feed/rss2/
    I just used the above url of yours in Abilon, and it works just fine - I see Jake :)

  5. James
    Happiness Engineer
    Posted 9 years ago #

    WordPress does not maintain a static .xml feed. The php file (wp-rss2.php) generates the .xml feed once it is called. http://www.kensavage.com/wp-rss2.php is the URL of your feed and will be accepted and work properly in any RSS reading application or web-service.

  6. kensav
    Member
    Posted 9 years ago #

    thanks everyone for the help. WP rocks!!

  7. ezytodo
    Member
    Posted 9 years ago #

    The link given here (thanks very much) works but the link in my WP blog is the /feed/rss2/
    mentioned above.
    Do I need rewrite rules or can I insert this http://www.ezytodo.com/blog/wp-rss2.php
    somewhere (where, please?)?
    If I need rewrite rules, how do I do that?
    Thanks.

  8. ezytodo
    Member
    Posted 9 years ago #

    I made an htaccess file for the utility to block spam comments
    Do I have to add something to that or change, please?
    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /blog/wp-feed.php?category_name=$1&feed=$2 [QSA]
    RewriteRule ^category/?(.*) /blog/index.php?category_name=$1 [QSA]
    RewriteRule ^author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /blog/wp-feed.php?author_name=$1&feed=$2 [QSA]
    RewriteRule ^author/?(.*) /blog/index.php?author_name=$1 [QSA]
    RewriteRule ^([0-9]{4})/?([0-9]{1,2})?/?([0-9]{1,2})?/?([_0-9a-z-]+)?/?([0-9]+)?/?$ /blog/index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
    RewriteRule ^([0-9]{4})/?([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/(feed|rdf|rss|rss2|atom)/?$ /blog/wp-feed.php?year=$1&monthnum=$2&day=$3&name=$4&feed=$5 [QSA]
    RewriteRule ^([0-9]{4})/?([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/trackback/?$ /blog/wp-trackback.php?year=$1&monthnum=$2&day=$3&name=$4 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /blog/wp-feed.php?feed=$1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /blog/wp-feed.php?feed=$1&withcomments=1 [QSA]

  9. James
    Happiness Engineer
    Posted 9 years ago #

    When you made a change to your permalinks via Options/Permalinks, WordPress may have given you some changes to make to your .htaccess file. If it did, you need to make the changes. In order to find out, repeat the procedure for setting up your preferred permalinks again.

  10. ezytodo
    Member
    Posted 9 years ago #

    Sorry, this is the entire htaccess file - I did not have one as far as I am aware until I copied this text from the options/permalinks page.
    So now, in language suitable for someone that started with Word Press today and does not understand how the software works - just wants to use it, how do I set up an RSS feed that matches the Rss link that Word Press put on my blog
    OR
    how do I change the link that Word Press put on my blog to the (currently) correct one -
    http://www.ezytodo.com/blog/wp-rss2.php
    Thanks.

  11. James
    Happiness Engineer
    Posted 9 years ago #

    Slightly techie-english: The problem is that you have set up permalinks incorrectly. Click on a post title, you will see those 404 as well. Here's what you need to do. Go to Options/Permalinks enter the following, without quotes, in the first text field "/%year%/%monthnum%/%day%/%postname%/". Do not enter anything in the second text field. Hit the "Update Permalink Structure" button. You will notice that a text field now appears below the button. Copy what is now in the text field, usually starting with "RewriteEngine On" and paste it into your .htaccess file. Everything should work after that, let us know if it doesn't.
    Plain English: It just plain doesn't work, your system is messed up. Click on a post title, you will see those 404 as well. You need to make a few changes. Here's what you need to do. Go to Options/Permalinks enter the following, without quotes, in the first text field "/%year%/%monthnum%/%day%/%postname%/". Do not enter anything in the second text field. Hit the "Update Permalink Structure" button. You will notice that a text field now appears below the button. Copy what is now in the text field, usually starting with "RewriteEngine On" and paste it into your .htaccess file. Everything should work after that, let us know if it doesn't.

  12. ezytodo
    Member
    Posted 9 years ago #

    Thanks.
    Like MacArthur, "I shall return".

  13. ezytodo
    Member
    Posted 9 years ago #

    No, I'm probably still doing something wrong.
    The command you gave was already in the first box on the options/permalinks page
    I redid the "Update Permalink Structure" and copied the text from the bottom box again to the htaccess file on my PC, then put the .htaccess file in the wp-admin folder because that's what the address i saw when I held the mouse over the link for WP to edit it seemed to mean.
    But WP can't find it and I don't see any way to republish the blog which is what I would do with other programs I've used.
    This has the feel of being something very simple.
    It is also extremely frustrating.

  14. James
    Happiness Engineer
    Posted 9 years ago #

    If WP can't find it, then you need to make your own .htaccess file. Open NotePad, and copy the code it give you into that. Then, save the file as plain text file called "htaccess". Remove the .txt extension and upload it to your "blog" directory (folder). Once it's there, add a dot ( . ) in front of it. That should do it.

  15. ezytodo
    Member
    Posted 9 years ago #

    Thanks to all that responded to help me - the promptness and clarity of the posts is impressive but following th instructions in the post that Bell pointed out for me is probably not at my level.
    All is well and working now.
    I hope that I can return the favor for some other newbie in time to come.

  16. James
    Happiness Engineer
    Posted 9 years ago #

    Congrats! Glad to hear everything is up and running.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.