WordPress.org

Ready to get started?Download WordPress

Forums

RSS Import Fails w/ No Errors (6 posts)

  1. ddaniel
    Member
    Posted 5 years ago #

    Yes, this is a multi-post - I was informed that the post should be here rather than in the installation forum. So here goes:

    This is on a brand new install for a new site, and I've got an odd issue. I've performed the compulsory forum search with no success.

    I'm using the RSS import in WordPress. I'm seeing multiple issues. The issues center on a failed RSS import.

    The RSS import processes to the "All done, have fun" page, but no new posts exist (even though the RSS file has entries).

    So, I edited the RSS file so it would not be a properly crafted XML document. The import demonstrated the exact same behavior!

    If a non-XML file (IE, a random text file) is specified, the RSS import processes to the "All done, have fun" page, even though the file has no XML at all.

    I'd love to be able to get my past entries imported. Any thoughts? Again, this is a brand new deployment. I can successfully add new posts manually.

    Site Info:
    WordPress 2.6
    MySql 5.0
    PHP 5.2.6
    Windows Server 2003
    IIS 6.0

    Here's my
    Wordpress site
    and my Sample RSS , or you can pull your own from the RSS link on my top page.

  2. ddaniel
    Member
    Posted 5 years ago #

    bump.....

    no one?

  3. stanleydankoski
    Member
    Posted 5 years ago #

    ddaniel, have you figured this out? I'm running into the same issue.

  4. twilliampowell
    Member
    Posted 5 years ago #

    I'm receiving the same error on two different setups. rss.xml, up to 200KB. No errors, just the "All done, have fun"

  5. twilliampowell
    Member
    Posted 5 years ago #

    Okay. I have a solution that appears to work in Windows, if you have the rss.xml on a web server somewhere.

    Click browse, and type in the URL for the RSS feed on the webserver that it's on.

  6. twilliampowell
    Member
    Posted 5 years ago #

    I found an even better solution:

    - Go to Blogger.com
    - Click on "Settings" for your ftp blog.
    - Under the "Settings" tab, click "publishing"
    You'll see the following options

    Switch to: • blogspot.com (Blogger's free hosting service) • Custom Domain (Point your own registered domain name to your blog) • SFTP (secure publishing on your ISP server)

    - Click blogspot.com
    - Pick an arbitrary blogspot.com address, verify the word, and select [Save Settings].

    You should be able to import the converted blogspot.com blog using WordPress' Blogger import now.

Topic Closed

This topic has been closed to new replies.

About this Topic