WordPress.org

Ready to get started?Download WordPress

Forums

rss feeds -- strange 404 errors (5 posts)

  1. champignon
    Member
    Posted 9 years ago #

    Hi.

    I recently installed 1.5.

    I can pull up my feeds in Firefox and read the xml.
    I have subscribed to my wp-rss2.php feed in Thunderbird and it updates with new posts just fine.

    I tried to LiveJournal syndicate the same feed (multiple times) and got errors saying the feed was invalid or unavailable.

    So I went to two different feed validators, both of which returned a 404 error for the very same feed URL that I am refreshing in my browser and seeing with no problem:
    http://www.conditionsoccasionsfacts.com/wp-rss2.php

    Ideas?

    Thank you,
    Kristina

  2. Kafkaesqui

    Posted 9 years ago #

    This validates:

    http://www.conditionsoccasionsfacts.com/?feed=rss2

    Your problem with wp-rss2.php appears to be due to this bug:

    http://mosquito.wordpress.org/view.php?id=903

    Try downloading a fresh copy of wp-blog-header.php, and replace your current one with it:

    http://trac.wordpress.org/file/trunk/wp-blog-header.php?rev=2378&format=raw

  3. champignon
    Member
    Posted 9 years ago #

    Perfect! Thank you so much for your help.

    I didn't know about this url for the feed:
    http://www.conditionsoccasionsfacts.com/?feed=rss2
    so that's good to know.

    And the fresh copy of wp-blog-header.php fixed things right up.

    Thanks.

  4. rastamad
    Member
    Posted 9 years ago #

    Not in our blog's case. I've reported similar problems with our feeds not working properly. I employed the same solution Kafkaesqui provided, replacing the wp-blog-header.php file with the current one. The problem still persists, and the advise to me was to copy onto our server the feed files again.

    But this still doesn't work, although Bloglines is able to display our feeds properly now. With Firefox live bookmarks, feeds continue to "fail to load."

    Help please.

  5. rastamad
    Member
    Posted 9 years ago #

    Still trying to find solutons to our feed problems. In the bug report, there's mention of calling index.php?feed=rss2. Where do I do this? In wp-blog-header.php? Which part?

    I'm losing hope... =(

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags