WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] RSS feeds not working on brand new install? (5 posts)

  1. edwardv2
    Member
    Posted 8 years ago #

    I have set up my first blog and everything works fine (www.qdinformation.com/qdisblog/). I've now installed two additional full copies of WordPress in two other subdomains (www.qdinformation.com/searching/ and http://www.qdinformation.com/pharmanews/) following the directions for mutliple blogs with a single MySQL database making sure the wp-config.php is correct. I am able to post to and view both blogs, but the feeds are not working. One blog is located at http://www.qdinformation.com/searching/

    I've tried all the different types; myurl.com/feed/, myurl.com/feed/atom/, myurl.com/?feed=rss2, etc. in my browser (safari) and get error on line 10 at column 6: XML declaration allowed only at the start of the document

    When I try validating the feed http://www.qdinformation.com/searching/feed/ at feedvalidator.org it gives the following:

    It looks like this is a web page, not a feed. I looked for a feed associated with this page, but couldn't find one. Please enter the address of your feed to validate.

    Sorry

    This feed does not validate.

    line 3, column 0: Undefined root element: xhtml:html [help]

    <html xmlns="http://www.w3.org/1999/xhtml">
    line 10, column 0: XML parsing error: <unknown>:10:0: junk after document element [help]

    <?xml version="1.0" encoding="UTF-8"?>

    I'm totally confused. I also read through the support and found one suggest to get rid of "feed:" from the footer of the default installed theme and this didn't help either. Somehow it looks like the feed isn't even getting generated. I have no plugins installed and this is just the basic installation wih the default theme. I have made sure prmalinks is on and have edited the .htaccess file per instructions.

    Any help would be gretly appreciated.

    Ed

  2. Kafkaesqui

    Posted 8 years ago #

    Something is inserting this into your feed source:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <title></title>
    </head>
    <body>
    </body>
    </html>

    Actually, looking at the source of your home page shows it's inserting it everywhere.

  3. edwardv2
    Member
    Posted 8 years ago #

    Why would this be? As I stated this is a bare fresh install, no plugins or anything else. I've already tried deleting aboslutely everything and starting fresh a second time with the same results.

  4. Kafkaesqui

    Posted 8 years ago #

    If I knew... To start, what does the index.php in your searching/ directory (that particular WordPress' install) look like?

  5. edwardv2
    Member
    Posted 8 years ago #

    Problem solved. Well, it looks like some new software I was using for editing html and php automatically adds this to pages when it is saved if it doesn't see these tags (this is an option which I have now turned off). When I edited the wp-config file for multiple blogs it adds this to the end of the file when I saved it. Opening it back up I saw this was indeed the case. I deleted it and saved and now everything works fine.

    Thanks for your help, I really should have caught that myself. Your commetn got me thinknig in the right direction. Thanks again!

    Ed

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags