WordPress.org

Ready to get started?Download WordPress

Forums

RSS Feeds Not Working (46 posts)

  1. JessicaMessica
    Member
    Posted 6 years ago #

    I have noticed that I am not recieving any RSS feeds what so ever. I have another blog that I updated as well and that blog has no problems what so ever taking on rss feeds.

  2. SpeKopuZ
    Member
    Posted 6 years ago #

    I'm having the exact same problem after upgrading from 2.5 to 2.5.1.
    Any help?

  3. headsign
    Member
    Posted 6 years ago #

    I'm having this problem too. Isn't there any help?

  4. Chris_K
    Member
    Posted 6 years ago #

    And none of you included a link so that we might look for ourselves.

    *cough* *hint*

  5. headsign
    Member
    Posted 6 years ago #

    Sorry, HandySolo, you are right for this one but I included links in this post http://wordpress.org/support/topic/173856?replies=1 which cover the same topic.

    I now also found a workaround by tweaking the .htaccess but if you like, I can disable it for testing within a given timeframe.

  6. AmandaNoelle82
    Member
    Posted 6 years ago #

    Where is your feed not working? Mine works if I click on the RSS icon on my browser.

    However, the default RSS links that come with WordPress were not working for me (mine are in my footer). I noticed that http://www.amandanoelle.com/feed/ was now feed:http://www.amandanoelle.com/feed/ (same with comments feed). I removed the "feed:" in both instances by editing my footer, and now they work.

  7. headsign
    Member
    Posted 6 years ago #

    Amanda: my feed is not working when the link structure is like:
    domain.xx/myblogaddress/feed/feedtype/
    my feed is working when the link structure is:
    domain.xx/myblogaddress/?feed=feedtype

    The former wordpress version linked to the first type so that my few readers registered the first type of link. In the new version, the first type of link is broken and the second type works.

    I looks as though it is fixed but it is not, I just tweaked the .htaccess so that those people who registered my blog under the first type of address are now automatically sent to the second type of address. Nevertheless, it's still kaputt.

  8. MAHAROGERS
    Member
    Posted 6 years ago #

    Folks. I'm having the same issue. I'm getting feed errors again after having solved them a few weeks ago. My feed link is

    feed://feeds.feedburner.com/markrogersphotography/BVra

    Getting this error

    XML Parsing Error: xml declaration not at start of external entity
    Location: http://feeds.feedburner.com/markrogersphotography/BVra
    Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8"?>
    ^
    The problem last time was with a plug-in, which I deactivated

    Only two things have changed sincethen: I added an automatic upgrade plug-in and then I upgraded to 2.5.1.

    I've gone in and individually de-activated all plug-ins one by one, including the upgrade one and that didn't fix it. Now I'm trying to follow feedburners advice about checking for blank lines outside of <?...?> sections in my wp-config.php file, theme functions.php as well as my rss2.php and atom.php files.

    The only things that looks odd to me are that my wp-config.php file and functions.php files don't seem to have a closing ?> tags. I tried adding one to the end of the config file but that didn't do anything. Can someone look at the code below for each and let me know what to do? Specifically, if I need to add closing ?> brackets where exactly they should go?

    Thanks

    Config.php

    <?php
    // ** MySQL settings ** //
    define('WP_CACHE', true); //Added by WP-Cache Manager
    define('DB_NAME', 'blog');     // The name of the database
    define('DB_USER', 'abc');     // Your MySQL username
    define('DB_PASSWORD', '123'); // ...and password
    define('DB_HOST', 'mysql');     // 99% chance you won't need to change this value
    
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix  = 'wp_';   // example: 'wp_' or 'b2' or 'mylogin_'
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    
    /* Stop editing */
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    
    functions.php
    
    <?php if ( function_exists('register_sidebar') ) {register_sidebar();register_sidebar();}
    // Custom Header Image Support
    
    define('HEADER_TEXTCOLOR', '336');
    define('HEADER_IMAGE', '%s/img/header.jpg'); // %s is theme dir uri
    define('HEADER_IMAGE_WIDTH', 900);
    define('HEADER_IMAGE_HEIGHT', 180);
    
    function theme_admin_header_style() {
    ?>
    <style type="text/css">
    #headimg {
    	background:#fff url(<?php header_image() ?>) no-repeat center;
    	height: <?php echo HEADER_IMAGE_HEIGHT; ?>px;
    	width: <?php echo HEADER_IMAGE_WIDTH; ?>px;
    }
    #headimg h1{
    	margin:0;
    	padding: 10px 0 0 10px;
    	font-size: 1.8em;
    	font-variant:small-caps;
    }
    #headimg #desc {
    	margin:0;
    	padding:  10px 0 0 10px;
    	font-size: 1em;
    	font-family:Tahoma, Verdana, Arial, Serif;
    }
    
    #headimg a {
    	text-decoration: none;
    }
    #headimg *
    {
    	color: #<?php header_textcolor();?>;
    }
    </style>
    <?php
    }
    function theme_header_style() {
    ?>
    <style type="text/css">
    #header
    {
    	background:url(<?php header_image(); ?>) no-repeat center;
    }
    #header *
    {
    	color: #<?php header_textcolor();?>;
    }
    </style>
    <?php
    }
    if ( function_exists('add_custom_image_header') ) {
    	add_custom_image_header('theme_header_style', 'theme_admin_header_style');
    }
  9. Chris_K
    Member
    Posted 6 years ago #

    @headsign

    Amanda: my feed is not working when the link structure is like:
    domain.xx/myblogaddress/feed/feedtype/
    my feed is working when the link structure is:
    domain.xx/myblogaddress/?feed=feedtype

    Did you change your Permalinks? What are they currently set to? Seems like you're trying to fix the symptom instead of the problem (or am I missing something?).

  10. MAHAROGERS
    Member
    Posted 6 years ago #

    Seems like we may have two separate issues going on this thread -- one that's 2.5.1-upgrade related and another tied to permalinks.

    HandySolo can you weigh in on both of them?

  11. Miguelthai
    Member
    Posted 6 years ago #

    I've got the same problem. I am also getting the same message about

    XML Parsing Error: xml declaration not at start of external entity
    Location: http://www.art-by-pla.com/blog/feed
    Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8"?>
    ^

    Site is: http://www.art-by-pla.com/blog

    I also recently updated version.php and rewrite.php per this post and no luck.

    http://wordpress.org/support/topic/172697?replies=9

    Any help would be greatly appreciated.

  12. JessicaMessica
    Member
    Posted 6 years ago #

    Sorry for the slow reply but it happens when I try to add an ATOM feed

    http://questions.vox.com/library/posts/atom.xml

    it keeps returning this message...
    Error: could not find an RSS or ATOM feed at that URL.

    am I doing something wrong maybe?

  13. libyano
    Member
    Posted 6 years ago #

  14. ventz
    Member
    Posted 6 years ago #

    Hey Everyone,

    So just like everyone else here, I ran into the same thing, and it *really* annoyed me because most of my friends use RSS to follow me (i mean come on, who uses the browser now a days -- we all do it from our cellphones ;)). Anyway, after busting my head for a few hours trying to learn how wordpress works, here's the solution to everyone's problem:

    http://vpetkov.net/blog/bugs/

    Let me repeat, SOLUTION HERE^^^

    Good luck. Feel free to comment here/email me if you need any more info/help.

  15. JessicaMessica
    Member
    Posted 6 years ago #

    I'm just a little confused by what you described in your post. Do I put a # in front of all the echo's or do I have to copy and paste that code into all my Feed files. I tried that way and it gave me an internal server error.

  16. JessicaMessica
    Member
    Posted 6 years ago #

    O.K. so I found it and added the # and it still doesn't work. Any other ideas? Or am I doing it wrong?

  17. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    ventz's "solution" is incorrect and will not work. WordPress does not have any "bug" with this section of code, and the feeds work fine. However, other things, such as plugins, can mess them up.

    For those of you getting the "XML Parsing Error: xml declaration not at start of external entity" error, then you have the Blank Line problem.

    Read this:
    http://feedvalidator.org/docs/error/WPBlankLine.html

  18. libyano
    Member
    Posted 6 years ago #

    Thanks otto42 i have disable all plugins and it works

  19. MAHAROGERS
    Member
    Posted 6 years ago #

    This is still not working for me. I've disabled all plug-ins one by one and checked all the files that the feed validator site recommends for extra spaces before or after tags.

    I really don't know what else to look for here. Any ideas?

  20. Miguelthai
    Member
    Posted 6 years ago #

    Interesting.

    With all of my plugins off, it does seem to work in Firefox but not in IE.

    In IE I end up seeing the actual xml code.

    After reactivating, I am seeing it work in Firefox still but unfortunately not IE.

    (I'm using IE6)

    I also did not find any blank spaces in my php files.

  21. Chris_K
    Member
    Posted 6 years ago #

    In IE6 I think you'll always expect to see XML though, right? (RSS is XML) Been a while since I tried to look at a feed with IE6 ...

  22. ventz
    Member
    Posted 6 years ago #

    ventz's "solution" is incorrect and will not work. WordPress does not have any "bug" with this section of code, and the feeds work fine. However, other things, such as plugins, can mess them up.

    I don't agree with you Otto. I have all my plugins disabled, the only thing I have is a custom theme. This is the case on all of the blogs that we run for different faculty and staff at my work. The RSS/Atom feeds do not work under Firefox and Safari. I am not sure under IE as I haven't personally checked. As soon as we commented out the <?xml line, everyone's feeds started working. I understand what the bigger problem is, but I didn't have time to look into it (about the blank lines before the xml declaration). This might not be a "nice" solution, but it is in fact A solution.

  23. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    I don't agree with you Otto.

    It's not a matter of agreement or not. His solution does not actually solve the problem at hand.

    A feed is an XML document, and so the XML prefix is actually required.

    Just because it works without it in some (note, not all) feedreaders does not mean that the problem has been solved. It may get you through some step somewhere, but it doesn't fix it because your feed is still invalid after you do this.

  24. ventz
    Member
    Posted 6 years ago #

    Yes, you are right, but it's a working "quick-fix" :) I do plan on looking into it eventually though. I am assuming here:

    <?php
    /**
     * RSS2 Feed Template for displaying RSS2 Posts feed.
     *
     * @package WordPress
     */
    
    header('Content-Type: text/xml; charset=' . get_option('blog_charset'), true);
    $more = 1;
    
    ?>
    <?php echo '<?xml version="1.0" encoding="'.   get_option('blog_charset').'"?'.'>'; ?>

    Maybe it's something in the header? I don't have any plug-ins enabled and I am not sure what else could be putting the empty spaces.

    CORRECTION: It's not, I played with that file. It's something else that's calling that one.

  25. ventz
    Member
    Posted 6 years ago #

    Otto,

    My apologies. After spending some time and really looking around I found out that it is my theme (beautiful_sunrise) that is doing the "breakage". I will try to find out why/where and post back.

  26. ventz
    Member
    Posted 6 years ago #

    I Finally found the *real* problem (it was in the Theme).

    So in the functions.php (in the Theme "Beautiful Sunrise" you have to find lines: "43", "70", and "71" (they are all blank) and remove them. Please find all 3 of them before you remove the 1st, as they will shift :)

    This fixes it.

    I am assuming that everyone else who has disabled their plugins and is STILL having a problem has the same type of problem with their theme -- take a look inside that file. I found that to be a problem with 14 of our users -- their functions.php file for their theme contained blank spaces between the <?php ... ?> lines.

  27. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Yep. A theme, a plugin, your text editor when you edit the wp-config.php file... These are the most common causes of this problem.

    Again, read this:
    http://feedvalidator.org/docs/error/WPBlankLine.html

  28. rawalex
    Member
    Posted 6 years ago #

    The main issue is that wordpress allows third party plugins to play around with the content of the rss feeds. Without a proper validation structure to be sure that the plugins in place are compatible with the current version of wordpress, you get all sorts of weird behaviors.

    Basically, any time you have a problem, turn off ALL your plugins and try again, then re-add them one at a time until you find the one that is breaking your stuff.

  29. t3ch33
    Member
    Posted 6 years ago #

    I didn't read through all of your posts, but just in case people are still having problems: I had the same problem. It was caused by a captcha plugin and probably my ftp program (I looked at the original file that I uploaded to the server and the garbage text was not there). Go through your files and make sure that there is no garbage text at the beginning of your files or wherever the error says the text is located.

    It drove me crazy at first, because it only happened in Opera and I know for a fact that no changes were made to our files. Then, Google started rejecting all of our sitemap files that they had been successfully downloading for some time. I was literally about to start from scratch when I viewed the feed again after disabling the plugin. It was fixed!

  30. Anonymous
    Unregistered
    Posted 6 years ago #

    My site seems to have the same error. can not read the feed from feedburner and so on.

    https://feedburner.jp/fb/a/addfeed?sourceUrl=http://lumo.s67.coreserver.jp/wp/

    here is my wordpress
    http://lumo.s67.coreserver.jp/wp/

    wp 2.51 JP

Topic Closed

This topic has been closed to new replies.

About this Topic