WordPress.org

Ready to get started?Download WordPress

Forums

RSS Feeds keep returning 304 Not Modified, even when they have. (7 posts)

  1. admiraljustin
    Member
    Posted 8 years ago #

    On my site, the feeds keep returning 304 not modified, even showing old posts, even though the blog itself has the latest posts on it.

    Sample header convo:

    http://www.admiraljustin.net/feed/

    GET /feed/ HTTP/1.1
    Host: www.admiraljustin.net
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
    Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 300
    Connection: keep-alive
    If-Modified-Since: Fri, 22 Apr 2005 13:38:46 GMT
    If-None-Match: "de8e000af8fddd71455801d354352cca"
    Cache-Control: max-age=0

    HTTP/1.x 304 Not Modified
    Date: Sat, 23 Apr 2005 04:21:45 GMT
    Server: Apache/1.3.29 (Unix)
    Etag: "04785ad87d0e8d2189b80ce9e67d613b"
    X-Pingback: http://www.admiraljustin.net/xmlrpc.php
    X-Powered-By: PHP/4.3.10
    Last-Modified: Sat, 23 Apr 2005 03:38:19 GMT
    Keep-Alive: timeout=2, max=200
    Connection: Keep-Alive
    Content-Type: text/html
    ----------------------------------------------------------

  2. Kelson
    Member
    Posted 8 years ago #

    I've started seeing the same thing since upgrading from 1.5.0 to 1.5.1

  3. James
    Happiness Engineer
    Posted 8 years ago #

  4. Kelson
    Member
    Posted 8 years ago #

    Sorry, I thought I was searching. And those other threads... no mention of the 304 status, which is what I was searching on.

    Obviously these boards aren't for support. It must have been the word "support" in the URL or maybe "Troubleshooting" in the title that confused me. I'll be sure not to make the same mistake again.

    While you're at it... check the date on the original post by admiraljustin. It predates the bug (which, incidentally, I found in my second round of searching... before coming back here to helpfully post the info) by 2.5 weeks. I hope you're not admonishing him for not searching as well.

  5. James
    Happiness Engineer
    Posted 8 years ago #

  6. whooami
    Member
    Posted 8 years ago #

    ugh, nm

  7. James
    Happiness Engineer
    Posted 8 years ago #

    ugh, nm

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.