WordPress.org

Ready to get started?Download WordPress

Forums

RSS feeds don't work (7 posts)

  1. susanisk
    Member
    Posted 7 years ago #

    I am unable to subscribe to my blog's feed through any service (bloglines, google reader). I get messages such as, "No feeds were found. Please verify that the website publishes an RSS feed."

    Can anyone suggest a fix? My readers are frustrated (as am I).

    The link to my blog is: http://www.susanisk.com

  2. Chris_K
    Member
    Posted 7 years ago #

    Fixed?

    I subscribed to your feed via Google Reader.
    Read 10 posts.

    However... upon validating your feed, I see you have blank title and blank description elements.

    I'm going to guess that you thought leaving those blank at Options -> General would be a good idea. (Weblog Title and Tagline)

    Alas, 'tis not.

    I'd wager with proper values there, other feed readers will like your feed better.

    "But but but, that puts text over my custom header image!" you'll next exclaim.

    To which I'll reply, "Hide 'em. A quick search here will turn up how to hide those via one line of CSS."

    :-)

  3. susanisk
    Member
    Posted 7 years ago #

    Thank you for your reply. Unfortunately I have added a Weblog Title and Tagline and have hidden them. Bloglines is still unable to pick up any feeds. Any suggestions?

  4. Chris_K
    Member
    Posted 7 years ago #

    The validator is much happier now.

    It might take a bit for Bloglines to stop by and have a fresh look (all the big feed read services cache).

    Personally, I'd give it half a day to see what happens.

  5. oncidium
    Member
    Posted 7 years ago #

    My feeds seem to be a little wonky right now too but I have no idea how to fix it. http://www.divaknitting.com/blog/?feed=rss2

  6. Chris_K
    Member
    Posted 7 years ago #

    Well...

    #  <div id='error'>
    # <p class='wpdberror'><strong>WordPress database error:</strong> [Not unique table/alias: 'wp_post2cat']<br />
    # <code> SELECT SQL_CALC_FOUND_ROWS distinct wp_posts.*, wp_sticky.sticky_status FROM wp_posts  LEFT JOIN wp_post2cat ON (wp_posts.ID = wp_post2cat.post_id) LEFT JOIN wp_post2cat ON wp_post2cat.post_id = wp_posts.ID  LEFT JOIN wp_sticky ON wp_sticky.sticky_post_id = wp_posts.ID WHERE 1=1  AND wp_posts.ID NOT IN (105, 388, 389, 393, 394) AND (post_type = 'post' AND (post_status = 'publish')) AND wp_post2cat.category_id NOT IN (12) GROUP BY wp_posts.ID ORDER BY (wp_sticky.sticky_status = 2 AND wp_sticky.sticky_status IS NOT NULL) DESC, DATE_FORMAT(wp_posts.post_date,'%Y-%m-%d') DESC, (wp_sticky.sticky_status = 1 AND wp_sticky.sticky_status IS NULL) DESC, DATE_FORMAT(wp_posts.post_date,'%T') DESC LIMIT 0, 10</code></p>

    Looks like you have a sticky plugin running amuck.

  7. oncidium
    Member
    Posted 7 years ago #

    I disabled the wp-sticky plugin. Is that all I need to do? The feed still does not appear to be updating.

    I did make a change to the functions.php file (I noticed you mentioned that somewhere with another feed problem) I just added the code: `//exclude category 12

    function limit_feed() {

    if (is_feed() && !is_category()) {

    query_posts($query_string . "&cat=-12");

    }

    }

    add_action('rss2_head','limit_feed');

    //END exclude category 12` curtesy of otto42.

    The code does exclude category 12 but it seems like I've been having feed issues every since. However, when I remove it that doesn't fix the problem either. I updated my wordpress installation just to make sure that all the files are correct. Any other suggestions?

Topic Closed

This topic has been closed to new replies.

About this Topic