WordPress.org

Ready to get started?Download WordPress

Forums

RSS feeds and Comments Feeds not working (16 posts)

  1. meekiee
    Member
    Posted 9 years ago #

    I am not sure what happen to my RSS, it couldn't seem to open <http://meekness.net/blog/rss.xml> and <http://www.meekness.net/blog/wp-commentsrss2.php%22>

    I did follow a fewsteps to amend rss.php to rss.xml and atom.php to atom.xml. I am not sure if I have done all that correctly. I am not too certain with what others' described here as RSS is new term to me.

    Could any expert here help me to rectify the problems so I can resume the right feeds?

    Thank you in advance.

  2. Lorelle
    Member
    Posted 9 years ago #

    Which version of WordPress are you using?

  3. meekiee
    Member
    Posted 9 years ago #

    I'm using 1.5.1 version. I have even switched THEME but it would just show FEED, not registered protocol or something like that. I felt hopeless as I couldn't do much to help.

  4. First of all, you're not supposed to change the names of your feed files. You need to return your feed files to what they originally were. wp-rss2.php is a dynamically generated feed and will work exactly as it should and will not function when renamed. If you would like queries for files such as rss.xml to be redirected to your dynamically generated feeds, use this plugin: http://boren.nu/archives/2005/03/29/feed-director-plugin/

    Second, upgrade to WordPress v1.5.1.2. There were a few feed-related bugs in v1.5.1.

    Third, for "feed:" not being a registered protocol, see: http://wordpress.org/support/topic/29291#post-164887

    The most important thing right now is that you return your feed files to their original names and configurations, then upgrade to WP v1.5.1.2.

  5. meekiee
    Member
    Posted 9 years ago #

    Macmanx, I can't remember which file names have I changed as I just followed one suggestion from the thread.

    I recall the files as rss, atom and feed. Not sure if I'm right. So in another word saying, I just need to change the feed files into their original names, i.e. *.php?

    Thanks in advance.

  6. Just adding .php to the end of the files will not be enough. Again, they need to be the correct file names. The feed files are:

    wp-atom.php
    wp-commentsrss2.php
    wp-feed.php
    wp-rdf.php
    wp-rss.php
    wp-rss2.php

    Honestly, it's better to download WordPress again and cross-reference that against your site to find out which files you changed. Even better would be to upgrade to Wp v1.5.1.2 and overwrite/upload all WordPress files except those in /wp-content/.

  7. meekiee
    Member
    Posted 9 years ago #

    Macmanx, you mean to overwrite all the files except /wp content. Which means the theme file will be overwritten and I need to do a back up the coding on *.txt, so I don't need to worry about rewriting?

    I'm new in WordPress, doing a lot trial and error. I certainly appreciate your support here.

    Will try doing that soon and buzz you if I face any problems still. Not ethical to do it @ office. :)

    Thanks Mac!

  8. The theme files are supposed to be in /wp-content/themes/, that's why I said not to over-write /wp-content/. You should have no theme files in any other locations.

  9. I know these say that they're the upgrade instructions for 1.5-1.5.1, but they'll work for 1.5.1-1.5.1.2 as well if you need a guide: http://wordpress.org/support/topic/33189#post-187724

  10. meekiee
    Member
    Posted 9 years ago #

    I did all I can by following the instructions. Now it is showing

    Warning: main(/home/meekness/public_html/blog/wp-includes/wp-db.php): failed to open stream: No such file or directory in /home/meekness/public_html/blog/wp-settings.php on line 39

    Fatal error: main(): Failed opening required '/home/meekness/public_html/blog/wp-includes/wp-db.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/meekness/public_html/blog/wp-settings.php on line 39

    Do u hv any clue on this?

  11. Is there a wp-dp.php file in /blog/wp-includes/ ?

  12. meekiee
    Member
    Posted 9 years ago #

    There is wp-db.php not wp-dp.php. I have deleted every single files belong to blog root directory except wp-config.php & /wp-content. All new files from 1.5.1.2 are uploaded and replaced the old ones.

    Im trying to change http://meekness.net/blog/rss.xml on Theme Editor to http://meekness.net/blog/wp-rss.php. Do you think this shall help the feeds?

  13. meekiee
    Member
    Posted 9 years ago #

    Mac, yes it is working now by changing to wp-rss on the Theme Editor. However commentsrss2.php is still not working. I wonder why.

    I'm glad at least one of them is working now! :D

  14. Meekiee, there's an extra space or oddball character after the feed link in Sidebar.php, check it again. The link should be http://www.meekness.net/blog/wp-commentsrss2.php

  15. meekiee
    Member
    Posted 9 years ago #

    I missed the <"> before http. So it answers all the concerns.
    I think it's all running well now.

    Thank you so much and appreciate for your help.

  16. meekiee
    Member
    Posted 9 years ago #

    macmanx do you have any idea why one is showing the RSS feed on the lower right corner but another one's not. The sites are opened on the same Firefox browser but on different pc.

    Any clue?

Topic Closed

This topic has been closed to new replies.

About this Topic