WordPress.org

Ready to get started?Download WordPress

Forums

RSS feed won't validate (9 posts)

  1. budiselich
    Member
    Posted 9 years ago #

    I am struggling with my RSS feed. It will not validate. I have replaced all of the files (rss, rss2, atom, etc.) but that did not fix my problem. As far as I can tell what is wrong is the extra line entered at the first of my feed but I do not know what to do to get ride of it. Any suggestions?

    http://www.virtualtheology.org/wp-rss2.php

  2. NuclearMoose
    Member
    Posted 9 years ago #

    Have you seen this page:
    Validator info ?

  3. budiselich
    Member
    Posted 9 years ago #

    Yes! But I don't know what to do to fix my problem. I have changed the settings on the options menu in WP to ASCII. That didn't fix anything. I changed them back to UTF-8. That didn't fix anything either.

    I have figured out that the reason I am having problems is because of the extra line inserted at the front of the feed (notice it when you run it through the validator). But how do I get rid of the extra line? That is what I need to know. When running the feed through the validator it ought to have no blank line on the first line. Why does it have that? I think if I could get ride of that extra line the feed would work just fine.

  4. budiselich
    Member
    Posted 9 years ago #

    The problem I am having is when I try to validate my feed, an error occurs which says:

    <unknown>:2:0: xml declaration not at start of external entity

    An errant white space is being added on line one so the xml is invalid and the feed won't work.

    Well, I haven't heard anything yet and have spent some significant time on the IRC chan trying to get help. Podz and ryanduff were very helpful, but did not know what the problem was. Here is what I have tried:

    -reuploaded wp-includes and wp-admin folders
    -Added AddDefaultCharset to .htaccess file
    -Played around with UTF-8 and US-ASCII settings in the wp control panel, options, reading tab.
    -reuploaded all of the rss, rss2, atom, and rdf files with new, clean files.

    I think that is about it. I probably have done other things but just can't think of it right now. If there is anyone out there who has seen this problem and has some idea of what I could do, please let me know.

    Thanks.

  5. Ted
    Member
    Posted 9 years ago #

    Hello.

    I am also getting an error when I try to validate RSS:

    line 1, column 1: XML Parsing error: <unknown>:1:1: xml declaration not at start of external entity

    The line in question is:

    <?xml version="1.0" encoding="iso-8859-1" ?>

    Can anyone help? Thanks.

  6. Stedi
    Member
    Posted 9 years ago #

    After uppgrading to 1.5 the RSS2 feed does not validate anymore at feedvalidator.org.

    " pubDate must be an RFC-822 date"

    Also the language of the feed is marked "en". My feed is not. Can't find a place where to set the feed language.

  7. Stedi
    Member
    Posted 9 years ago #

    I found the reason why it does not validate.
    I use a fresh translated version (Finnish mo file). When I've translated the days Sun, Mon, Tue, Wed, Thu, Fri, Sat into Finnish version of them, that breaks the feed validation.
    This is a bug which I've reported in Mantis.

  8. davestinner
    Member
    Posted 9 years ago #

    To change the feed language, you can go into your database and do it there.

  9. shad
    Member
    Posted 9 years ago #

    I also noticed that when the feed date is translated, agregators and planet cant parse correctly the date and think that either the postdate is the time the feed was fetched or the 1970/01/01, this is only occur with the main rss feed , the comment one is ok.
    I rollback the the 1.2 way to print the date and that worked fine

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.