WordPress.org

Ready to get started?Download WordPress

Forums

[closed] RSS feed won't show Full Text (22 posts)

  1. Anonymous
    Unregistered
    Posted 6 years ago #

    I thought I posted this yesterday, but I must have forgotten - I recently upgraded to WP 2.6, and now my RSS-feed doesn't show full text - I'm not entirely sure that this is due to the upgrade, it might seem that it happened before, but I'm not sure.

    I've of course checked to see if "Full text" is chosen under settings, I've tried deactivating all plugins, I've testet the feed directly, through the feedvalidator.org, Bloglines and Feedburner - all show it as being a summary-feed, with the [...] at the end.

    This is farily annoying, as this means I won't get clickable links in the feeds, and that the feeds with links on the bottom of the post won't be shown, at least until someone clicks on the post directly.

    Is there something that has borked with a previous plugin? Is this a known bug in WP 2.6? Is there anywhere I can manually set the feed to always show full text, disregarding the choices made in the admin panel alltogether?

    Any help on this would be deeply appreciated!

  2. Binh
    Member
    Posted 6 years ago #

    Me too, I already enable full text feed but it just doesn't so full text. This problem seem to be long time ago, but I started to notice it recently.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Sigh.

    If you enabled full-text, then it is showing full-text. Really. No, really, we know what we're talking about here.

    The fact that you don't see the full text in Firefox or IE is not the issue here. Try it in a real feed-reader instead.

    If you know how to look at the feed directly, look at what is inside the <content:encoded> sections.

    And if you use FeedBurner, then you may want to check your settings on there.

  4. Rick Powell
    Member
    Posted 6 years ago #

    Sorry, but I am having the same problem. Have attempted to read the feed in Google Reader, Feedly, NetnewsWire, bloglines. Still shows only summaries. Unsubscribed, then subscribed. Same.

    I'm using feedburner but the service for providing summaries instead of full text is not active. I triple-checked this as well as quadruple-checked whether or not the wp 2.6 setting was specifying full-text. it is.

    I also see several posts in the forums with this problems and so far the first two pages of them indicate the issue is unresolved.

    suggestions? plug-in conflict?

  5. tlobf
    Member
    Posted 6 years ago #

    i am having exactly the same issue. using 2.6 too, full text is ticked on the reading options.. the really annoying and frustrating thing for me is in google reader, for example, i get full text. in IE, i get full text and in firefox i get the optional excerpt.

    now - i wouldnt normally mind to be honest, but i have just been made a partner in the new mog music network and my posts are all showing up as excerpts = http://mog.com/blog_post/content/106

    even when you click on one of the posts: http://mog.com/blog_post/content/106/181627 you still only see the excerpt.

    ive looked at other peoples sites within the mog network who use wordpress and their feeds are coming in fine - with pictures, plugins and everything.

    im 99.000% sure that feedburner is set up correctly - on 'optimize' its the Browser Friendly service right? The feed views great on my feedburner preview when im logged in...

    my site address is http://www.thelineofbestfit.com and my feedburner is http://feeds.feedburner.com/thelineofbestfit

    i have tried everything that the above people have suggested - and am having the exact same issues as rickpowell and PoPSiCLe

    please help!! :-)

  6. iridiax
    Member
    Posted 6 years ago #

    I've seen quite a few forum posts like these and the common denominator is usually that they are using feedburner. If you just can't get it fixed and you absolutely must have full feeds, then consider not using feedburner.

  7. tlobf
    Member
    Posted 6 years ago #

    ok - ive taken your advice and deleted my feedburner address.

    my feed is now at http://www.thelineofbestfit.com/feed

    to me - it's looking the same as it was on feedburner. and my posts are still coming in as excerpts here: http://mog.com/blog_post/content/106

    any ideas?

  8. MulderDSM
    Member
    Posted 6 years ago #

    I'm having the exact same problems with my feedburner feeds. I've checked both WordPress Options and Feedburner options both say full text and always have.

    http://www.livingdowntowndesmoines.com

  9. marywy2
    Member
    Posted 6 years ago #

    I'm having the same problem. New to WordPress so my only experience is 2.6 version, self-host. Full-text is checked, I don't use Feedburner. NetNewsWire, Google Reader and Vienna are giving excerpts only, no images, and an awful image "caption" line. I migrated from TypePad and never had a feed problem so hoping to find a solution here.

    http://www.redshiftblog.com

  10. marywy2
    Member
    Posted 6 years ago #

    I'm fixed. When I looked at the feed source it was defaulting to rss 0.92. I read on one of these forums that WP feeds would not display full text or images unless it was rss 2.0. I got the information from the theme support forum about how to make rss 2.0 the default for my blog.

    I never had this issue with TypePad. The feeds always displayed full text with images using rss 1.0. I'm so grateful to whoever posted this hint, buried among hundreds that I've scanned trying to find the answer. I hope it resolves this issue for some of you.

  11. alexgerv
    Member
    Posted 5 years ago #

    I still have the same problem, and when I check the xml source of my feed, it is clearly shown as RSS 2.0 yet only the excerpt is displayed...

  12. Digital Film
    Member
    Posted 5 years ago #

    Following marywy2's advice above - ensure you are pulling a 2.0 feed into feedburner - solved my problem right away. If you're also using the feedburner plugin, make sure that you get the RSS 2.0 feed address from there, not the default.

  13. Crul
    Member
    Posted 5 years ago #

    I'm having the exact same issue as everyone else here. However, I don't have feedburner installed, my rss version is at 2.0 and I have full text selected in the settings.

    Is there anything else I can do to fix this? From looking at the source it seems that the feed is only showing the description instead of showing the whole content.

    Any suggestions would be appreciated.

  14. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Argh!

    WordPress DOES show the full content if you have the full text feed turned on in Settings->Reading.

    Really. I'm not making this up. There is no bug here.

    Look at the code:

    <?php if (get_option('rss_use_excerpt')) : ?>
    		<description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
    <?php else : ?>
    		<description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
    	<?php if ( strlen( $post->post_content ) > 0 ) : ?>
    		<content:encoded><![CDATA[<?php the_content() ?>]]></content:encoded>
    	<?php else : ?>
    		<content:encoded><![CDATA[<?php the_excerpt_rss() ?>]]></content:encoded>
    	<?php endif; ?>
    <?php endif; ?>

    That says if you're set to only use the excerpt, then you only get the description. If you're set to use full feed, then you get both the description (which has the excerpt in it) AND the content:encoded (which has the full content). See that "the_content();" code? That is the FULL CONTENT.

    See? IT WORKS. Stop posting that it is broken, because IT'S NOT BROKEN. Really. No fooling.

    If you think it's not working, then you're doing it wrong.

  15. Crul
    Member
    Posted 5 years ago #

    fyi, I figured it out. You need to go into the feed-rss2.php file and make some changes.

    Incorrect code removed, because somebody else might break their feed this way too.

  16. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Crul: No, wrong, that is incorrect. The description should not contain the full content, it should contain the excerpt. The full content is in the content:encoded field.

    Your feed now contains two copies of the exact same thing, which it should not have.

  17. alexgerv
    Member
    Posted 5 years ago #

    Otto42 : Even if you say it works and that it's not broken, the fact remains that my rss doesn't show the full content of my post, so something is obviously broken somewhere...

  18. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    If it's a WordPress site and it is not showing the full text, then you don't have full text selected. Either that, or you're using FeedBurner and have something set wrong there.

    Without a link to your site, I can't look at it and tell you anything at all. Where's the site with the problem feed? Post a link.

  19. alexgerv
    Member
    Posted 5 years ago #

    It is a WordPress site but self-hosted on Dreamhost, my url is http://gervnet.com

    Again I checked and Full text is selected, I do use feedburner but I double checked and the source is the RSS 2.0 source, I tested with and without feedburner for every possible url for RSS 2.0 and everytime I got only the excerpt...

  20. sanju74
    Member
    Posted 5 years ago #

    I think I got the clue but do not know where to fix. In IE and Firefox the RSS feed contents come properly but I think Firefox does not process the <content:encoded> tag properly. If you see the view source you will see contents in both browser (IE and firefox) are same but firefox just process discription tag whereas IE process <content:encoded> .

  21. sanju74
    Member
    Posted 5 years ago #

    I am able to make a quick fix till I get proper solution. I removed the <description> tag from the else part and it fixed the problem. I know this is temperary fix. Can you guys tell me the proper way to fix this please?

  22. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    alexgerv: Your feed is showing the full content. There's nothing broken there. I'm looking at it, and it's fine.

    sanju74: There is no need to fix it because it is not broken. Firefox doesn't show the full content, but a REAL FEEDREADER will.

    Closing this, because all these bad solutions are just going to mess with people and make them screw up their feeds. WordPress is not broken, there's no need to fix anything. We've proven this, time and again.

    Let me try to make this perfectly clear:
    1. WordPress is NOT broken. The full text feed DOES WORK.
    2. The reason you think it's broken is because you're using Firefox. When you load up your feed in Firefox, you only see the excerpt, regardless of the setting. This is simply how Firefox works with WordPress, and it is what is supposed to happen. This is not a bug.
    3. Instead of using Firefox, load up your feed in a real feedreader. Google Reader, for example. There you will see the full feed, if that's what you have turned on.

    Get it? It's really very simple. WordPress isn't broken, it's really that your expectations are incorrect. Firefox is not a feed reader. It doesn't show the full content, it shows what is known as the 'description' instead. And in WordPress, the description is the excerpt. If you were using manually made excerpts, those would show up in the Firefox view, but the full content would show up in an actual reader like Google Reader. This is by design. This is what it is supposed to do.

Topic Closed

This topic has been closed to new replies.

About this Topic