WordPress.org

Ready to get started?Download WordPress

Forums

RSS Feed Too Slow - Timeout while fetching the feed. (10 posts)

  1. exquisite000
    Member
    Posted 3 years ago #

    Recently i change my url, transfer hosting n upgrade wordpress to 3.02.

    The matter now is the feed. Before this (on my old url), the feed working perfectly. However, now when i want to burn feed for my new url, Feedburner can't fetch the feed. It said "Timeout while fetching the feed". Validator said "Server returned timed out"

    I try posted new post on my blog. The feed works. It updates with my latest post. The feed url (http://wwww.mynewdomain/feed) work on Browser. The problem is just to load:

    My website (full with images)
    http://www.mynewdomain.com/ ==> 10 seconds to load perfectly
    My Feed
    http://www.mynewdomain.com/feed ==> 40 seconds to load

    Well, i believe that is the reason why Feedburner always timeout to fetch the feed. Why this happen? i try to change the theme to twenty ten but no luck. Help please..

    Thanks in advance

  2. exquisite000
    Member
    Posted 3 years ago #

    Anyone can help on this matter?

  3. No one can possibly help unless you post the real URL so people can see the load times and source for themselves.

  4. exquisite000
    Member
    Posted 3 years ago #

    yes please. try it yourself. just compare the load time.

    _http://www.khidhir.com/
    _http://www.khidhir.com/feed

  5. You're loading an *outrageous* number of javascripts, css files and images. The site will simply never be faster until you get better hosting. You can try Super Cache and Minify: WordPress Plugins

  6. exquisite000
    Member
    Posted 3 years ago #

    ok. i try to disable some plugin,n use minify. The feed load really fast now. But i wonder why Feedburner still said "Timeout while fetching the feed"?

  7. You're still on a slow host. That's the cause of the timeouts.

  8. danazz09
    Member
    Posted 3 years ago #

    Hi, I'm getting a similar issue, where I get WP HTTP Error: Operation timed out after 10001 milliseconds with 0 bytes received.....

    If I refresh the page it then works. Just wondering what you asked your host and what they did to fix the issue.

    So is the issue on my servers side or is it from the yahoo pipes server side where the information is being sent too slow?

    My url is http://www.dansportznet.com

  9. oooorgle
    Member
    Posted 3 years ago #

    Problems started with an upgrade... Your RSS loaded faster than your site for me. Not a slow host that I can tell. Perhaps this is fixed for you.

    I was having issues nesting foreach loops with fetch_feed() and getting consistent results. Some rss feeds would import and others would not and end the script with no error or any return. What has worked for me so far, after I know my coding is correct, is to adjust the WP_MEMORY_LIMIT.

    I added this line to the top of my wp-config.php file.

    define('WP_MEMORY_LIMIT', '128M');

    I read that the default setting is 32M. I first tried 64M and it didn't work. Then 96M and it did work until I got up to around 50 feeds, then increasing it to 128 is working alright for the time being. I don't understand how WP uses memory for fetch_feed but this something I didn't expect and had a hard time figuring out. Not sure if this is your problem but fyi. :) Cheers.

  10. ThorsDad
    Member
    Posted 3 years ago #

    I too was having a problem submitting my feed to Feedburner.
    http://www.capeparrot.org/wordpress/feed/
    http://www.capeparrot.org/

    I kept getting timeouts. I tried the repair/optimize routine on my database with no effect.

    I added oooorgle's line:
    define('WP_MEMORY_LIMIT', '128M');

    and Feedburner instantly accepted my feed. Works for me.

Topic Closed

This topic has been closed to new replies.

About this Topic