WordPress.org

Ready to get started?Download WordPress

Forums

RSS feed shows RSS comments after update (23 posts)

  1. pauloc
    Member
    Posted 8 years ago #

    As said in the title, some people is telling us that their feed-readers get the RSS for the comments insteed of the main RSS after the update to 2.0.1 version.
    Any idea? Somebody with similar problem?

  2. incursio
    Member
    Posted 8 years ago #

    Yesp - same problem here - been reported in a few other threads as well.

  3. rockschtar
    Member
    Posted 8 years ago #

    Yes, same problem here http://www.clubfans.de
    After update from 2.0 to 2.01

    Any ideas?

  4. jdybka
    Member
    Posted 8 years ago #

  5. chochem
    Member
    Posted 8 years ago #

    Uhm I am no expert and maybe this is completely of the mark but I'm pretty sure it's really down to the theme. Go to the "Presentation" part of the administration, click "Theme Editor" and check the file which will most probably be called "Sidebar". Somewhere in there should be a reference to your rss feed. Mine looks like this:

    <a href="<?php bloginfo('rss2_url'); ?>" title="<?php _e('Syndicate this site using RSS'); ?>"><?php _e('<abbr title="Really Simple Syndication">RSS</abbr>'); ?></a>

    In case the php refers to the comments instead it would look something like this:

    <a href="<?php bloginfo('comments_rss2_url'); ?>" title="<?php _e('The latest comments to all posts in RSS'); ?>"><?php _e('Comments <abbr title="Really Simple Syndication">RSS</abbr>'); ?></a>?

    Basically you should simply be able to copy-paste the one you want into the sidebar file and remember to hit the 'update' button at the bottom of the screen.

  6. pauloc
    Member
    Posted 8 years ago #

    I'm affraid it's not this, but thanks anyway.
    Our code at El utilitario:
    <li><a href="<?php bloginfo('rss2_url'); ?>" title="<?php _e('Syndicate this site using RSS 2.0'); ?>"><?php _e('Entries <abbr title="Really Simple Syndication">RSS</abbr>'); ?></a></li>
    <li><a href="<?php bloginfo('comments_rss2_url'); ?>" title="<?php _e('The latest comments to all posts in RSS'); ?>"><?php _e('Comments <abbr title="Really Simple Syndication">RSS</abbr>'); ?></a></li>

    The first points to http://www.elutilitario.net/index.php/feed/ and the second to http://www.elutilitario.net/index.php/comments/feed/.
    The problem seems to be with permalink codification (or something) 8$

  7. despacho
    Member
    Posted 8 years ago #

    if you cahange the permalink structure, it works.

  8. ozeflyer
    Member
    Posted 8 years ago #

    @despacho: Sorry, but this cannot be the solution of this problem. There are more than 600 entries with an explicit permlink-url in my wp - also in the searchengines.

  9. despacho
    Member
    Posted 8 years ago #

    searchengines will renew entries!
    ..in some time...
    ...long time :)

  10. rwt
    Member
    Posted 8 years ago #

    All these sites use index.php as part of the permalink structure. What could be causing the problem with that??

  11. blueexile
    Member
    Posted 8 years ago #

    I'm having exactly the same problem. Any fixes yet?

  12. jdybka
    Member
    Posted 8 years ago #

    There's a ticket created in the bug reporting system
    http://trac.wordpress.org/ticket/2379

  13. stid
    Member
    Posted 8 years ago #

    Same problem here.
    Also with a clean new installation of WP 2.0.1

  14. flavien
    Member
    Posted 8 years ago #

    Got a solution if you like to use:
    just set permalinks to default and RSS works correctly now~

    check out my site:
    http://www.flaviensun.com/weblog

  15. Herby007
    Member
    Posted 8 years ago #

    It's solved: click to the ticket number which is mentioned by jdybka and then copy and past one line in /wp-include/classes.php - ready. All your "old" URLs works fine again.

  16. arizonius
    Member
    Posted 8 years ago #

    This seems to solve the problem of allowing the "old" URLs to work, but it doesn't seem to solve the problem in which RSS for Entries (Posts) acutally points to RSS for Comments.

    As flavien mentions above, setting Permalinks to default allows the main RSS for Entries (Posts) to point to Posts, but even with the fix added to $comments_rewrite (ticket 2379), permalink settings other than default "breaks" the Main RSS Feed. By "breaks", I mean that the Main RSS points to comments rather than posts.

    I've implemented the code fix to /wp-include/classes.php, but it doesn't seem to fix the RSS issue which is the original topic of this discussion thread.

  17. Frankenboy
    Member
    Posted 8 years ago #

    I've got the same problem, have this fix (ticket 2379) also implemented to wp-includes/classes.php and the result is negative! This fix doesn't fix my problem. I still get RSS feeds with the comments of my website.
    When I use the default permalink structure my RSS Feed runs well. Using the Customer Structure of permalinks with the values:
    /index.php/%year%/%monthnum%/%day%/%postname%/
    the RSS Feed fails and shows only the comments.
    Thank's for tipps
    frankenboy

  18. bradbice
    Member
    Posted 8 years ago #

    For anyone else coming across this problem, the fix shown here:
    http://trac.wordpress.org/ticket/2379
    ...works. Just be sure not to leave in the '+' character.

    And all you have to do after changing that code is to make a new page. That's it! Then delete your new page or whatever.

  19. Frankenboy
    Member
    Posted 8 years ago #

    I've changed the fixed row (fix 2379) in module: -> wp-includes/classes.php
    but the fix DOESN'T work for me.

    Then I found out, that:
    When the URL has the following ending
    -> /index.php/feed/
    then only comments are displayed!
    When I change the URL to the following ending
    -> /index.php/?feed=rss2
    the feed works and my posts are shown.
    QUESTION:
    Where can I change these values and set them to "/?feed=rss2" ?

  20. Chris_K
    Member
    Posted 8 years ago #

    oops!

  21. polycon
    Member
    Posted 8 years ago #

    This has been my exact same problem too! You're right that ?feed=rss2 works, but my atom feed still doesn't work - still only shows comments. doesn't this have to be something in the index.php file or something, that is pointing the wrong files to the feed?

  22. wdekreij
    Member
    Posted 8 years ago #

    Yeah, I just have the exact same problem! Is it fixed already?

  23. Frankenboy
    Member
    Posted 7 years ago #

    I've change the call to RSS-Feed
    from
    -> /wpwetter/index.php/feed/
    to
    -> /wpwetter/?feed=rss

    Now it works - Thank you

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags