WordPress.org

Ready to get started?Download WordPress

Forums

RSS Feed + Page Not Found (12 posts)

  1. slylake
    Member
    Posted 5 years ago #

    Hi all,

    Not sure if this is related to my permalink changes or not (i made the changes too long ago and forgot to test) but when i click on the RSS feed icon on my page, i get a "page not found" error.

    Feed URL: http://www.grumpysgreen.com/fitzroy/feed/

    Page URL: http://www.grumpysgreen.com/fitzroy/

    Any suggestions?

  2. Samuel B
    moderator
    Posted 5 years ago #

  3. slylake
    Member
    Posted 5 years ago #

    thanks samboll,

    my broken header link looks like this:

    <li><a href="<?php bloginfo('rss2_url'); ?>" title="Subscribe to RSS feed"><img src="<?php bloginfo('template_directory'); ?>/images/feed.png" alt="Subscribe to RSS feed" /></a></li>

    Resulting in feed not found.

    The suggested "added feeds" looks pretty similar to that:

    <li>
    <a href="<?php bloginfo('rss2_url'); ?>" title="<?php _e('Syndicate this site using RSS'); ?>"><?php _e('<abbr title="Really Simple Syndication">RSS</abbr>'); ?></a>
    </li>

    Changing the feed to this code (but keeping the image instead of the RSS text link) has not fixed the issue.

    It still says "feed not found".

    I'm officially confused.

  4. slylake
    Member
    Posted 5 years ago #

    Please - could someone offer any advice on this?

    Cheers!!

  5. slylake
    Member
    Posted 5 years ago #

    I hate "bumping" but surely someone else has experienced this??

    I can't work out how to fix the error courtesy of the link provided as per the above post and this is something I would like to sort out ASAP. *insert begging for help*

    Cheers!

  6. llizard
    Member
    Posted 5 years ago #

    It's possible that your plugin(s) are conflicting. I just changed permalink settings from the default to "Month and name" and suddenly I too was getting 404 page when trying to access the rssfeed. Try putting the permalink setting back to the default: http://yoursite/wordpress/?p=123

    It might not look pretty but it seems to get rid of the 404 page for the feed. It's a better alternative than having to eliminate a wanted and used plugin.

    ejm, WP2.7

  7. dkusleika
    Member
    Posted 5 years ago #

    I did the same as <b>llizard</b> (changed back to default permalink) and it solved the problem for me too.

  8. slylake
    Member
    Posted 5 years ago #

    Thanks for this feedback guys.

    I'm going to go without RSS. It is more important to have search-friendly URLs to help drive hits to the site, given the nature of this site.

  9. arkain283
    Member
    Posted 4 years ago #

    SLYAKE,

    I had this problem too, its been 9 months, but im sure you or someone else will find this valuable, so everyone I will tell you what you need to do if you have this problem so listen up.

    1) The problem is b/c you changed the permalink from default to whatever you chose, BUT your htaccess file was not "writable".

    So what you need to do, is FTP you site, find your htaccess file (its under public_html). Right click on it (i use filezila) select file permisions, then check off read,write,execute for everything. The important this is to change "file permisions" for the htaccess file.

    It will make more sense once you do it. Then go back in to WP, select setting -permalink, re-select your option, and save it. You should be all set, it should be http://www.yourdomain.com/feed. You should not get a 404 error anymore.

    Hope that helps!

    Utke

  10. massacre
    Member
    Posted 4 years ago #

    Thanks for the help, arkain283, but this is not working (for me).

    I even tried to delete the .htaccess so the WordPress is creating it as a new one. Still, with pretty permalinks I have error 404. I am still working on it and if I succeed, I'll write back.

  11. massacre
    Member
    Posted 4 years ago #

    Little update - works like a charm on my second blog. with /feed - the RSS stream is there. I guess that after using a Feedburner, the problems begin. But I am not sure!! I think so, because lot of people complains of the same problem with WP + feedburner installed.

  12. massacre
    Member
    Posted 4 years ago #

    Guys, I think I found the problem!

    After all night browsing over the Net, installing new blog, re-installing my current one, creating new DB, migrating, starting everything from the scratch, installing test-server on virtual machine, etc.... few minutes ago I clicked once and now my RSS is working perfect!

    The problem is with the plug-in GD Press Tools and especially with the RSS delay option. Start it - and you don't have a feed with pretty permalinks. Stop it and it's validated perfectly!

    WP and GD Press Tools are the latest official versions available.

    I don't think that this is the main reason, but at least, it works for me just fine.

Topic Closed

This topic has been closed to new replies.

About this Topic