WordPress.org

Ready to get started?Download WordPress

Forums

RSS feed not working after Directory Move (2 posts)

  1. bparigo
    Member
    Posted 5 years ago #

    My blog was in a subdirectory /blog, and today I made it so the blog now exist in the main directory, but all its files still live in the subdirectory. Only the index.php and the htaccess in the main directory, the rest in the old directory. which means that the rss feed is now at http://www.mysite.com/feed. I need to have it be in its old place. http://www.mysite.com/blog/feed.

    anyway to get the old feed to forward to the new one or just have the feed update in the old location?

  2. JenRed
    Member
    Posted 4 years ago #

    From the sounds of it, this is the same problem I have been having. I have a blog set up in a subdirectory but referenced from the root, as described here: http://www.codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    I found that feedreaders and feed plugins were all looking for http://www.my-domain.com/feed which didn't exist (it gave a blank white page) and I then discovered that the feed was actually located in the subdirectory at http://www.my-domain.com/my-subdirectory/feed but none of the feed plugins knew to look there.

    I eventually worked out that I could set up a 301 Permanent Redirection via my .htaccess file and it works like a charm now. Add this to your .htaccess file:

    Redirect 301 /feed http://www.my-domain.com/my-subdirectory/feed

    (replacing my-domain.com and my-subdirectory with the real names of course)

    Jen

    http://www.redinstead.com.au

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.