WordPress.org

Ready to get started?Download WordPress

Forums

RSS Feed not working (7 posts)

  1. Laura Nuttall
    Member
    Posted 2 years ago #

    Hello,

    I'm trying to put an RSS button on my website - I have facebook, twitter and mail all working fine. When you click on the RSS button I get the following error:

    "This XML file does not appear to have any style information associated with it. The document tree is shown below." and then lines and lines of code.

    I have used the following code for the button. I'm using an HTML leaf in the Headway theme:

    <a>" title="<?php _e('Syndicate this site using RSS'); ?>"><img src="http://www.lauranuttall.co.uk/wp-content/uploads/2011/05/rss-button.jpg" alt="RSS Feed" title="RSS Feed" /></a>

    [Please post code snippets between backticks or use the code button.]

    Does anyone have any idea as to why it's not working?

    Thanks so much for any tips!

  2. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    I see it is working fine now.

  3. Laura Nuttall
    Member
    Posted 2 years ago #

    Hi there, hmmmmm, I just clicked on my button and it's still not working for me! When you click what are you getting...?

  4. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    When I go here, http://www.lauranuttall.co.uk/ and click on the RSS button, I get this, http://www.lauranuttall.co.uk/?feed=rss2

  5. Laura Nuttall
    Member
    Posted 2 years ago #

    A big page of code......? Or are we seeing different things?

  6. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    This is what I see. http://www.ourexcellentadventures.com/feed.jpg
    Your feed works in IE7, 8, 9 and in FF 4.0.1. It does not work in Chrome which just displays the source cpode.

    However, neither your site, http://validator.w3.org/check?verbose=1&uri=http%3a%2f%2fwww.lauranuttall.co.uk%2f nor your feed validate, http://feedvalidator.org/check.cgi?url=http%3a%2f%2fwww.lauranuttall.co.uk%2f

    This is the code from your feed button. http://pastebin.com/rvdDj0rc

    I think cleaning up the validation errors will solve the problem.

    [Edit] The feed validation link above takes a while to load as the feed has errors.

  7. Laura Nuttall
    Member
    Posted 2 years ago #

    Ah I see! Yes, I tried it in FF and it looks much better. Thank you!

    As for the validation....wow that is a whole new dimension I have never entered before. I think I may have to go back to HTML school to understand it! Thank you again for pointing me in this direction, I will do my best to understand and put it right :/

Topic Closed

This topic has been closed to new replies.

About this Topic