WordPress.org

Ready to get started?Download WordPress

Forums

My Calendar
[resolved] RSS feed link doesn't work (25 posts)

  1. ctpweb
    Member
    Posted 1 year ago #

    Hi,

    I have my calendar version 2.4.0 and in the settings I set to display the rss subscribe option. When I click the link I get a page not found 404 error.

    I use the plugin on xenturion.be. The feed url is xenturion.be/feed/my-calendar-rss

    Any idea what is going wrong?

    http://wordpress.org/extend/plugins/my-calendar/

  2. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    You should re-save your permalink structure. It probably needs refreshing to be aware that you've enabled that feature.

  3. ctpweb
    Member
    Posted 1 year ago #

    Indeed, that was the issue, thanks! However, I now see the rss feed for the calendar, but no events show up...

    You can check it here: xenturion.be/feed/my-calendar-rss

  4. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    That appears to be showing events to me; it definitely has a number of events. Are you still seeing this issue?

  5. ctpweb
    Member
    Posted 1 year ago #

  6. ctpweb
    Member
    Posted 1 year ago #

    Any news?

  7. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    Your feed has some bad data in it that's triggering a problem.

    PMBOK<sup>®</sup> Guide (E) - 3/3

    In general, the 'registered' character seems to be causing problems. I can look at this, to see what I can do. How do you enter that data?

    -Joe

  8. ctpweb
    Member
    Posted 1 year ago #

    I see, I manually enter the html code. Can I change something in the code maybe?

  9. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    Do you enter an entity-encoded string for the character, or are you entering a raw character?

  10. ctpweb
    Member
    Posted 1 year ago #

    I just enter the html code in the title field, manually like this:

    PMBOK<sup>®</sup> Guide (E) - 2/3

  11. ctpweb
    Member
    Posted 1 year ago #

    is there something you can do about it? tomorrow i will need a functioning rss feed for the calendar

  12. ctpweb
    Member
    Posted 1 year ago #

    any news?

  13. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    I've been out of town the last week, and haven't been able to look into this in any way. What have you done to experiment?

    Have you tried removing the registration marks to see what the result is? That would help to isolate the issue.

  14. ctpweb
    Member
    Posted 1 year ago #

    Hi Joe, I removed the <sup>®</sup> tags. You can see the calendar on the site: xenturion.be. The feed is still not working :(

    xenturion.be/feed/my-calendar-rss

    Do I need to reindex the events or something?

  15. ctpweb
    Member
    Posted 1 year ago #

    I'm sorry, I just did a hard refresh and they all show up now! Awesome

  16. ctpweb
    Member
    Posted 1 year ago #

    would there be a solution so I can add the <sup>®</sup>?

  17. ctpweb
    Member
    Posted 1 year ago #

    I did some tests and the issue is the ® and not the html tags. The html tags are not interpret in the rss feed, they just show up

  18. ctpweb
    Member
    Posted 1 year ago #

    I was too quick, it only shows one event multiple times :(

  19. ctpweb
    Member
    Posted 1 year ago #

    the rss feed is totally screwed. I'm glad something shows up, but it's worth nothing at the moment. could you please have a look? it's becoming very urgent. thanks!

  20. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    It really looks right to me, but I have no way to know what order you added your events in. Those are all different events - the exam dates for 2 August, 6 September, 4 October, etc.

    What is it that you're expecting the RSS feed to show?

  21. ctpweb
    Member
    Posted 1 year ago #

    Aha that's good news. It might have something to do with caching maybe? Altough I refreshed a lot already.. this is what I see: http://www.contactpunt.be/rss-feed.jpg

    I guess it's different from what you see? i'm sorry for all the "nagging"!

  22. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    No, that's the same thing I see. The date shown should be the date the events were added. The RSS feed is feed of new events, and events are added to the RSS feed when they are added to the database.

    If you look at the source code for the RSS feed (which doesn't display in that view), then you can see the descriptions and start dates for the events, which shows that they are different.

  23. ctpweb
    Member
    Posted 1 year ago #

    So you said you see 2 august, 6 september, 4 october, but you don't see that?? so the rss feed doesn't work? is there any solution....

  24. ctpweb
    Member
    Posted 1 year ago #

    Joe, can you please stop talking beside the point.. you have been stretching and avaiding the actual issue that the rss feed is not working and all you do is give vague answers or tell me that it works while it doesn't work for a bit.

    Can you answer one simple question: is there a way to get the rss feed to work or not? And if so.. can you help me out fast here, cause this is going on for 3 weeks.

  25. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    As far as I can see, the RSS feed is working. I have no way of knowing whether the events shown are correct, because I don't know when you last added new events.

    However, the information you see when you view an RSS feed in many browsers is *not* the entire data in the feed. The screenshots you've posted show only the title and publication date - not the event date, but the *publication* date. The rest of the information is in the source code, and would be viewed in an RSS reader, or can be seen by using your browser's "view source option.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags