WordPress.org

Ready to get started?Download WordPress

Forums

RSS feed doesn't work., error message (6 posts)

  1. missmel58
    Member
    Posted 5 years ago #

    My blog is up and running (http://mejones.net). Sort of. I am using Vladimir Prelovac's theme "Amazing Grace".

    I tried to add my blog to Facebook's blog network -- and was told it could not connect to my blog via rss -- soooo... I went and clicked on the RSS links on the page and received the following error message:

    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://mejones.net/blog/feed/
    Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8"?>

    Changing the theme makes no difference; I continue to get this message. If there is something in the admin panel I need to click to activate the rss feed, I cannot find it. Any help appreciated.

    I googled the error message and found a forum post that suggested that I re-paste the post uing notepad, instead of MSword. I did that -- and it then sent the feed to my facebook page, I am assuming using an RSS feed. But when one clicks on the RSS links on my blog the error message still occurs.
    Mel

  2. missmel58
    Member
    Posted 5 years ago #

    So, after hours of searching for answers. I know what is CAUSING the rss to create an error message. There is an extra line before the code...somewhere. When I load my blog and view source there is indeed an extra line -- which I will gladly delete. But I have opened several files and not found the matching code.

    As I had edited no files prior to discovering this issue, I am unsure how the problem was created...but I really want to fix it.

    Could someone PLEASE give me some direction? Please?

    Mel

  3. missmel58
    Member
    Posted 5 years ago #

    bump

  4. moonglampers
    Member
    Posted 5 years ago #

    Hello. I had the same error. The problem was that there was an errant blank space (or two, or three, or more) outside of the php script brackets <?php ?> in several of the *.php pages in my main WordPress directory. I am not sure which one it was, but once I made sure there was no "white space" outside of the brackets, my RSS feed worked fine. Hope this helps!

  5. flyaga
    Member
    Posted 5 years ago #

    Please try this plugin fix-rss-feed, it will fix your rss error automatically, and you can get more information from http://wordpress.org/extend/plugins/fix-rss-feed/, and you also can get help from the author website http://www.flyaga.info/en/wordpress/plugins/fix-rss-feed-error-wordpress-plugins.htm

  6. Vineeta
    Member
    Posted 4 years ago #

    Had the same error. Tried suggested plugin. It found 1655 faults and fixed them. But feed still doesn't work. Message has now changed slightly though to:

    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://www.scamperbranding.com/feed/
    Line Number 3, Column 1:<?xml version="1.0" encoding="UTF-8"?>
    ^

    Any ideas? It used to work fine but we just upgraded to latest version of WP.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.