WordPress.org

Ready to get started?Download WordPress

Forums

RSS feed broken on new WP3 installation... :( (7 posts)

  1. eyedea
    Member
    Posted 3 years ago #

    Hi

    I've tried searching and searching - and it seems that though I'm not the only one with this problem - there is no clear solution...

    I've installed WP3 for a new site (an update for an old setup actually) and all is working fine - apart from the RSS feed... the link: http://webeyedea.info/wp/feed/
    ERROR:

    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://webeyedea.info/wp/feed/
    Line Number 4, Column 1:<?xml version="1.0" encoding="UTF-8"?>
    ^

    I have not touched the RSS (never do as I wouldn't know enough about it) - using another theme like the 2010 - or disabling all plugins does not make a difference....:-(

    I'd appreciate any thoughts on this - would like to solve this asap...

    The link to the site: http://webeyedea.info

  2. Samuel B
    moderator
    Posted 3 years ago #

    almost always a plugin causes that error
    deactivate them and re-activate one by one and test in between

    if that isn't it, you might try this
    http://wordpress.org/extend/plugins/broken-rss-feed-fixer/

  3. Miss-Frustrated
    Member
    Posted 3 years ago #

    SAME PROBLEM! I've installed the fix-rss-feed plugin, no help. I deactivated and deleted it. I've MANUALLY removed every bit of whitespace, still no luck. I've deactivated every single plug-in, checked, and STILL no luck. I have no clue what is going on and now I'm simple frustrated, WORDPRESS or whomever needs to fix this issue.

  4. eyedea
    Member
    Posted 3 years ago #

    Hi :)

    just to report back - managed to fix it... I did try the fix-rss-feed plugin - didn't fancy setting permissions for all files to have the white space removed so I decided to try the long and time-consuming approach of manually doing it.

    Going through about 250-odd files, main WP files, within wp-admin, and mainly the includes folders - was surprised to find some <?php ?> tag unclosed - and lots of the files had the empty tail end lines...
    SO I went through them all - and voila... error fixed - all ok.

    I found the plugin useful for pinpointing all files with the space to be deleted - and it took a while but it's working.

    http://webeyedea.info/feed/

    PS: if you want my copy of the WP files, now with white-space removed - feel free to get in touch [prisca AT eyedea.eu] and I'll email it to you :)

  5. Samuel B
    moderator
    Posted 3 years ago #

    eyedea
    thanks for the resolution

  6. eyedea
    Member
    Posted 3 years ago #

    Samuel ;)
    was a bit of a task - but glad it's done and was definitely worth it ;)

  7. eyedea
    Member
    Posted 3 years ago #

    Hi, I'm back.... :(

    sadly the problem is back and very oddly - the RSS link in my footer works just fine in Safari, also works fine when subscribing to the feed via a feed reader (eg Reeder) - but in other browsers (Chrome/Firefox) - the same issue is back... :(

    tried the rss fix plugins again, no luck...
    http://webeyedea.info/feed/

    anyone have any other ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags