WordPress.org

Ready to get started?Download WordPress

Forums

RSS feed before the "more" tag (8 posts)

  1. Maleficus
    Member
    Posted 4 years ago #

    Might be a silly question but I didn't find anything of use to this issue. Actually I've only found people's concerns about this feature being BAD. The irony is I need it this way - my rss content to be everything before the more tag and excluding everything after.

    I tried "summary" option, pinged feedburner and it still shows the full text. Also I'd be glad if someone could advise how to exclude a particular "class=" form showing in feeds.

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    The summary option is your best approach though it may take feedburner some time to update. You can't, however, exclude content from the feed based on a CSS class. Classes simply don't apply - in any way , shape or form, to news feeds.

  3. Maleficus
    Member
    Posted 4 years ago #

    Thx for an answer. Feedburner updated, though it's still not as I want it too. Is there any way to code rss to grab all the info before the "more" tag? Also all my posts have a picture first. It was displayed in full text feed but is not in summary, which is a pity.

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    It was displayed in full text feed but is not in summary, which is a pity.

    The summary feed uses an rss-version of the_excerpt() - which means that a lot of formatting is removed.

    Have you had a look at:
    http://codex.wordpress.org/Customizing_Feeds
    http://xplus3.net/2008/10/30/custom-feeds-in-wordpress/

  5. Maleficus
    Member
    Posted 4 years ago #

    I did, but it says nothing about stopping right after "more" tag, I don't need an exact amount of of words (50), I need the feed to look, whether "more" tag has started and basically publish everything till that point. I don't get why such an "easy" and essential option is nowhere to be found.

  6. giossicom
    Member
    Posted 4 years ago #

    I have the same problem, looks like someone else has found a solution, but I can't really come up with a solution for myself, it doesn't work for me.
    It's a bit odd, since I use wordpress since ages and have never had problems modding here and there. kinda lost

  7. matthewpaul
    Member
    Posted 4 years ago #

    Is there a solution for this? I am having the same issue.

  8. jnrbsn
    Member
    Posted 3 years ago #

    I know this thread is a little old, but I think this is what you're looking for... Just add the code below to the functions.php file in your theme.

    function mytheme_content_feed($feed_type = null) {
    	if ( !$feed_type )
    		$feed_type = get_default_feed();
    
    	global $more;
    	$more_restore = $more;
    	$more = 0;
    	$content = apply_filters('the_content', get_the_content());
    	$more = $more_restore;
    	$content = str_replace(']]>', ']]& gt;', $content);
    	return $content;
    }
    add_filter('the_content_feed', 'mytheme_content_feed');

    Remove the space between the '&' and the 'gt;' on line 10.

Topic Closed

This topic has been closed to new replies.

About this Topic