WordPress.org

Ready to get started?Download WordPress

Forums

RSS feed auto-shortening (12 posts)

  1. alittler
    Member
    Posted 6 years ago #

    I noticed in my FeedBurner url (http://feeds.feedburner.com/ThisAintNarniaKiddo) that every feed was being shortened with a [...] at the end of each. So I the removed every plugin, everything I could actually remove and checked the feed from my actual site, pre-Burning (http://www.thisaintnarnia.com/?feed=rss2) and I have the same problem. I dont remember this happening before, I just recently re-installed 2.6 (thus the basic theme) to try to get it to work before anything else.

    Am I missing somethig here? Especially with FeedBurner, I dont want to have every feed shortened so much.

  2. Dgold
    Member
    Posted 6 years ago #

    Admin > Options > Reading

    check the settings there... something about Full Feed or Summary

    EDIT: oops Options might be called Settings now

    Also, in spite of the settings there, some versions of WP will put ... in your feed anyplace you used the "MORE" command in the Write Post

    but I think WP 2.6 doesn't pay attention to "MORE" in feeds now (Not positive about this)

  3. alittler
    Member
    Posted 6 years ago #

    I should have been more specific, that was the first thing I checked, and I do have the "Full text" option selected, Summary is just overkill.

    And in 2.6, its Settings > Reading.

    I had a Plugin that set MORE tags after each first paragraph, but that is disabled, otherwise I have not use a MORE tag in ages.

  4. Dgold
    Member
    Posted 6 years ago #

    So you still have the problem?

    I just looked around on Feedburner, couldn't find a setting there that would be doing this.

    But mainly, the problem is still in your orig feed from your site.

    No chance you've modified the PHP files in the admin that create the RSS, right? Normally you wouldn't mess with those, I forget what the filename even is.

    Anyone else have an idea for alittler?

  5. alittler
    Member
    Posted 6 years ago #

    Its a fresh install, so nothing has been modified. The original url is http://www.thisaintnarnia.com/?feed=rss2, so I assume the RSS properties are somewhere in the (or included in the) index.php? I will go give it a shot, but any tips on what to look for there?

  6. Anonymous
    Unregistered
    Posted 6 years ago #

    I'm having the same problem with my feed at http://www.junkfoodjunkie.no/feed - seems to me this is a problem with WordPress, as I have checked the settings and everything, but can't seem to get WP to show Full text. No plugins added that should do this, also tried disabling all plugins.

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    alittler: That feed link you provided at http://www.thisaintnarnia.com/?feed=rss2 is correct and showing the full content of each post. WordPress puts two types of content in the feed. The shortened thing goes into the description, and that's what Firefox shows, but the full content goes into the content:encoded, and that's what feed readers like Google Reader will use. Your feed at http://feeds.feedburner.com/ThisAintNarniaKiddo is similarly okay, nothing wrong with it.

    PoPSiCLe: Same thing, your feed is fine.

    Always look at your feed using a real feed reader, not just Firefox or something similar.

  8. Anonymous
    Unregistered
    Posted 6 years ago #

    Uhm - I did that - I use Bloglines normally, and it shows the summary - not the complete feed. So does feedvalidator.org (which I am assuming checks the whole feed?) - and for instance, Twingly does not always show posts I make with links to Twingly-enabled blogs/newspapers.

    I tried looking at the feed in IE, and there it seems to be okay, although I'm not really convinced that the feed is okay - is there some way to only send the complete content, without the shortened description?

  9. alittler
    Member
    Posted 6 years ago #

    Hrm! Well thank you very much, this combined with the laptop I was on was really screwing up with cookies was why I couldnt figger that myself. Thanks!

  10. Anonymous
    Unregistered
    Posted 6 years ago #

    Hmm... well, I'm using feedwordpress to read them, and I just get the summary. But I guess it's a feedwordpress problem then. Ugh.

  11. sacvietguy85
    Member
    Posted 6 years ago #

    Hi guys, i just recently have the same problem. You might wanna check the .htaccess file and make sure it begin with
    # BEGIN wordpress
    or
    # Begin supercache
    if you using supercache
    Check the php.ini also
    I'm not sure but that's how i fixed my problem

  12. sacvietguy85
    Member
    Posted 6 years ago #

    Oh by the way, the supercache has the feature where u could delete cache, so make sure you delete cache before checking the feed url

Topic Closed

This topic has been closed to new replies.

About this Topic