WordPress.org

Ready to get started?Download WordPress

Forums

RSS Feed and Validation Problems (1 post)

  1. Nerino
    Member
    Posted 9 years ago #

    Hello everyone, I've spent the last 4 nights trying to get my feed to work for http://www.compujurist.com. I'm using the Imhotep theme and have been through the Codex and the RSS topics here multiple times and tried many of the recommended fixes.

    I've updated to WP 1.5.2

    I've added a feed on the sidebar from scratch rather than working with the theme link in the footer so I could take advantage of the recommendations here.

    I've removed the word feedand the colon from the sidebar code

    If I validate compujurist.com/wp-rss2.php it validates; however, that's not the link generated from my my rss link code. What I get from my link is compujurist.com/feed which does not validate.

    I've removed the header theme code for RS and Atom and replaced it with the code from the posted topics. The header now reads

    <head profile="http://gmpg.org/xfn/11">
    <title><?php bloginfo('name'); ?><?php wp_title('- '); ?></title>
    <meta http-equiv="Content-Type" content="text/html; charset=<?php bloginfo('charset'); ?>" />
    <meta name="generator" content="WordPress <?php bloginfo('version'); ?>" /> <!-- leave this for stats please -->
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" title="Main" />
    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="<?php bloginfo('rss2_url'); ?>" />
    <link rel="alternate" type="application/rdf+xml" title="RSS .92" href="<?php bloginfo('rss_url'); ?>" />
    <link rel="service.feed" type="application/atom+xml" title="Atom0.3" href="<?php bloginfo('atom_url'); ?>" />
    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    <?php wp_get_archives('type=monthly&format=link'); ?>
    <?php wp_head(); ?>
    </head>

    My sidebar link reads

    " title="<?php _e('Syndicate this site using RSS'); ?>"><?php _e('RSS'); ?>

    If I link directly to the compjurist/wp-rss2.php using Thunderbird's RSS reader I get the 2 posted articles. However, if I use this for infoRSS in Thunderbord I get nothing.

    One other strange thing is that when I installed WP, it did not create a .htaccess file.

    I apologize in advance if I've missed something simple, but I feel that it's time to ask for help from more knowledgable users of WP. I know legal tech hardware and software, but little or nothing about HTML and even less about PHP. If you go to lawtechguru.com when you use infoRSS you get rolling banners. His links point to an XML index, but he is also using Typepad. I could use Typepad, but I like to know the tools that I am using (and being able to select my own host).

    Any help will be greatly appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic