WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] RSS Fails to validate (7 posts)

  1. carm8568
    Member
    Posted 1 year ago #

    Tried to add blog to alltop.com and usual rss feed failed to validate. Website is http://www.carmenamato.net and rss feed is http://carmenamato.net/?feed=rss2.
    Here is what the feed validator returned:
    Sorry

    This feed does not validate.

    line 14, column 11: language must be an ISO-639 language code: [help]
    	<language></language>
               ^
    line 15, column 1: channel contains more than one generator [help]
    	<generator>http://wordpress.org/?v=3.4.1</generator>
     ^
    line 18, column 0: Undefined rss element: item (18 occurrences) [help]
    <item><title>Author Carmen Amato website home</title><link>http://carmenamat ...

    Am a wordpress rookie so could use some specific advice how to fix. Many thanks, Carmen

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    And why haven't you updated WordPress yet?

  3. carm8568
    Member
    Posted 1 year ago #

    Was doing wp housekeeping today so will be updating. Will deactivate the plugins and see if that works. Have been using the Skirmish theme for some time, would theme suddenly cause this problem?

  4. carm8568
    Member
    Posted 1 year ago #

    Rogue plugin was the problem. Thanks for your help. And yes, wp is updated!

  5. utern
    Member
    Posted 1 year ago #

    i have an rss feed problem too i keep on getting this error message from
    http://utern.org/?feed=rss

    This page contains the following errors:

    error on line 2 at column 348: XML declaration allowed only at the start of the document
    Below is a rendering of the page up to the first error.

    I have tried validating it and it shows as
    http://feedvalidator.org/check.cgi?url=http%3A%2F%2Futern.org%2F%3Ffeed%3Drss2

  6. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    @utern: It is impolite to interrupt another poster's ongoing thread with a question of your own and it causes significant problems for the forum's volunteers. Please post your own topic.

  7. utern
    Member
    Posted 1 year ago #

    Sorry, I apologize for interrupting the forum by another poster. Thank you for informing me about the problems that can occur.

Topic Closed

This topic has been closed to new replies.

About this Topic