WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] rss and atom errors (4 posts)

  1. ostap
    Member
    Posted 4 years ago #

    I have WordPress 2.8.1 installed and both my rss and atom feeds don't function properly. The rss address to the main blog page instead of the posts, and atom just references to itself

    Here're what Feedvalidator says:

    Atom: http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fkarmodi.com%2Fostap%2F%3Ffeed%3Datom

    RSS: http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fkarmodi.com%2Fostap%2F%3Ffeed%3Drss2

    It's pretty clear here what's wrong, but I'm new to wordpress and have not a slightest idea where and how should I correct it. Could you explain me, please, taking into account that I'm possibly have no knowledge of some WordPress concepts you consider basics?

    Thanks

  2. ostap
    Member
    Posted 4 years ago #

    It seems to me that the problem is with get_permalink() or the_permalink_rss() functions: they don't return any permalink, so there's no link to my post in the template, there's nothing between link tags.

    But I still don't understand how to fix it.

    Anybody?

  3. ostap
    Member
    Posted 4 years ago #

    When I deactivate Google Analytics plug-in, everything is back to normal. Could anybody advice me how I should tweak the plug-in code to get rid of this problem?

  4. ostap
    Member
    Posted 4 years ago #

    I've deactivated Google Analytics for WordPress and downloaded and activated instead Google Analyticator. It seems that everything's alright now.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags