WordPress.org

Ready to get started?Download WordPress

Forums

RSS and 1.5 Problem (26 posts)

  1. dbockes
    Member
    Posted 9 years ago #

    I upgraded from 1.2 to 1.5 on one of my sites and since that time, the RSS feeds are not working properly. On 1.2, the url to the feed was http://www.bockes.com/wp-rss2.php. That url hasn't changed in 1.5 but the feed won't read. From looking at a couple of other threads I saw where you could add the ?feed to any url to retrieve the feed. However, I'm not keen on having to tell everyone to change the feed url unless I can do a redirect of the old url to the new url. However, seems to me that could potentially create a looping situation. Anyone else have this problem or care. Even if I use the query string to get the feed, the feed doesn't validate and some readers won't process it.

  2. davestinner
    Member
    Posted 9 years ago #

    It doesn't validate because it 404's for some reason. I can go to it directly but when I enter it into the feed validator, I get a 404 error.
    http://www.feedvalidator.org/check.cgi?url=http%3A%2F%2Fwww.bockes.com%2Fwp-rss2.php

  3. James
    Happiness Engineer
    Posted 9 years ago #

  4. Roar
    Member
    Posted 9 years ago #

    I am confused by that forum....

    do we make this change:

    '--------------
    if ( preg_match('/cgi/', php_sapi_name()) )
    @header('Status: 404 Not Found');
    else
    @header('HTTP/1.x 404 Not Found');
    --------------

    and turn them into this:

    --------------
    /* if ( preg_match('/cgi/', php_sapi_name()) )
    @header('Status: 404 Not Found');
    else
    @header('HTTP/1.x 404 Not Found'); */'

    or this change:

    change:
    ' (false === strpos($_SERVER['PATH_INFO'], 'index.php'))'
    to
    ' (false === strpos($_SERVER['PATH_INFO'], '.php'))'

  5. americasroof
    Member
    Posted 9 years ago #

    I am confused by the issue also. When I click on the rss feed at the bottom of the 1.5 page I get:

    feed:http://mysite.com/feed/

    This of course produces an error.

    I can manually get the rss by
    http://mysite.com/feed/
    or
    http://mysite.com/rss2/

    But I would like the feed without the drama (the same error also occurs with comment rss)

  6. James
    Happiness Engineer
    Posted 9 years ago #

    DBockes and Rori, go here and click the "download" link and replace your file: http://cvs.sourceforge.net/viewcvs.py/cafelog/wordpress/wp-blog-header.php?rev=1.131&view=auto

    Americasroof, the feed: is a new syntax which automatically launches your feed reading app when clicked. To remove it, simple access whichever part of your template contains the RSS links and remove it.

  7. tonusp
    Member
    Posted 9 years ago #

    I'm still getting problems too. Although, macmanx, you said my feeds were working OK,
    (blog URL: http://www.godspell.org.uk/wordpress/

    they aren't getting picked up by Bloglines. There's the dreaded red exclamation mark next to my blogname, and the error message:

    Bloglines has encountered an error trying to fetch the latest version of this feed. Bloglines handles errors automatically, no action is required by you. The error was:

    The feed does not appear to exist. This can be caused by the feed URL being incorrect, or it can be caused by a configuration issue with the server hosting the feed. If this error continues, you should check the feed URL and, if it is wrong, subscribe to the correct URL.

    Any suggestions, please?

  8. dbockes
    Member
    Posted 9 years ago #

    macmanx, that worked perfectly. Thanks a ton for the help.

  9. tonusp
    Member
    Posted 9 years ago #

    Ok, I think I'm working again. Bloglines needed to be unsubscribed and resubscribed - it didn't then automatically find the correct URL and I had to do it manually. Something about the set-up of 1.5 seems to confuse it - which is a shame, when everything else works so well.

  10. James
    Happiness Engineer
    Posted 9 years ago #

    Blogines usually takes 24 hours before it realizes that it can access a feed again.

  11. Roar
    Member
    Posted 9 years ago #

    does that wp-blog-header file need to be replaced on every theme?

  12. akhmadf
    Member
    Posted 9 years ago #

    Hmm, I get 404 when I tried to browse http://myblog.com/feed. As far as I concern, there's no such feed directory in wordpress. Does it use mod_rewrite?

    I thought it was harcoded in the theme. But after I checked it, the theme uses get_blog_info('rss2') . get_blog_info called get feed_link and get_feed_link some how returns http://myblog.com/feed/ instead of http://myblog.com/wp-rss2.php.

    Any clues? Wrong installation or settings maybe?

  13. James
    Happiness Engineer
    Posted 9 years ago #

    If you're using permalinks, your feed will be at /feed/. If not, your feed is at /wp-rss2.php.

  14. americasroof
    Member
    Posted 9 years ago #

    Thanks macmanx. I deleted the "feed:" command from the footer.php in the template files and things work great. I suspect the feed option is probably too high tech for the average user (I too use bloglines to read rss). But if that's the only thing I have to complain about wp then I don't have much to complain about!

    Americasroof, the feed: is a new syntax which automatically launches your feed reading app when clicked. To remove it, simple access whichever part of your template contains the RSS links and remove it.

  15. Knightcrawler
    Member
    Posted 9 years ago #

    I am confused by that forum....

    do we make this change:

    '--------------
    if ( preg_match('/cgi/', php_sapi_name()) )
    @header('Status: 404 Not Found');
    else
    @header('HTTP/1.x 404 Not Found');
    --------------

    and turn them into this:

    --------------
    /* if ( preg_match('/cgi/', php_sapi_name()) )
    @header('Status: 404 Not Found');
    else
    @header('HTTP/1.x 404 Not Found'); */'

    This is what I did and the RSS2 feeds work agian, I'm using the wp-rss2.php direct urls IE: http://www.domain.com/wp-rss2.php

  16. SamC
    Member
    Posted 9 years ago #

    Hi Everyone,

    I've been struggling with this feed. Keep getting a 404 error with feed validator. I tried the changes above that I could identify, but no luck. Any help is greatly appreciated.

    Here is the feed:
    http://www.sportspodnet.com/americanfan/wp-rss2.php

    Thanks,
    Sam

  17. nscott
    Member
    Posted 9 years ago #

    For those who have found a solution with this RSS problem, can you help explain to me how to change my RSS feed to point to /wp-rss2.php rather than /feed.

    I am using WordPress 1.5. and pretty much a newbie.
    My url is http://www.citizenofthemonth.com I see this is a fairly common problem, but I don't really understand some of the answers in the forum.

    Is this (/feed) supposed to be a new type of WordPress feed? Do I need to write something in .htaccess (I did change my permalinks and had to put in an empty .htaccess file to make it work)? I see where I can delete the /feed in the local version of sidebar.php, but where do I make the changes on the remote files?

    Thanks,

    Neil

  18. Ravn
    Member
    Posted 9 years ago #

    Hey

    My feed is still not working. I triede installing the new wp-blog-header that macmanx postede. I triede removing the "feed:" in front of the link.

    The link to the feed is: feed:http://www.hamberg.dk/php/wp/wp-rss2.php

    What to do?? I really wants it to work!

    Thanks!

    Ravn

  19. James
    Happiness Engineer
    Posted 9 years ago #

    Ravn, your feed works fine, but you haven't removed the feed: from in front of your link yet. That's why your feed's link is still feed:http://www.hamberg.dk/php/wp/wp-rss2.php

    To remove it, find whichever part of your template holds your sidebar content, and change:

    <a href="feed:<?php bloginfo('rss2_url'); ?>">Entries (RSS)</a>

    to:

    <a href="<?php bloginfo('rss2_url'); ?>">Entries (RSS)</a>

  20. Ravn
    Member
    Posted 9 years ago #

    Thanks for the answer!

    But i already tryede that, i just made it back to the original. I now made it again, but its still not working!

    the new url is: http://www.hamberg.dk/php/wp/wp-rss2.php

    Any other ideers??

    Ravn

  21. dyn4mik3
    Member
    Posted 9 years ago #

    Anyone fix this issue? there is definetly something up with bloglines+wordpress feeds.

  22. DElyMyth
    Member
    Posted 9 years ago #

    Try to add these lines to your htaccess file (if you can use mod_rewrite):
    RewriteRule ^wp-rss2.php /index.php?feed=rss2 [QSA]
    RewriteRule ^wp-commentsrss2.php /index.php?feed=rss2&withcomments=1 [QSA]
    RewriteRule ^wp-atom.php /index.php?feed=atom [QSA]
    RewriteRule ^wp-rdf.php /index.php?feed=rdf [QSA]
    RewriteRule ^wp-rss.php /index.php?feed=rss [QSA]

    This works and does not require editing of original WP code.

  23. dewaun
    Member
    Posted 9 years ago #

    macmanx your "wp-blog-header.php" file fixed the feed problem for me, now NetNewsWireLite and Firefox both pick up the feeds okay.

    One question though... it seems that if I use firefox to subscribe to the site feed from a particular "post", the feed is to that particular post only...not the whole site feed.

    Odd. Is that supposed to happen?

    I have to go to the homepage and then click the Subscribe button to the the generic feed.

    It's not a bad thing, necessarily...just curious.

  24. Tim Griffin
    Member
    Posted 9 years ago #

    Ok,
    tried the wp-blog-header.php... no change. My page gives the post rss just fine - but NO comment rss...
    I have the same error I started with...
    ~permalinks on
    ~wp 1.5
    ~installed entity2NCR plugin
    ~tried the .htaccess stuff...
    ~looked for 'white space' in the rss files
    ~googled for too long and got this: http://mosquito.wordpress.org/view.php?id=903
    ~tried to apply the &ampersand quick fix: http://priyadi.net/archives/2005/02/25/wordpress-15-bugs/
    ~reverted to the original files and have the original problem...
    ...
    ...
    ...

    HELP?
    anyone?

    http://www.griffhome.com/comments/feed/

    I see that others have found a fix... not sure what to do

    tGriff :-)

  25. Tim Griffin
    Member
    Posted 9 years ago #

    Uploaded the latest wp-comments-post.php...
    get it here:
    http://cvs.sourceforge.net/viewcvs.py/cafelog/wordpress/wp-comments-post.php?rev=1.30&view=log
    Seems to be working just fine...
    got the tip here:
    http://wordpress.org/support/topic.php?id=8695#post-52022

    :-D
    took me a little to find this :-)

  26. Charles McKeever
    Member
    Posted 9 years ago #

    I installed WP 1.5 this morning successfully. I was able to get the podcast enclosure functionality to work. But, when I would click the 'Entries (RSS)' link at the bottom of index.php to go to wp-rss2.php I would get a 404 error. I finally found a google link to the following url that gave me the fix:

    http://mosquito.wordpress.org/view.php?id=903

    I am using IIS 5.0 and I had to modify wp-blog-header.php. I changed the line

    (false === strpos($_SERVER['PATH_INFO'], 'index.php'))

    to

    (false === strpos($_SERVER['PATH_INFO'], '.php'))

    Dropping 'index' from the .php extension in the line fixes the problem. There is an issue with the way the path is returned and this produces an incorrect reference that results in a file not found.

    I hope this is of help to someone.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.