WordPress.org

Ready to get started?Download WordPress

Forums

RSS 2.0 is not working (11 posts)

  1. placutus
    Member
    Posted 9 years ago #

    Hello, I have set up permalink, but rss2 doesn't work; when I try to access to http://mydomain.com/blog/feed/rss2/
    I get 404 Not Found error.
    I looked in this form another thread with similar problem (not the same ) but was not fixed.
    Anybody could advise me?
    Thanks

  2. NuclearMoose
    Member
    Posted 9 years ago #

    Would be easier to advise if we knew what version of WP you were talking about. Also, a link to your actual site is generally helpful.

  3. It might've been my thread you saw. What I did was remove the extraneous .htaccess files I had scattered in various folders, and made sure the root .htaccess was fine. Then, I redid the .htaccess rules for WP by manually entering it in CPanel (rather than doing it through the WP admin).

  4. placutus
    Member
    Posted 9 years ago #

    Thanks to everybody,
    NuclearMoose:
    -I have installed WordPress Version 1.2
    -My blog test website http://www.exportfocus.com/xblog1/
    btvillarin:
    -The thread I was telling about is .../support/topic.php?id=15974

    To deliver you more detailes about my experience, I add:
    when in admin. suite I click over the link "....htaccess file is writable by WordPress, you can edit it through your template interface"
    I get 'Internal Server Error....'; also I have seen I have no any .htaccess file into 'xblog1' directory,
    so I have created one, have written mod_rewrite rules suggested - by 'options-permalink' - in it, but after upload in the directory,
    I got also for main page http://www.exportfocus.com/xblog1/ Internal Server Error.
    (Now I have cancelled the file so you can view again the site with the rss problem)
    Thanks for your help

  5. unfortunate
    Member
    Posted 9 years ago #

    hey im totally new to wordpress. i installed wp 1.2 and discovered the my rss feeds display a 404 error. i read through the top posts and saw something about htaccess. could someone give me the gradeschool explaination as to what i should do?

    my site is here: http://unfortunate.belike.net

    thanks.

  6. James
    Happiness Engineer
    Posted 9 years ago #

    Placutus, I'm sorry I didn't see this before. The permalinked RSS feeds won't work with a /index.php/ structure. You will have to go into index.php and change the feed links manually. Your correct feed URL is: http://www.exportfocus.com/xblog1/wp-rss2.php

  7. placutus
    Member
    Posted 9 years ago #

    May be I have fixed the problem; I have rewritten .htaccess file and uploaded it in ASCII mode via FTP. It seems Rss is now working.

    As I am newbie for blog, also a question: I see Rss display the same page (the same code) including all of items posted, either I click the rss link from main page or from category page, even from single item page. Is that ok, or not properly is working?

  8. placutus
    Member
    Posted 9 years ago #

    Macmanx, I have posted before to view your reply; so you tell me I have to go into index.php and change feed links manually; could you tell me what links I have look for (if you can write an example of it) and what I have to replace with?
    If you can have a look again to my blog test, you can tell me if it works properly or not (so also answering to my second question about rss code displayed) and if the change you suggest me is necessary.
    Thank You

  9. James
    Happiness Engineer
    Posted 9 years ago #

    Amazing, Placutus, you're the first person to get your feed to work while using the /index.php/ structure. Now you don't have to change any URLs in index.php, you're running perfectly. Congrats!

    Unfortunate, your feed appears to be working fine.

  10. unfortunate
    Member
    Posted 9 years ago #

    i disabled the custom permalink which is why my feed is working again. i haven't figured out a way to make the permalink /index.php/archives/%post_id%/ without messing up my rss feed.

  11. James
    Happiness Engineer
    Posted 9 years ago #

    You need to have a complete date structure for permalinks to work properly in v1.2.x. Try:
    /index.php/archives/%year%/%monthnum%/%day%/%postname%/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.