WordPress.org

Ready to get started?Download WordPress

Forums

RSS 2.0 feed is blank, but comments-rss2 works... Any Ideas? (11 posts)

  1. smindeaux
    Member
    Posted 6 years ago #

    Hi all. I have looked through the forums and don't know where to start on my problem. My rss feeds have been working flawlessly for the last 2 years.

    Today, my rss feeds stopped working. When you enter the URL manually, it returns a blank screen. When you run it thru RSS validator is stays: Server returned httplib.BadStatusLine

    Any ideas? RSS 1.0 also isn't working...

    My feed is http://www.scottmindeaux.com/wordpress/?feed=rss2

  2. cstina
    Member
    Posted 6 years ago #

    Seems it's working now. How did you remedy the problem? I'm having the same issue.

  3. paulcurrion
    Member
    Posted 6 years ago #

    Same issue here - as far as I know it's only just broken the rss feed. I've tried deactivating all plug-ins, checked the theme (semiologic), looked at the plug-in (wp-chiclets) - all with no result. Any help would be most appreciated.

  4. jerrywaxler
    Member
    Posted 6 years ago #

    I'm having the same problem. The blog is working fine, but the feed, which used to be working, has now stopped.

    Any help would be greatly appreciated!

    Jerry

  5. Chris_K
    Member
    Posted 6 years ago #

    @jerrywaxler if you're asking about the feed at the site in your profile, it looks fine. If not that site, perhaps a link to it would be helpful.

  6. jerrywaxler
    Member
    Posted 6 years ago #

    Hi HandySolo,

    Thanks so much for getting back to me! Yes, it's the blog in my profile. (and the links are also pasted below). How strange that it works for you. I have two rss links on the page right now and neither of them is giving me a feed.

    When I use the RSS widget in my sidebar, then look at the blog from a visitor's point of view, it gives me this error message.

    "An error has occurred; the feed is probably down. Try again later."

    This problem also occurs in addthis, so as near as I can tell no one is seeing my rss feed. Perhaps I'm typing in the wrong link (although it worked before.)

    The two links I tried, are: (Please break them after you are through with them so I don't get linked back here.)

    http://www.foo.com/blog/wp-rss.php
    http://www.foo.com/blog/wp-rss2.php

    Thanks again. I greatly appreciate knowing that you are taking the time to help me figure this out.

    Jerry

  7. jerrywaxler
    Member
    Posted 6 years ago #

    Good news, bad news. I see the problem with the RSS widget. That was my mistake. Now I realize that's supposed to allow me to add OTHER RSS feeds to my blog, not my own. Doh! So forget that.

    But the problem with the Addthis widget is troubling, because I think it used to work. (Maybe it never did.) I probably need a different Feed button (unless you can see something I'm doing wrong.)

    Thanks,
    Jerry

  8. Chris_K
    Member
    Posted 6 years ago #

    Use the blog/feed address for your feed url instead of blog/wp-rss and it'll give better results.

  9. jerrywaxler
    Member
    Posted 6 years ago #

    Thanks HandySolo. Could you tell me how to find the blog/feed address? I keep mousing around looking for how to find these feed URL's and I can't figure out where to look.

    Jerry

  10. Chris_K
    Member
    Posted 6 years ago #

    Well, at some point I'm assuming you configured the AddThis thingy for your blog. So, next time you configure it, tell it to use
    http://memorywritersnetwork.com/blog/feed
    as your feed URL.

  11. jerrywaxler
    Member
    Posted 6 years ago #

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags