WordPress.org

Ready to get started?Download WordPress

Forums

WP RSS Multi Importer
[resolved] ’ or ' (single quotation not displaying) (28 posts)

  1. Anam
    Member
    Posted 1 year ago #

    Dear Allen,

    Your Plugin is rock. I am totally happy with your plugin. Only a tiny tiny problem need to be fixed. Single quotation (') not working in RSS title and content. instead of showing single quotation ('), The browser showing the following strange symbol (rsquo; ).

    http://www.rsquo.net/ // rsquo or single quotation

    example feed:
    http://lifescientist.com.au/feeds

    Many Thanks,

    Anam

    http://wordpress.org/extend/plugins/wp-rss-multi-importer/

  2. Anam
    Member
    Posted 1 year ago #

    Sorry, Correct feed link is:
    http://lifescientist.com.au/feed.rss

  3. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    go into the excerpt_functions.php file and find the CleanHTML function...then add this line to that function

    $content=str_replace("»", "'", $content);
  4. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    or change that from raquo, to rsquo

  5. Anam
    Member
    Posted 1 year ago #

    Thank You Allen for your reply. I have changed the code in excerpt_functions.php. However, Title still displaying the
    ’

    I have taken a screenshot for you.
    http://tinypic.com/r/345bf3n/6

  6. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Ok. Then are you using shortcode or feed to post?

  7. Anam
    Member
    Posted 1 year ago #

    That's right.

  8. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Which one? Feed to post OR shortcode?

  9. Anam
    Member
    Posted 1 year ago #

    I have used shortcode.

  10. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    ok..then which template is this as the change would need to be made to the template...are you, for example, using the default template?

  11. cocoonfxmedia
    Member
    Posted 1 year ago #

    I can't get the plugin to work again... It will not import into a post.

    http://nmsm.co.uk/category/blog/feed

    It does work on some feeds. I know 123reg screwed up my DNS settings a couple of days ago but its just not working.

  12. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    well, not sure sure what's going on since you can see this is working fine here

    http://www.wprssimporter.com/

    Again, this is the shortcode (so it's not importing into a post - that would be the Feed to Post option)

  13. Anam
    Member
    Posted 1 year ago #

    I am currently using default template. If possible please give code change for the regular template as well.

    Thanks,
    Anam

  14. cocoonfxmedia
    Member
    Posted 1 year ago #

    I am confused... one domain its working the other domain its not.

  15. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    you need to go into the template and where you see this:

    $items["mytitle"]

    change to this

    CleanHTML($items["mytitle"])
  16. cocoonfxmedia
    Member
    Posted 1 year ago #

    default.php in the plugin folder?

  17. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    go into the templates folder, the find the default.php file

  18. cocoonfxmedia
    Member
    Posted 1 year ago #

    which line should it be on as I can see every but mytitle...

  19. Allen
    Member
    Plugin Author

    Posted 1 year ago #

  20. cocoonfxmedia
    Member
    Posted 1 year ago #

    ok got it.. still not working.

  21. Anam
    Member
    Posted 1 year ago #

    Thank you Allen but its not working. I have changed code as you said.

    $items["mytitle"]
    
    change to this
    
    CleanHTML($items["mytitle"])

    Title is still displaying the ’

  22. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    ok...this was tricky...put this somewhere on a line in default.php before where you put the CleanHTML, as here

    http://www.screencast.com/t/q36tU85X4

  23. Anam
    Member
    Posted 1 year ago #

    Fantastic, Working fine. Thank you very much for your help.

    One last question, if want to change the CSS, I mean if i don't want any formatting as my WordPress theme has a css file for that. Only thing i need is a line break <br/> after one item. Which file should i edit?

    Many thanks,

    Anam

  24. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Use template.css if you want to do this via CSS or edit the default.php file. Be sure to save this using the template options tab

  25. Kelli Sussman
    Member
    Posted 1 year ago #

    I am having a similar issue with ' showing instead of a single quote. I have tried the items mentioned above. It's in my widget feed. Any ideas for correcting it? Here is a page that shows this in the sidebar feed: http://50.87.144.103/~volufire/volunteer/

  26. Kelli Sussman
    Member
    Posted 1 year ago #

    I think it converted my & # 0 3 9 ; -- that is what is showing instead of the single quote (minus the spaces since it was converting it here! :).

  27. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Kelli...I'm not seeing the problem...exactly where is in the sidebar feed?

  28. Kelli Sussman
    Member
    Posted 1 year ago #

    Hi Allen - Thanks for responding. I took a screenshot of it and put a link to that screenshot image below. Thank you! It's a very cool plugin to merge all these feeds! http://50.87.144.103/~volufire/images/screenshot-quote.jpg

    It's also in the live feed here:
    http://50.87.144.103/~volufire/volunteer/
    Under the sidebar item:
    Thu, Jun 06, 2013
    Facebook - Forest Grove Fire & Rescue

    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic