WordPress.org

Ready to get started?Download WordPress

Forums

Root Directory /blog/ for WordPress 3.0 main Multisite (22 posts)

  1. stylecollision
    Member
    Posted 3 years ago #

    Hi there,

    i'm playing around with 3.0-beta and installed a main Site and two further ones. The furthers ones are mydomain.com/site1 and mydomain.com/site2 - the main Site ist mydomain.com.

    The problem now is, that all posts (even custom post types) on the main Site have the address mydomain/blog/2010/05/12/post/ or similar. So eacht time we have the leading /blog/ for post-urls.

    I took a look in the WordPress Settings and found, that i couldn't change the permalinks, because the part "/blog" can't be edited.

    Is there any chance to change this? Thanks for an answer.

    Yours

  2. stylecollision
    Member
    Posted 3 years ago #

    Thanks a lot, that points me into the right direction. Unfortunately the merging of WordPress MU and WordPress prevents the plugin you mentioned from working.

    I dropped a comment to the plugin author hoping he will consider helping me out.

  3. Darfuria
    Member
    Posted 3 years ago #

    Has anyone found an update/solution for this? I can't imagine the amount of site owners who wouldn't want /blog/ in their URLs.

  4. Supposedly, this will be addressed in 3.1, but right now there is no workaround.

  5. ulyssesr
    Member
    Posted 3 years ago #

    I'm disappointed to see that there is no workaround for this in terms of removing the /blog slug in WordPress version 3.0. Lots of people like me have an existing blog on the root of my domain. I would like to turn the entire site into a multiblog site with WordPress 3.0. If I enable multisite feature with 3.0, it will break all my permalinks because it will add /blog slug to the original blog. I don't know .htaccess enough, but will a redirect in .htaccess for a link such as example.com/blog/2010/05/30/article to example.com/2010/05/30/article work?

  6. Other way around, really. You want to point your .htaccess to the /blog directory, otherwise it doesn't exist.

    RewriteRule ^([0-9]{4})/([0-9]{2})/([0-9]{2})/(.*)$ http://domain.com/blog/$1/$2/$3/$4 [L,R=301]

    That said, the plugin I linked to above supposedly works with 3.0 RC2, so. Try that instead.

  7. Anna
    Member
    Posted 3 years ago #

    I had this problem earlier.

    I went to Super Admin > Sites > Edit.

    Scroll down to "Permalink Structure" and remove the "/blog" part. That should work.

  8. ulyssesr
    Member
    Posted 3 years ago #

    ohthenoes,

    Thank you! It worked! I didn't know there's a permalink setting under Super Admin > Sites > Edit for each individual blog. This solved my issue with the /blog slug. Thank you once again.

  9. Anna
    Member
    Posted 3 years ago #

    Glad to help :)

  10. Wow. That's awesome! I do wonder if it'll cause nasty conflicts with other things, but that's a great fix.

    Just make REALLY careful not to name any pages /YYYY though. Pages will still always show up as domain.com/pagename.

    Also check your archives (they're normally domain.com/blog/YYYY )

  11. cazm
    Member
    Posted 3 years ago #

    Oh, great, that's sorted my problem out too! Thanks.

  12. Darfuria
    Member
    Posted 3 years ago #

    Excellent solution, well spotted.

  13. nims
    Member
    Posted 3 years ago #

    I hope that doesn't conflict with categories and other subdirectory sites (in case of sub-directory network install).
    Suppose you have a category coolmovies and someone registers a sub directory domain as coolmovies then ?

  14. It does.

    that's why the /blog/ is in there and why removing it can cause conflicts.

    pretty sure it will be addressed in a future version.

  15. bobdebilder
    Member
    Posted 3 years ago #

    ho hum .. the wheel it turns slowly but surely

  16. patrickd88
    Member
    Posted 3 years ago #

    Wished I'd known about this before my install snafu. Although Andrea recommends you not remove the /blog/ slug, so maybe I went the right way. I will be following this discussion.

  17. I'd just redirect my old posts to my new location:
    RewriteRule ^/([0-9]{4})/([0-9]{2})/([0-9]{2})/(.*)$ http://domain.com/blog/$1/$2/$3/$4 [L,R=301]

    Actually, I went to this:
    RewriteRule ^/([0-9]{4})/([0-9]{2})/([0-9]{2})/(.*)$ http://domain.com/blog/$4 [L,R=301]

    So my URLs are now domain.com/blog/postname -- Shorter = better :)

  18. marianTheMartian
    Member
    Posted 3 years ago #

    Great discussion. I've recently removed /blog from my multisite. And so far so good. Just keeping my eyes open for any conflicts. @_@

  19. Jason Paul
    Member
    Posted 2 years ago #

    I've done the same...removed 'blog' from the site admin. I also needed to go into the Config and remove:

    define( 'BLOG_ID_CURRENT_SITE', 1 );

    Now the main blog shows up as the root directory blog which is much more desirable than before.

    Aside from the concerns about category names about If anyone thinks this will cause long-term problems to the site I'm working on please advise!

  20. Just FYI: If you re-save permalinks on blog #1, /blog/ will come back.

Topic Closed

This topic has been closed to new replies.

About this Topic