WordPress.org

Ready to get started?Download WordPress

Forums

Role Scoper
[resolved] Role Scoper Gives Warnings after PHP upgrade (5 posts)

  1. kblanch09
    Member
    Posted 2 years ago #

    Heyy,

    After upgrading PHP to version 5.4.3, I have been getting multiple warnings:

    Warning: Creating default object from empty value in /wp-content/plugins/role-scoper/definitions_cr.php on line 57

    Warning: Creating default object from empty value in /wp-content/plugins/role-scoper/taxonomies_rs.php on line 37

    Warning: Creating default object from empty value in /wp-includes/capabilities.php on line 598

    Warning: Creating default object from empty value in /wp-content/plugins/role-scoper/query-interceptor_rs.php on line 296

    Is this a known issue? Is there a quick fix?

    http://wordpress.org/extend/plugins/role-scoper/

  2. Rulatir
    Member
    Posted 2 years ago #

    I am getting the same warning from capabilities.php (don't have Role Scoper), and in addition I cannot log in. My attempts at debugging seem to indicate that some subtle change in handling of magic methods (__get, __set, __isset etc.) in PHP 5.4.3 broke the WP_User class, so this seems to be a deep problem. I will probably file a ticket on WordPress trac later this night.

  3. twlack
    Member
    Posted 2 years ago #

    Did you figure this out? I have the same problem with Role Scoper. I bought Googlyzer Pro and it requires php5.3 or higher and that screws up Role Scoper which is a big part of my site.

  4. kblanch09
    Member
    Posted 2 years ago #

    No luck yet

  5. kevinB
    Member
    Plugin Author

    Posted 2 years ago #

    PHP 5.4 warnings are fixed in Role Scoper 1.3.56

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic