WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] role manager help (25 posts)

  1. ulisse1
    Member
    Posted 7 years ago #

    i make an error with role manager and now i can't activate plugin. i am administator of the blog.
    what i have to do ?
    thanks

  2. moshu
    Member
    Posted 7 years ago #

    FTP > delete
    and re-upload, activate, don't make errors :)

  3. ulisse1
    Member
    Posted 7 years ago #

    delete what ?
    i'm not expert
    sorry for my english

  4. moshu
    Member
    Posted 7 years ago #

    Delete the plugin.
    What "error" did you make? - you don't need to be an expert, but you need to give details.

  5. ulisse1
    Member
    Posted 7 years ago #

    the role "administrator" haven't the capability "activate plugins"

  6. ulisse1
    Member
    Posted 7 years ago #

    if i delete the plugin with ftp and then i will re-upload the plugin i will not able to activate the new plugin.

  7. moshu
    Member
    Posted 7 years ago #

    1, You should never mess around with the admin's capabilities. That's not "error" - that's crazy!

    2. Can't you just restore that capability to activate plugins? If logged in as admin and going to the Users > Roles page?

  8. ulisse1
    Member
    Posted 7 years ago #

    user>roles does not exist anymore

  9. moshu
    Member
    Posted 7 years ago #

    OK, let's clarify.
    Is the plugin deleted now - yes or no?
    Or is it there and is not activated?

  10. ulisse1
    Member
    Posted 7 years ago #

    the plugin is activated and not deleted

  11. moshu
    Member
    Posted 7 years ago #

    Then why don't you see the "Roles" submenu???

  12. ulisse1
    Member
    Posted 7 years ago #

    i don't see

  13. moshu
    Member
    Posted 7 years ago #

    Man, if you have the plugin uploaded AND activated - you must see it.
    However, if you deleted once and uploaded again... it means it is NOT activated because by deleting you deactivate any plugin.

  14. ulisse1
    Member
    Posted 7 years ago #

    sorry is not active

  15. moshu
    Member
    Posted 7 years ago #

    Do you have phpMyadmin access to your database? If yes, we can try activating it directly from the database and after that you could restore the admin's capability to activate plugins.

  16. ulisse1
    Member
    Posted 7 years ago #

    i have phpmyadmin

  17. moshu
    Member
    Posted 7 years ago #

    OK, then try to follow exactly the steps:
    BEFORE everything else - make a backup of your database, using the "Export" button at the top! when done:

    go to your phpMyadmin and select the line "wp_options" for Browse. (or whatever your prefix is)
    find the line that is called "active plugins" (mine is line #39)
    click on the "pencil" to edit
    depending on your active plugins, you will see a line that looks like this:
    a:15:{i:0;s:35:"adsense-manager/adsense-manager.php";i:1;s:23:"custom-query-string.php";etc...}
    check what is the number after the LAST "i" and add this between the lats [;] and the closing } -
    i:X;s:29:"role-manager/role-manager.php";
    BUT replace the X with the last value for i+1; i.e. if the last i has the values of i:8... make this one i:9, I hope you got it.

  18. ulisse1
    Member
    Posted 7 years ago #

    a:6:{i:0;s:50:"UltimateTagWarrior/ultimate-tag-warrior-legacy.php";...;i:5;s:28:"rolemanager/role-manager.php";}
    what this becames ?

  19. moshu
    Member
    Posted 7 years ago #

    You mean you have it already there? If this is there
    i:5;s:28:"rolemanager/role-manager.php";
    then the plugin should be active! (although I have s:29 for every active role manager...)

  20. ulisse1
    Member
    Posted 7 years ago #

    i can give you the access in my phpmyadmin ?
    i broken my head

  21. moshu
    Member
    Posted 7 years ago #

    email me using my name here AT transycan DOT net
    give access info to the site admin, and to the blog

  22. ulisse1
    Member
    Posted 7 years ago #

    send

  23. moshu
    Member
    Posted 7 years ago #

    Are you sure? to moshu at transycan dot net?

  24. ulisse1
    Member
    Posted 7 years ago #

    i send on [moderated]

  25. moshu
    Member
    Posted 7 years ago #

    OK, I got it, check the reply and let's take this off from the forum.

Topic Closed

This topic has been closed to new replies.

About this Topic