WordPress.org

Ready to get started?Download WordPress

Forums

Only Network Admin can change/save image title on post/pages (6 posts)

  1. elevencars
    Member
    Posted 3 years ago #

    There is a strange role issue going on in WordPress 3.1 installed as multisite.

    - Issue with all roles (also the admin role)
    When uploading images with the editor (on posts or pages) the Title field is not added to the html of the image tag. Also, when editing the an existing image with the editor (on posts or pages) the change to the Title field is not added to the image tag. In both cases (new or existing image), after updating/publishing the post or page, the Title field is empty.

    - Network admin
    This issue does not happen when marked as Network Admin.

    - Media library
    Strangely enough, all the image meta data (title, alt etc) is saved to the database. In the media library the information is visible. This counts for all roles.

    - Conclusion
    According to me there is a strange role issue going on or there is an issue with the TinyMCE editor. It seems to me that the TinyMCE only adds the Title field of images to the html on the page/post when logged in as Netword Admin.

    - Tests
    We have tested this in many ways, also in different browsers and on Mac and Windows and everywhere it's the same issue. So it's not platform/browser specific.

    I'm curious if others can reproduce the issue.

  2. Are you using any TinyMCE plugins?

  3. elevencars
    Member
    Posted 3 years ago #

    No, we are not using any TinyMCE plugins. We also turned off all plugins without any difference.

  4. Do a manual upgrade.

    The TinyMCE version DID change between 3.0 and 3.1, but this is a bit odd, and I've not heard of this one yet.

  5. Bart van Poll
    Member
    Posted 3 years ago #

    I have the same issue!

  6. Same advice. Manual upgrade, turn off all plugins.

Topic Closed

This topic has been closed to new replies.

About this Topic