WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] robot.txt 404 error for multi site directories (12 posts)

  1. brokensite
    Member
    Posted 3 years ago #

    The may be strange but the fact is I have made a multisite with subdirectories which are redirected to subdomains by domain mapping.

    the problem is that for the main site I have a valid robot text showing but the subdirectories (which are pointed to subdomains) do not have robot text (containing information about individual sitmaps)=error 404 for google robots ... what should I do? should I address all subdomain site maps in the same robot text or write individual robot text and redirect 404 to them?

  2. brokensite
    Member
    Posted 3 years ago #

  3. The may be strange but the fact is I have made a multisite with subdirectories which are redirected to subdomains by domain mapping.

    Why? MultiSite can run subdomains.

  4. but the subdirectories (which are pointed to subdomains) do not have robot text (containing information about individual sitmaps)=error 404 for google robots ... what should I do?

    You should forget about the robots.txt file and use a sitemap plugin that works in multisite.

    like http://wordpress.org/extend/plugins/xml-sitemap-feed/

    Why? MultiSite can run subdomains.

    Some people domain map the subdomains on hosts that do not have wildcard subs.

  5. And they won't let you point subdomains, manually generated, to anything BUT public_html/subfolder? Okay, I can see that (though it strikes me as silly).

    You can also use http://wordpress.org/extend/plugins/pc-robotstxt/ to handle per-site robots.txt, but the http://wordpress.org/extend/plugins/xml-sitemap-feed/ should work fine (I don't know if it'll put your links as subfolders or subdirectories in that situation though....)

  6. brokensite
    Member
    Posted 3 years ago #

    Why? MultiSite can run subdomains.

    yeah I know , I started the site with subdirectories and then we have changed strategy but it was so late

  7. brokensite
    Member
    Posted 3 years ago #

    You should forget about the robots.txt file and use a sitemap plugin that works in multisite.

    I have indu=ividual sitemaps for all subdomains , they are all integrated with google webmaster, every subdomain has independent rss feed burner feeds also,

  8. brokensite
    Member
    Posted 3 years ago #

    You can also use http://wordpress.org/extend/plugins/pc-robotstxt/ to handle ....

    thank you , I will try them out, I have worked for hours on this site and now these 404 errors are freaking me out, this is my first multisite,

  9. brokensite
    Member
    Posted 3 years ago #

    Some people domain map the subdomains on hosts that do not have wildcard subs.

    yeah it makes it so much easier , I hope this won't make regret one day since apparently subdirectories are so much different

  10. I have indu=ividual sitemaps for all subdomains , they are all integrated with google webmaster, every subdomain has independent rss feed burner feeds also,

    And?

    , I hope this won't make regret one day since apparently subdirectories are so much different

    No, not really.

  11. Kapeltsov
    Member
    Posted 2 years ago #

    The problem isn't solved.
    I have made a multisite with domain mapping to different domain.
    Part of the domain contains robots.txt and some returns 404.
    What should I do?

  12. Kapeltsov - If a post is resolved and you have a similar problem, make a NEW topic all for yourself, eh?

Topic Closed

This topic has been closed to new replies.

About this Topic