WordPress.org

Ready to get started?Download WordPress

Forums

Robot.txt (11 posts)

  1. vdilorenzo
    Member
    Posted 1 year ago #

    When I google search my website, michelelisasalon.com, instead of getting a description of the site underneath the title, I am getting this message:

    A description for this result is not available because of this site's robots.txt – learn more.

    I use Andrina theme (from inkthemes) - have added meta tags, descriptions and enabled the site the be "searchable" (no privacy settings)

    Can you please me help correct this issue or point me in the direction to fix this?

    Still new to this, so please be kind...Thanks so much.

    Valerie

  2. jibbius
    Member
    Posted 1 year ago #

    What is the address of your site?
    It could be many things.

    Are you allowing search engines to index your site?
    I believe there is a check box under Settings > privacy.

    if you install the Yoast All-in-one SEO plugin, then the plugin performs several checks when you install it. It will often notify you if it finds problems.

  3. vdilorenzo
    Member
    Posted 1 year ago #

    Thank you for the suggestions, Jibbius.

    The address of the site is http://www.michelelisssalon.com

    The search engines are allowed to index the site.

    I installed the Yoast All-in-One as you suggested and it hasn't changed anything.

    When I search the name web name in Google, you will see the link but no title and the sentence about the robot.txt.

    Thanks again.

  4. riversatile
    Member
    Posted 1 year ago #

    In the source code of your home page, there is no Meta tag for "Description".
    This means that Yoast All-in-One is not working or not configured correctly for "Description".

  5. riversatile
    Member
    Posted 1 year ago #

    Also, did you try to use the Google Webmaster Tool ?
    It allows you to manage Google Crawlers indexing and a lot of SEO features.

  6. vdilorenzo
    Member
    Posted 1 year ago #

    Hi and thank you.

    Can you please point me as to where/how I can change the meta tag for description?

    I went into Yoast and did configuration but nothing has changed.

    I have also contacted inkthemes.com and they cannot help me.

    I did not try Google Webmaster Tool. I do not have a gmail account.

    Thanks again.

  7. riversatile
    Member
    Posted 1 year ago #

    Hey !!! The Google results didn't change yet, it's normal (this require a new passage of the Google crawler on your page)
    But it seems your change in YOAST worked !
    Here is now the YOAST informations on your Home page source code :

    <!-- This site is optimized with the Yoast WordPress SEO plugin v1.3.4.1 - http://yoast.com/wordpress/seo/ -->
    <meta name="description" content="Michele Lisa Salon is a Full Service Redken concept salon."/>
    <link rel="canonical" href="http://michelelisasalon.com/" />
    <meta property='og:locale' content='en_US'/>
    <meta property='og:title' content='Michele Lisa Salon'/>
    <meta property='og:description' content='Michele Lisa Salon is a Full Service Redken concept salon.'/>
    <meta property='og:url' content='http://michelelisasalon.com/'/>
    <meta property='og:site_name' content='Michele Lisa Salon'/>
    <meta property='og:type' content='website'/>
    <!-- / Yoast WordPress SEO plugin. -->

    As you can see above, there is a Description and some other usefull information for the most of web crawlers on the web.

    From now, you have just to wait some days for that Google make a new indexation of your Home page. Sure, you can force Google to crawle it as fast as possible by adding your website URL here : http://www.google.com/webmasters/tools/submit-url
    I already done it (2 times in a row) for you ! So you should see a better result in Google Search tomorrow.

    For your information, your correct website URL is :
    http://michelelisasalon.com/
    NOT
    http://www.michelelisasalon.com/

    Regards

  8. vdilorenzo
    Member
    Posted 1 year ago #

    Okay, good news...so it will take a couple days for google to catch up?

    I appreciate your actually helping me and being nice about it...thanks so much!

  9. riversatile
    Member
    Posted 1 year ago #

    Also, to help your WordPress blog to be explored by Google is to use the extension Google XML Sitemaps.
    Once a post is created or modified, WordPress re-generate a XML Sitemap file (sitemap.xml), and Google read this file for the latest post/page to be crawled as soon as possible.

  10. vdilorenzo
    Member
    Posted 1 year ago #

    thanks, i'll check it out.

  11. riversatile
    Member
    Posted 1 year ago #

    But I think YOAST provide an option to use XML Sitemap, check this out !

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags