WordPress.org

Ready to get started?Download WordPress

Forums

WP SlimStat
[resolved] Right Now is not displaying any graph (10 posts)

  1. adiwiyarso
    Member
    Posted 1 year ago #

    Hi Camu,

    I just installed SlimStat. However, the Right Now is not displaying any graph or chart. It only displays: No data to display. I already go to Settings and set the Refresh every 600 second seconds (10 minutes), but still nothing change after several auto-refresh.

    Kindly help me to resolve this situation.

    Thanks,
    ~Adi~

    http://wordpress.org/extend/plugins/wp-slimstat/

  2. quoctan0309
    Member
    Posted 1 year ago #

    I just got the same problem.
    Please fix it, Camu

  3. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi guys, we've got a fix for that. Please feel free to contact me at

    http://www.duechiacchiere.it/contatto

    so that I can send it to you and you can test it.

    Thanks,
    Camu

  4. banglocelt
    Member
    Posted 1 year ago #

    Hi Camu

    Suddenly there is "No data to display" on my SlimStat. I'm sure I'll be recommended to upgrade as my versions are old but nevertheless, is it possible to recover the stats?
    Here is some info about versions:

    wordpress 2.9.1
    phpMyAdmin 3.5.2

    webserver is
    Apache/2
    Database client version: libmysql - 5.5.25a
    PHP extension: mysqli Documentation

    A sample from the Error log of db is

    [Mon Nov 26 03:40:25 2012] [error] [client 209.85.238.139] WordPress database error BIGINT UNSIGNED value is out of range in '(<cache>(unix_timestamp()) - <code>web182-pfw_db</code>.<code>wp_slim_stats</code>.<code>dt</code>)' for query INSERT INTO <code>wp_slim_stats</code> ( <code>searchterms</code>, <code>resource</code>, <code>ip</code>, <code>language</code>, <code>country</code>, <code>dt</code>, <code>browser_id</code> )\r
    [Mon Nov 26 03:40:25 2012] [error] [client 209.85.238.139] \t\t\tSELECT '', '/?feed=rss2', '3512069771', 'xx', 'us', '1353904825', '22'\r
    [Mon Nov 26 03:40:25 2012] [error] [client 209.85.238.139] \t\t\tFROM DUAL\r
    [Mon Nov 26 03:40:25 2012] [error] [client 209.85.238.139] \t\t\tWHERE NOT EXISTS ( SELECT <code>id</code> \r
    [Mon Nov 26 03:40:25 2012] [error] [client 209.85.238.139] \t\t\t\tFROM <code>wp_slim_stats</code>\r
    [Mon Nov 26 03:40:25 2012] [error] [client 209.85.238.139] \t\t\t\tWHERE <code>searchterms</code> = '' AND <code>resource</code> = '/?feed=rss2' AND <code>ip</code> = '3512069771' AND <code>language</code> = 'xx' AND <code>country</code> = 'us' AND (UNIX_TIMESTAMP() - <code>dt</code> < 30) AND <code>browser_id</code> = '22' LIMIT 1 ) made by require, wp, WP->main, do_action_ref_array, call_user_func_array, wp_slimstat->slimtrack
    [Mon Nov 26 03:40:25 2012] [error] [client 209.85.238.139] WordPress database error BIGINT UNSIGNED value is out of range in '(<cache>(unix_timestamp()) - <code>web182-pfw_db</code>.<code>wp_slim_stats</code>.<code>dt</code>)' for query SELECT <code>id</code> \r
    [Mon Nov 26 03:40:25 2012] [error] [client 209.85.238.139] \t\t\t\tFROM <code>wp_slim_stats</code>\r
    [Mon Nov 26 03:40:25 2012] [error] [client 209.85.238.139] \t\t\t\tWHERE <code>searchterms</code> = '' AND <code>resource</code> = '/?feed=rss2' AND <code>ip</code> = '3512069771' AND <code>language</code> = 'xx' AND <code>country</code> = 'us' AND (UNIX_TIMESTAMP() - <code>dt</code> < 30) AND <code>browser_id</code> = '22' LIMIT 1  made by require, wp, WP->main, do_action_ref_array, call_user_func_array, wp_slimstat->slimtrack

    Let me know if you need any more info. Thank you

    Tarik

  5. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there,

    I bet the data is still there, it's just not being visualized properly. You can contact me at the address above to see if we can sort the issue out.

    Send me your db structure, and some more info about what version of wp SlimStat you have installed.

    Best
    Camu

  6. cdx
    Member
    Posted 1 year ago #

    camu

    what would cause an old existing version to suddenly "have no data" like banglocelt's and hang like mine which is 2.8.3? i had no changes to my server. does slimstat access anything outside of my server, such as your site? other users have said 2.8.3 hung so they stopped using it, 2.8.4. didn't fix the problem, and 2.8.5 is having problems so i won't upgrade until i hear from users that it's working fine. can you tell us what exactly you are finding that is causing these issues and if it's external to our servers or is slimstat just messing up its sql db?

    thx

  7. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Users are reporting that 2.8.5 is working fine for them. If you have no data under Right Now, it's because your settings are not properly configured or your server is not allowing the script to track client-side info, such as screen resolution and browser plugins.

    Camu

  8. thescarletfire
    Member
    Posted 1 year ago #

    I also just now noticed that all my graphs are saying No data - blank. Same error as the other poster here above.

    How can I fix this? :( Please help.

    I'm running v2.8.5 on two sites of mine - it's weird, one site is OK the other is blank and not collecting/displaying any data :(

    ?

  9. thescarletfire
    Member
    Posted 1 year ago #

    RIGHT NOW and OVERVIEW are blank - yet it seems VISITORS and CONTENT, etc all are reporting information.

    How can I fix this?

    Thanks!

  10. camu
    Member
    Plugin Author

    Posted 1 year ago #

    What's the URL of your site?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic