WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Rich text editor...gone? (36 posts)

  1. clpo13
    Member
    Posted 7 years ago #

    Recently (just a few days ago), my rich text editor on WP stopped working. Now it's just the basic editor that shows up. As far as I know, I haven't changed any options that might affect this (all the right boxes are checked and so on), so I have no idea why the rich text editor would not show up. This problem shows up in both Firefox 2 and IE7, so it must be something with my copy of WP. A plugin perhaps? Any help would be great because I miss my rich text...

  2. Kafkaesqui

    Posted 7 years ago #

    A plugin perhaps?

    Well, *have* you installed any plugins that might futz with the editor? We have difficulties here on the support forums when it comes to divining that.

    Something to check in your browser is to see if you get any javascript errors related to TinyMCE (that's the 'rich text' editor WordPress uses) when in your post editor.

    Something to do to try and resolve this, assuming it's script file-related, is to delete everything found in wp-includes/js/tinymce/ and do a full reupload of the directory and its subs.

  3. clpo13
    Member
    Posted 7 years ago #

    None of the plugins I've installed recently should affect TinyMCE, but I deactivated them all just in case. No effect there not even when I delete and re-uploaded the TinyMCE directory.

    Anyways, here's a list of the plugins I'm using. Maybe there's something about one of them that I'm not aware of:

    *Akismet
    *Creative Commons Configurator
    *fArc
    *fQuick
    *Improved Include Page
    *Random Quotes
    *Subscribe2
    *Viper's Video Quicktags
    *WordPress Database Backup

  4. bestfoot
    Member
    Posted 7 years ago #

    you know you can select to use the fancy editor or not for each user? go to the bottom of the profile page and be sure rich text editor is in fact ticked. If it is, untick it then save and then retick it on a subsequent save perhaps?

  5. clpo13
    Member
    Posted 7 years ago #

    I tried that, but still nothing.

    But, I have come across some things that may help in figuring out what's going on:

    Today when I was writing a post, I noticed that the FireBug plugin in Firefox was giving me two errors on the Write New Post page. The first error says "invalid flag after regular expression
    tiny_mce_gzip.php... (line 709)" and gives this:

    <b>Warning</b>: file_get_contents(/usr/home/logan/public_html/blog/wp-includes/js/tinymce/plugins/buttonsnap/editor_plugin.js) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: No such file or directory in <b>/

    The second says that TinyMCE is not defined in post.php (line 188).

    Now, I checked and, sure enough, there is no editor_plugin.js file in the buttonsnap directory. Heck, there's not even a buttonsnap directory. Never was. So why is the editor trying to get a file that was never there in the first place?

  6. Kafkaesqui

    Posted 7 years ago #

    >> *Viper's Video Quicktags

    Pretty sure it uses the Buttonsnap js library.

  7. vkaryl
    Member
    Posted 7 years ago #

    There isn't a buttonsnap directory.... it's just buttonsnap.php (one file unless things have changed lately....)

  8. clpo13
    Member
    Posted 7 years ago #

    Hmm, I used the video quick tags plugin for a little while before TinyMCE disappeared. I tried deactivating and even deleting the plugin, but the problem is still there.

  9. clpo13
    Member
    Posted 7 years ago #

    So, any other ideas?

  10. amucklow
    Member
    Posted 7 years ago #

    Hi

    My Rich Text Editor has also stopped working. I've deactivated all plug-ins, and deleted and re-uploaded the TinyMCE directory.

    In the javascript console it says 'TinyMCE not defined' - any thoughts?

    The only thing I've done recently that may have caused this is change the blog files' main directory?

    Thanks

  11. clpo13
    Member
    Posted 7 years ago #

    Oh, hey, I did that too. I don't know if TinyMCE quit working then or not, but I did set the blog URL to mydomain.com where WP is located at mydomain.com/blog.

  12. amucklow
    Member
    Posted 7 years ago #

    I've sorted it. My problem was related to the fact that I had switched wordpress files into my top-level directory from /blog, without first reading this.

    I've transferred the files back into /blog, and set up the blog address in 'Options' to be http://www.strangerpixel.com, while the WP address is http://www.strangerpixel.com/blog. Then I copied the main index.php file back into the top-level directory and amended ./wp-blog-header.php to ./blog/wp-blog-header.php. Now TinyMCE is back in action.

  13. clpo13
    Member
    Posted 7 years ago #

    All right, I upgraded to WP 2.1, which I thought would eliminate the problem (yes, it's still there). But even though the entire wp-includes folder was deleted, I still don't have a visual editor. Is it a database thing? And if so, how could I fix it?

  14. Liski
    Member
    Posted 7 years ago #

    Same problem here :(

  15. dsi0743
    Member
    Posted 7 years ago #

    For me, after upgrading with WP 2.1... it's ok in IE7 but not with Firefox 2.0.0.1... !? Still can't get formatting buttons, and can't get tabs (Visual/Code)

    Very very strange...

  16. clpo13
    Member
    Posted 7 years ago #

    I found a temporary fix for the formatting buttons not showing up in 2.1: turn off the visual editor option in your user profile. That will bring back the basic formatting tags, but still doesn't do anything for the visual editor.

  17. markerjoel
    Member
    Posted 7 years ago #

    I have just fixed mine - in tiny_mce_gzip.php under wp-includes/js/tinymce, find LINE 131.

    blockquoteif ((in_array('gzip', $encodings) || in_array('x-gzip', $encodings) || isset($_SERVER['---------------'])) && function_exists('ob_gzhandler') && !ini_get('zlib.output_compression')) {/blockquote

    You can see the function exists part - which checks if the gzhandler exists and if not then it won't try and use the disk cache. So, if we change the function name ob_gzhandler to ob_gzhandlerX it won't find the function and therefor ob_gzhandler will not be used and therefore not make any problems. The only drawback with this is that it may run a little slower.

    blockquoteif ((in_array('gzip', $encodings) || in_array('x-gzip', $encodings) || isset($_SERVER['---------------'])) && function_exists('ob_gzhandlerX'/*FUNCTION WON'T EXIST*/) && !ini_get('zlib.output_compression')) {/blockquote

  18. markerjoel
    Member
    Posted 7 years ago #

    I have just fixed mine - in tiny_mce_gzip.php under wp-includes/js/tinymce, find LINE 131.

    if ((in_array('gzip', $encodings) || in_array('x-gzip', $encodings) || isset($_SERVER['---------------'])) &&amp; function_exists('ob_gzhandler') &&amp; !ini_get('zlib.output_compression'))

    You can see the function exists part - which checks if the gzhandler exists and if not then it won't try and use the disk cache. So, if we change the function name ob_gzhandler to ob_gzhandlerX it won't find the function and therefor ob_gzhandler will not be used and therefore not make any problems. The only drawback with this is that it may run a little slower.

    if ((in_array('gzip', $encodings) || in_array('x-gzip', $encodings) || isset($_SERVER['---------------'])) &&amp; function_exists('ob_gzhandlerX'/*FUNCTION WON'T EXIST*/) &&amp; !ini_get('zlib.output_compression'))

  19. clpo13
    Member
    Posted 7 years ago #

    I tried doing that, but I'm still missing it. I must have really screwed things over, but I can't imagine where.

  20. waterblossoms
    Member
    Posted 7 years ago #

    I have the same problem. I don't think I did anything to mess it up, it worked fine for several days and then just stopped.

    None of the fixes posted on the support boards have helped me either.

    :(

  21. Mittineague
    Member
    Posted 7 years ago #

    My RTE was gone too. But I just installed the new version of "subscribe2 for WP ver 2.1" and now all seems well again.

  22. designoahu
    Member
    Posted 7 years ago #

    I am having the same issue as well. I tried markerjoel's fix, reinstalling tinymce, and even installing the subscribe 2 plugin. Nothing seems to be working. If someone has solved this please update this post.

  23. Chris_K
    Member
    Posted 7 years ago #

    Just as a word of sanity... in many cases, the upgrade unchecks the option to use the wysiwyg. So, visiting Users -> Your Profile and ensuring the top option is checked is a good starting point.

    Browser caching has also been a common issue. Visit Write Posts and clear your browser's cache (ctrl-F5 for many browsers) will often pop it back up.

  24. babar
    Member
    Posted 7 years ago #

    If you followed a recent post that suggested changing a line in the tiny_mce_config.php to fix the <div> to <p> conversion, then that is probably the cause.

    I changed my tiny_mce_config.php back to the original file and it worked.

  25. designoahu
    Member
    Posted 7 years ago #

    In my case I have checked to make sure that my preferences do in fact use the rich text editor. If I disable the rich text editor I am able to use the regular on just fine. I have also reuploaded the entire wp-admin and wp-include directories deleting the old ones entirely and not just overwriting the files. Also, I disabled all my plugins and CTRL+F5 refreshed the write post post, but I still don't get the tinyMCE. I also tried the patch to the tiny_mce_gzip.php file found here as well as the one found here. The rich text editor was working fine for a few days after I upgraded to 2.1, but seemed to disappear suddenly. The write and code view tabs are not selectable, and I do not see any of the tinyMCE. Here is a screenshot.

  26. designoahu
    Member
    Posted 7 years ago #

    Also, this is occurring in Windows XP FF2 and IE6. Also, other wordpress installs on the same server are not having this issue.

  27. clpo13
    Member
    Posted 7 years ago #

    That's the same thing I get, only I don't even have the tabs (even when the checkbox is selected in my profile).

  28. orcan
    Member
    Posted 7 years ago #

    I encountered the same behavior as described (disappearing rich text editor). I'm using WP v2.1, but the same occurred under 2.0.x. I finally gave up and installed FCK Editor. Not as well integrated into WP (and seems to have minor 2.1 issues), but at least it doesn't change its behavior unexpectedly.

  29. eundas
    Member
    Posted 7 years ago #

    I'm having this problem too. Has somebody found a fix to this? Something I noticed is that I don't only lack the RTE but the option to select it by default is gone as well. I tested my site in both ubuntu 6.10 + Firefox 2.0, and Windows XP SP2 + Internet Explorer 6.0.

  30. wheelyweb
    Member
    Posted 7 years ago #

    Seems like the wordpress people are silent about this but it seems clear that the standard install of tinymce is broken with WP 2.1.

    It worked fine with WP 2, and I noticed it is called differently that it was with 2.0. Could that be the issue. But enough people are having a problem with this that WP shouldd be giving an official reply, no?

Topic Closed

This topic has been closed to new replies.

About this Topic