WordPress.org

Ready to get started?Download WordPress

Forums

Rich Text Editor Problem - 2.1 (25 posts)

  1. faustina
    Member
    Posted 7 years ago #

    I have posted my problem in other threads, but don't want to hijack anything that other people need help with.

    I have tried every solution to get my rich text editor working. When "Enable Rich Text Editor" is checked (in the correct place, users/profile) I see the two tabs. These are not clickable. There is no other options for formatting or anything. I have done the tiny patch said to fix this. I have completely replaced the wp-includes. I have refreshed my cache. I have disabled plugins. I have tried different browsers. I have tried all different combinations of my javascript options in my browser (FF 2.0.0.1). What else can I do? Is this just not fixable for some people?

    Any ideas at all about what I should do?

  2. uzbek
    Member
    Posted 7 years ago #

    I'm experiencing the same problem. Gone through the whole forum, but it looks like people problem limits to fail to check the "use rich text editor" checkbox in their profile.

    But, finally someone who is experiencing the same problem :) I'm not alone :)))

    I've checked the generated page. Text editor javascript has the post/page's content as a variable. So the problem is related to TinyMC.

    For the time being, I'm working with the basic text editor. I guess, will do till there is some kind of fix.

    Goodluck Uzbek.

  3. mozey
    Member
    Posted 7 years ago #

    ME TOO!, i'm having the same issue!, how do we report a bug!?!?

  4. Mantro
    Member
    Posted 7 years ago #

    Same issue here. Also think it's TinyMC. But problem only occurs with IE6. FF2 and IE7 are working fine.

  5. Mantro
    Member
    Posted 7 years ago #

    I just disabled the visual editor in my profile and then everything works fine. Thanks for the tip!
    But would be best if the visual editor works...

  6. contadino
    Member
    Posted 7 years ago #

    I have the same problem, rich text is enabled only when editing comments, and just now I disabled it in the profilewith the effect that now appears the editing bar with all buttons...the bug seems to be there.

  7. eija
    Member
    Posted 7 years ago #

    My friend had this same problem when I updated her blog. The problem was solved when she updated her browser (Firefox) from version 1.x to 2.0.0.2

    I had the latest version of Firefox when updating and there was no problem with anything.

  8. grebulon
    Member
    Posted 7 years ago #

    I have the same problem. It happens only with IE6 on one of my machines. In Firefox is working fine. I have another machine in which TinyMCE is working fine. Very strange.

  9. Andrew Ozz
    WordPress Dev
    Posted 7 years ago #

    Similar problems here... In FF 2.0.0.2 Tiny starts ok but if I hit 'Save and continue editing' Tiny disappears. If I reload the page - it comes back...

    Its even more weird in Opera. Tiny works fine but If I edit a post there, Tiny turns sone html tags to uppercase and the page doesn't validate as xhtml because of that! All HREF, IMG and some others are saved in uppercase in the database...

    (I have all disk cache set to zero in both browsers)

  10. joelion
    Member
    Posted 7 years ago #

    having the exact same problem here on a brand new installation of WP 2.0.3 using FireFox 2.0.0.3. It works in IE7. This is a pretty major problem, and I imagine a large portion of the WordPress community uses FireFox.

    any updates?

  11. rudolf45
    Member
    Posted 7 years ago #

    Why would you have a "brand new" 2.0.3 install when the latest in the 2.0.x series is 2.0.10?

  12. Kurt8
    Member
    Posted 7 years ago #

    I imagine joelion meant 2.1.3 here, but I could be wrong.

    I have been trying to solve the visual editor problems for weeks now. I've tried just about everything put out by the community. Now I'm moving back to 2.0.10 until things are more stable with the 2.1 series.

  13. joelion
    Member
    Posted 7 years ago #

    yeah, i meant 2.1.3 - i just downloaded it yesterday.

    but back to the problem. this is a pretty major problem, and that it hasn't been fixed (or that is was introduced in the first place) is a bit disconcerting to me. I've been using WP since pre-1.5 days and I have seen a good many bugs last WAY too long and "blatenly obvious missing features" remain unimplemented, but this takes the cake. One of the most important aspects of developing a webapp is testing it across all platforms, in this case, all popular browsers. Since WP 2.0, the rich text editor is a key feature for the whole program, and should therefore be garunteed to work in all major browsers. Obviously, Firefox 2 is a major browser, so either 1) the rich text editor was not tested outside of IE, or 2) the problem was/is known, and just simply remained unfixed. Either way, I think it's pretty unacceptable….. (yeah yeah, look at me - complaining about free, open-source software)

    I just installed WP 2.1.3 for a friend/client for a new site, and it's embarassing to have to tell him that he has to use IE to get all the functionality to work correctly.

  14. joelion
    Member
    Posted 7 years ago #

    ok - i take back (nearly) all the bad things I said about WordPress.

    This is (at least in my case) a greasemonkey user script problem. If you are having this problem, disable greasemonkey and see if it goes away. If it does, re-enable GreaseMonkey and start disabling all your user scripts. The one that was causing the problem for me was "Force Wrap", which forces wrapping of long text strings in the browser. You can either disable the script, or you can set it to exclude your wordpress site.

  15. Webigail
    Member
    Posted 7 years ago #

    I'm having the same problem. I upgraded yesterday, made one simple adjustment and then "POOF!" The editor was gone.

    I disabled all plugins; I reinstalled a clean editor; I tried installing the older editor (which happens to work on one of my other sites with no problem); I ultimately had to find a plugin, which does the trick, but I would prefer that the packaged one worked. *sigh*

  16. Andrew Ozz
    WordPress Dev
    Posted 7 years ago #

    If you're using FF with the NoScript plugin, you have to update NoScript...
    http://wordpress.org/support/topic/107146?replies=15

  17. grebulon
    Member
    Posted 7 years ago #

    I have the same problem. It happens only with IE6 on one of my machines. In Firefox is working fine. I have another machine in which TinyMCE is working fine. Very strange.

  18. Psychosmurf
    Member
    Posted 7 years ago #

    Hi,

    I had this same problem and was able to correct it in the most odd way possible. This worked for me:

    Go to options and in the field labeled 'WordPress Address (URL):' make sure that the URL entered in this field has a 'www' in it. I don't know why it works to fix the problem but it does for me on all five of my blogs.

    When I first set up the domains, I had it registered as 'blog.mydomain.com' and was having the www removed if someone typed it in. When I entered the field info above, I put it in as 'http://blog.mydomain.com'. TinyMCE went south. As soon as I allowed 'www.blog.mydomain.com' and entered that URL 'http://www.blog.mydomain.com' into the field above the TinyMCE started working like a champ. If I remove it, the tabs go blank, I lose my formatting buttons and can't edit the code.

    Hope this helps someone because I spent two months trying to figure out what was going on.

  19. siggma
    Member
    Posted 7 years ago #

    I have two issues that seem unrelated, but I think they are related. Thus they are posted here.

    First, I get corrupt output every so often. Usually when logging off or using the editor. I see random code, mostly three boxes, some html and something about atom feeds. The only common element I've see so far is the three boxes just inside a chevron that are considered incorrect characters. If they display as boxes they are probably incorrect for the character coding being used or specified.

    I've tried messing with PHP and searching for bugs but the only php match was corrected back in 2003. (system specs at bottom)

    Second, I suspect the corruption and tiny mce issues are related, possibly to the character encoding specified somewhere?

    Every so often my output gets corrupted in such a way that it doesn't mess up the screen but random garbage appears, usually above the editor window. It seems to be related to something in wordpress, an imporperly coded block perhaps, more than likely something to do with output since the corruption only occurs under wordpress and it's very sporadic, like when certain code gets executed...

    System:
    X86 Server 2003
    -System software-
    IIS 6.0
    PHP 5.2.3
    MySQL 5.027
    -Web scripts-
    Gallery2 2.2
    TNG (Next generation of genealogy)
    Wordpress

    WordPress is the only application that displays corrupt output so it's unlikely there is an issue with the underlying configuration.
    http://www.trbailey.net

  20. skippysandy
    Member
    Posted 7 years ago #

    My rich text editor has completely disappeared...
    http://wordpress.org/support/topic/125938?replies=1
    So I know how you feel. I'm guessing this happened because of some new plugin I tried installing...but I'm not sure. I de-activated all the new plugins, deleted them all, and it still isn't working...*sigh*

  21. siggma
    Member
    Posted 7 years ago #

    Turned out to be windows so I upgraded to fedora and it's now 100 times faster and things work fine. It's some kind of issue with PHP and IIS.

  22. feverinlove
    Member
    Posted 6 years ago #

    happy you solved your problem.

  23. engelmania
    Member
    Posted 6 years ago #

    Using version 2.3, I had the same problem, but was finally able to fix it when I realized that it was a directory permissions problem.

    For some reason my javascript directories where set as 644 and they need to be 755 (at least for me). After changing this, the problem still was not resolved, but at least the choice to use the Visual Editor now appeared in my profile. Then I installed the Tiny Style plugin and everything worked like it was supposed to. Hope that helps.

  24. Veritas777
    Member
    Posted 6 years ago #

    Hi Psychosmurf,

    Your WWW trick SOLVED my problems too! I'm using W2K , IE6...plus some other WP Blogs- and once I checked the other ones- they all had WWW in the address line, while the one giving me the problems didn't... Once I added the WWW it was FIXED!

    THANKS!

  25. rslonik
    Member
    Posted 6 years ago #

    YE! WWW trick solved the problem for me too. Thanks ;)

    Rafael,
    [sig moderated]

Topic Closed

This topic has been closed to new replies.

About this Topic