WordPress.org

Ready to get started?Download WordPress

Forums

Rich Text Editor missing when editing comments (18 posts)

  1. guess18
    Member
    Posted 7 years ago #

    I have upgraded to 2.1 and found that the Rich Text Editor is missing when I moderate comments. Is this a bug or done on purpose? It shows up when I create a new post or page. When I am editing comments it only shows the 'Code' view of the editor and not the visual mode.

    Thanks,

    Mike

  2. guess18
    Member
    Posted 7 years ago #

    Can someone at least confirm that they too do not have the Rich text editor when editing comments. I know this was there on my 2.0 install but not sure if I messed something up during the upgrade or if this is a bug.

  3. Beee
    Member
    Posted 7 years ago #

    by rich you mean wysiwyg ? i'm also missing it.
    as is the post preview button

  4. Beee
    Member
    Posted 7 years ago #

    lol... i found it.. we we're both probably too wasted or so...

    you have to click on use visual editor when writing in your user profile. But it has moved position, that's why I overlooked it.

    then both editors are visible

  5. guess18
    Member
    Posted 7 years ago #

    Thanks Beee, I have just made sure that this is checked and still no dice :( I have tried to change it to unchecked and then change it back and saving in between but nothing seems to work. It's odd that the WYSIWYG shows up when I'm writing a new page or post just not when editing comments. I am also missing the preview of the comment.

  6. SteveMunro2
    Member
    Posted 7 years ago #

    I too have just updated to 2.1 from 2.05 and have exactly the same problem. I get tabs for both editors when I am writing a post, but when I am editing a comment, I only get the code view.

  7. guess18
    Member
    Posted 7 years ago #

    Can anyone tell if this is a config issue or a new change to 2.1 ?

  8. hicinbot
    Member
    Posted 7 years ago #

    I just upgraded from 1.5 to 2.1.2, and I have the same problem. The visual editor works intermittently, maybe one out of twenty times. Looks like a bug to me.

  9. atQuest
    Member
    Posted 7 years ago #

    Same here, i am trying to debug this (or otherwise hack the MCE into giving me the candy).. i sure hope someone beats me to it tho!

  10. Chris_K
    Member
    Posted 7 years ago #

    I've never seen the visual rich editor (tinyMCE) when editing comments. Just posts.

    What makes us believe it should be there?

  11. atQuest
    Member
    Posted 7 years ago #

    It's there on WP 2.0.4
    (in the page: wp-admin/post.php?action=editcomment&comment=100) by default. Did it get removed in later versions? The Code-editor (i believe that's alco TinyMCE) is there on WP 2.1.3, so i assumed the wysiwyg tab can be enabled there too..?

  12. drmike
    Member
    Posted 7 years ago #

    I don't remember it. Are you sure you don't have a plugin in there that makes it come up?

  13. atQuest
    Member
    Posted 7 years ago #

    I'm very sure, i have it here in two separate installs of wordpress, 2.0.4 and 2.0.5... In the 2.0.5. i have only the default WP plugins running.

  14. atQuest
    Member
    Posted 7 years ago #

    It looks like the wysiwyg editor has been removed from "editing comments". can someone confirm this? (Maybe someone can point me to a changelog?)

  15. atQuest
    Member
    Posted 7 years ago #

    anyone?

  16. greenius
    Member
    Posted 6 years ago #

    I found this bug and patch in the wordpress bug tracker at http://trac.wordpress.org/ticket/3449
    with the title

    Disable RTE when editing comments

    and the patch that does this at: http://trac.wordpress.org/changeset/4622

    There is nothing in the bug/patch as to why this was done!

  17. atQuest
    Member
    Posted 6 years ago #

    I think this only disables the editer when you have opera or conqueror...

  18. atQuest
    Member
    Posted 6 years ago #

    I changed the code found in the patch back to pre-patching state. No changes occur on the comments page in the admin.

    I cannot find a decision to remove the WYSYWIG from the edit comments, nor get it back.. pls help.. :S

Topic Closed

This topic has been closed to new replies.

About this Topic