WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Rich Text editor gone.... tried it all(?) to resolve... (16 posts)

  1. Michiel
    Member
    Posted 8 years ago #

    First of all: sorry for the double post (it's also in "how to and troubleshouting, http://wordpress.org/support/topic/80448), getting somewhat desperate about this and thought that I try here too...

    -----------------
    Hi!
    The Rich Text editor is gone from my wordpress installations, it happened "just like that".

    I run:
    - WordPress 2.0.4 on two installations of wordpress

    I tried:
    - IE on WinXP
    - FF on OSX
    - disabling all plug-ins
    - CTRL+F5 in text editor area
    - deleting all the WP files in the root (except WP-CONFIG), WP-Includes, WP-Admin and copy fresh ones to my site. Written over existing plugins.
    - checked the settings in my account and writing options: all have the rich text editor marked.

    Is there anything I missed out, still can try?
    Could this be something that has to be resolved by my hosting provider

    Many thanks for your replies!!!

  2. Ethilien
    Member
    Posted 8 years ago #

    In FF, load the write page and then under 'Tools' open 'Javascript Console', and see if you can find any errors relating to javascript (you'll see a lot of css parse errors, just ignore those). Post any you find, and we'll try and figure out what's wrong from those.

  3. Michiel
    Member
    Posted 8 years ago #

    Hi! Many thanks for your help!!!
    Attacched the output from the javascript console on FF 1.5.0.6 on WIndowsXP. There are some errors related to TinyMC but I wonder how come as they are not modified at all, fresh from WP2.0.4.

    Error: Warning: unrecognized command line flag -installer
    Source File: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsBrowserContentHandler.js
    Line: 520

    Error: Unknown property 'zoom'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css
    Line: 605

    Error: Unknown property '-khtml-opacity'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css
    Line: 980

    Error: Unknown property 'filter'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css
    Line: 981

    Error: Unknown property 'zoom'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 605

    Error: Unknown property '-khtml-opacity'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 980

    Error: Unknown property 'filter'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 981

    Error: Unknown property 'zoom'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 605

    Error: Unknown property '-khtml-opacity'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 980

    Error: Unknown property 'filter'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 981

    Error: unterminated string literal
    Source File: http://www.mysite.com/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20051211
    Line: 32, Column: 145
    Source Code:
    l.replace(new RegExp('<\/(p|div)([^>]*)>', 'g'), "\n</$1$2>\n");html = html.replace(new RegExp('
    ', 'g'), "
    \n");}if (tinyMCE.settings['force_br_nee3

    Error: tinyMCE is not defined
    Source File: http://www.mysite.com/wp-admin/post.php
    Line: 307

    Error: Unknown property 'filter'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/inline-uploading.php?post=-1155373905&action=upload
    Line: 291

  4. yosemite
    Member
    Posted 8 years ago #

    I'd suggest you delete the tinymce/tiny_mce_gzip.php and re-upload it from the WP .zip/.tgz.

  5. Michiel
    Member
    Posted 8 years ago #

    Just tried that and still no luck:-( The java console gives exactly the same error. Could this have something to do with the hosting provider?

  6. filipv
    Member
    Posted 8 years ago #

    i had the same problem and once i overwritten tinymice folder with the fresh downloaded one it now seems to work fine.

    still having problems with ending images to editor..nothing happens ..but thats an issue for a different topic.

    Error: syntax error
    Source File: javascript:void()
    Line: 1, Column: 5
    Source Code:
    void()

  7. Michiel
    Member
    Posted 8 years ago #

    Just tried it, removed the whole wp-includes directory and uploaded from the fresh download: unfortunately the same error again and no signs of the richtext editor:-( what else could I try?

  8. yosemite
    Member
    Posted 8 years ago #

    Go to Users:Your Profile and turn "Use the visual editor when writing" off, save, test. Then turn it back on, save, test.

    Report back what changes, if any, you saw.

  9. Michiel
    Member
    Posted 8 years ago #

    Hi, here is the output from richtext off and on. It seems to go wrong in tiny_mce_gzip.php but... this is the latest version of the file (deleted everything)...

    -----------------
    RICHTEXT OFF:

    Error: Unknown property 'zoom'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 605

    Error: Unknown property '-khtml-opacity'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 980

    Error: Unknown property 'filter'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 981

    Error: Unknown property 'filter'. Declaration dropped.
    Source File: http:/www.mysite.com/wp-admin/inline-uploading.php?post=-1155492601&action=upload
    Line: 291
    ---------------------
    TURNING IT ON:

    Error: Unknown property 'zoom'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 605

    Error: Unknown property '-khtml-opacity'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 980

    Error: Unknown property 'filter'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/wp-admin.css?version=2.0.4
    Line: 981

    Error: unterminated string literal
    Source File: http://www.mysite.com/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20051211
    Line: 32, Column: 145
    Source Code:
    l.replace(new RegExp('<\/(p|div)([^>]*)>', 'g'), "\n</$1$2>\n");html = html.replace(new RegExp('
    ', 'g'), "
    \n");}if (tinyMCE.settings['force_br_nee3

    Error: tinyMCE is not defined
    Source File: http://www.mysite.com/wp-admin/post.php
    Line: 307

    Error: Unknown property 'filter'. Declaration dropped.
    Source File: http://www.mysite.com/wp-admin/inline-uploading.php?post=-1155492666&action=upload
    Line: 291

  10. vkaryl
    Member
    Posted 8 years ago #

    If you haven't yet checked with your host provider, you might just want to ask if they've changed/upgraded something on their end....

  11. yosemite
    Member
    Posted 8 years ago #

    Are you certain you first deleted wp-includes/js/tinymce/ completely and then uploaded it? "Error: unterminated string literal" should only happen if it's corrupt or edited (badly).

    If so, I'd suggest you download fresh install package (unless done already?), check the wp-includes/js/tinymce/tiny_mce_gzip.php file(?) then delete and re-upload.

    Sorry if this is beating a dead horse, you may have already done this procedure, but it's worked for others and I'm at a loss for any other ideas.

    What are you using to upload?

  12. Michiel
    Member
    Posted 8 years ago #

    Hi, Thanks for all your replies!
    @vkaryl: I am going to do that now indeed, just to be sure.
    @Yosemite: yes, I deleted the whole wp-includes directory, created it again and deleted it again. Then uploaded it with WSFTP on XP, have used as well Transmit on OSX. Will still do it through cpanel to see if it helps... This is very weird.

  13. Michiel
    Member
    Posted 8 years ago #

    Just tried the delete/upload with cpanel and no success. Will contact my hosting provider (hosting-unlimited.net) to see if something happened in their end.

  14. Dave Kaufman
    Member
    Posted 7 years ago #

    I was hoping to see a solution...I am having the identical issue. I have many other blogs running older ver. of WP 2.02 for example with tinyMCE working just fine.

    Any solutions?

  15. designoahu
    Member
    Posted 7 years ago #

    I am getting the same issue as well. I recently upgraded to version 2.1 and everything seemed fine for a while, but now I cannot switch between "visual" and "code" view. The entire tinyMCE bar is not displayed. I tried the suggestion of deleting the tinymce folder and then reuploading it, but to no avail. I am receiving the following JS errors:

    Error: tinyMCE.getInstanceById is not a function
    Source File: http://designoahu.com/wp-includes/js/autosave-js.php?ver=20070116
    Line: 99

    Error: unterminated string literal
    Source File: http://designoahu.com/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20061113&theme=advanced&language=&plugins=inlinepopups%2Cautosave%2Cspellchecker%2Cpaste%2Cwordpress&lang=&index=0
    Line: 172, Column: 80
    Source Code:

    ="http://www.w3.org/1999/xhtml"><base href="' + tinyMCE.settings['base_href'] + '" /><title>blank_page</title><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"><script src="/mint/?js" type="text/javascript"></script>

    Error: realTinyMCE is not defined
    Source File: http://designoahu.com/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20061113
    Line: 43

  16. lozeone
    Member
    Posted 7 years ago #

    I was just reading through this because i was getting the same TinyMCE is not defined error.

    After trying what was suggested in this post.
    I turned off each plug in i had, one by one, checking the post page each time. after the last was turned off, it began to work, I turned them all back on, one by one.. and now it looks like its working...

    thats weird, and i dont know why.
    but i hope that helps anyone having a similar problem.

Topic Closed

This topic has been closed to new replies.

About this Topic