WordPress.org

Ready to get started?Download WordPress

Forums

Google Rich Snippets - Reviews
Rich Snippets - Reviews Plugin blocks VideObject markup in Posts! (1 post)

  1. plugins24
    Member
    Posted 1 year ago #

    Hi, I use the Google Rich Snippets - Reviews Plugin by poer to display review microdata. Now I wanted to add this:

    <div itemprop="video" itemscope itemtype="http://schema.org/VideoObject">
    <h2><span itemprop="name">My Great Video</span></h2>
    
    <meta itemprop="duration" content="T17M57S" />
    <meta itemprop="thumbnailURL" content="http://i4.ytimg.com/vi/GCEPWfMTUZQ/mqdefault.jpg" />
    <meta itemprop="embedURL" content="http://www.youtube.com/watch?v=GCEPWfMTUZQ" />
    <meta itemprop="width" content="520" />
    <meta itemprop="height" content="300" />
    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000">
    <param name="movie" value="http://www.mywebsite.com/my-video.swf">
    <param name="quality" value="high">
    <param name="play" value="true">
    <embed src="http://www.youtube.com/watch?v=GCEPWfMTUZQ"type="application/x-shockwave-flash">
    </embed>
    </object>
    
    <p><span itemprop="description">This video was made to illustrate...</span></p>
    </div>

    [Moderator Note: Please post code or markup snippets between backticks or use the code button. Or better still - use the pastebin. As it stands, your code may now have been permanently damaged/corrupted by the forum's parser.]

    To embed a video and set the rich snippet for a video. It seems that the plugin blocks this because every time I save/refresh there is still the video but no microdata!

    Can anybody help?

    http://wordpress.org/extend/plugins/google-rich-snippets-plugin/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic