WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
rewriting https links too (3 posts)

  1. vsrinu26f
    Member
    Posted 1 year ago #

    I have this structure

    public_html
       secure
       blog <- wordpress installed here. http://blog.vengalatech.com
       oiopub <- ad manager. https://secure.vengalatech.com/~xezjqwtr/oiopub/purchase.php

    https settings:
    ssl host: secure.vengalatech.com/~xezjqwtr/blog
    port:
    domain mapping:
    blog.vengalatech.com => secure.vengalatech.com/~xezjqwtr/blog
    secure.vengalatech.com => secure.vengalatech.com
    vengalatech.com => secure.vengalatech.com/~xezjqwtr

    url filters:

    My prema links setting:
    http://blog.vengalatech.com/%category%/%postname%/

    observation :
    1. if url filters is '/' and go to http://blog.vengalatech.com :
    admin panel works great over https.
    ad url's https://secure.vengalatech.com/~xezjqwtr/oiopub/purchase.php are rewritten wrong url as https://secure.vengalatech.com/~xezjqwtr/blog/~xezjqwtr/oiopub/purchase.php

    2. if url filters is '/' and go to https://secure.vengalatech.com/~xezjqwtr/blog/ :
    I see page not found.

    "This is somewhat embarrassing, isn’t it?

    It seems we can’t find what you’re looking for. Perhaps searching can help."

    If I click about page link:
    "404 Not Found

    The server can not find the requested page:

    secure.vengalatech.com/~xezjqwtr/blog/about/ (port 443)

    Please forward this error screen to secure.vengalatech.com's WebMaster."

    Please help me how to put correct settings.

    I also have a question :Can the posts be seen both over http and https or only one method will work.

    Thanks for great plugin. Admin is working over https but could not see posts over https. My webhost is webhostingpad.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. vsrinu26f
    Member
    Posted 1 year ago #

    May be wordpress has limitation

    as it need to find post id from url and there is no place to put https://secure.domain.com/~user/blog along with http://blog.domain.com in wordpress settings.

    I am using wordpress-https, seems to rewrite urls properly but wordpress does not seem to be able to interpret them.

    Admin pages magically works. posts does not work. I can see the site theme in the its embrassing page.

    I have premalinks enabled.
    /%category%/%postname%/

    :'(

  3. vsrinu26f
    Member
    Posted 1 year ago #

    The problem with plugin part is that it also rewrites existing urls without checking if they are already https.
    The plugin is supposed to only rewrite http url's.

    Hope this will be fixed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic