WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Rewrite base takes one argument (12 posts)

  1. natcolley
    Member
    Posted 2 years ago #

    I am trying to set up a testing server on a wamp that matches much as possible my remote site which is on Linux. I've followed the multisite network setup directions as best I could step-by-step, but I've run into exactly the same problem that I had way back in April. Here are the links to those earlier discussions:
    http://wordpress.org/support/topic/rewrite-base?replies=7
    http://wordpress.org/support/topic/321-broke-adding-of-sites-on-multiple-sites-anyone-else?replies=4

    The error message I'm working with is

    [Sun Aug 28 21:32:25 2011] [alert] [client 127.0.0.1] C:/Apache2/htdocs/Semantic Law/.htaccess: RewriteBase takes one argument, the base URL of the per-directory context, referer: http://localhost/Semantic%20Law/wp-admin/network.php

    I don't really know what this means but I infer that it's telling me there should be only one “argument” but that there is some ambiguity which is causing the whole thing to stop and report a 500 internal server error. If there is more than one base how and where would I fix that?

    What I'm asking for is someone to help me interpret this error message in plain English and then suggests some ways to get my testing server up and running. Thank you.

  2. natcolley
    Member
    Posted 2 years ago #

    I changed the name of the folder to take out the space, adjusted the url accordingly, but now I just get 500 errors. Is this progress or should I start over (or give up)?

  3. Make a new sub site called test. WHat happens to it?

  4. natcolley
    Member
    Posted 2 years ago #

    semanticlaw/test
    semanticlaw/test/
    semanticlaw/test/index.php

    all 500 internal server error

  5. Then it's your local setup. mod_rewrite is not enabled.

  6. natcolley
    Member
    Posted 2 years ago #

    #LoadModule reqtimeout_module modules/mod_reqtimeout.so
    LoadModule rewrite_module modules/mod_rewrite.so
    LoadModule setenvif_module modules/mod_setenvif.so
    #LoadModule speling_module modules/mod_speling.so

    mod_rewrite is enabled as far as I know. But I don't see an htaccess file in the Apache folder.

    If your webserver's URLs are not directly related to physical file paths, you will need to use RewriteBase in every .htaccess file where you want to use RewriteRule directives.

    from

    Ok, so I think what this is telling me is I need an htaccess with a rewrite rule telling the server to look in localhost/Semantic%20Law.net and not C:/apache. Does that seem reasonable to you? If so, I'm still not 100% on how to do it. Can you tell me how to do that?

  7. localhost/Semantic%20Law.net

    That still needs to be localhost/Semantic_Law.net or something OTHER than a space. It'll just fox things up good.

    What WAMP stack are you using? Is it an all-in-one package like MAMP or ... what directions did you follow?

  8. htaccess files for WORPRESS go in the folder where the installation is.

    It was in the create a network instructions.

  9. natcolley
    Member
    Posted 2 years ago #

    First, thanks to both of you for your interest.

    Andrea
    - in order to deal with this issue, I was referencing an htaccess for apache.

    Ipstenu
    - I am not using a stack. The backstory there is even more long and convoluted, but that part works now so far as I can tell. This problem only comes up when I try to log back in after creating a network per the instructions.

    Do you think I'd be better off starting over with a new install and naming it something without spaces, or slogging this out for what I will learn?

  10. I'd start over if there's nothing to lose. I mean, now you know never to make a website with a space in the domain/folder ;)

  11. natcolley
    Member
    Posted 2 years ago #

    It seems to work fine now. Thx for your patient assistance.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.